<!DOCTYPE html>
<!--[if IE 8]><html class="ie8"><![endif]-->
<!--[if IE 9]><html class="ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1">
<title>Love and Harmony Diary: Caribbean Cultural Cruise - Jamaicans.com</title>
<!--[if lt IE 9]>
	<script src="http://jamaicans.com/wp-content/themes/voice/js/html5.js"></script>
<![endif]-->

<script type="c0672d000a142b37ecb9e033-text/javascript">
if(document.location.protocol=='http:'){
 var Tynt=Tynt||[];Tynt.push('abWrx44JCr4z2Wacwqm_6r');
 (function(){var s=document.createElement('script');s.async="async";s.type="text/javascript";s.src='http://tcr.tynt.com/ti.js';var h=document.getElementsByTagName('script')[0];h.parentNode.insertBefore(s,h);})();
}
</script>

<title>Love and Harmony Diary: Caribbean Cultural Cruise - Jamaicans.com</title>

<script type="c0672d000a142b37ecb9e033-">
			!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
			n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
			document,'script','https://connect.facebook.net/en_US/fbevents.js');
			fbq('init', '1055480241142713' );			fbq('track', 'PageView');
			
			</script>
<noscript><img height="1" width="1" style="display:none"
			src="https://www.facebook.com/tr?id=1055480241142713&ev=PageView&noscript=1"
			/></noscript>



<meta name="description" content="When I requested the assignment to cover Beres Hammond &quot;Love and Harmony&quot; cruise, I anticipated having a good time. My expectations were greatly exceeded." />
<link rel="canonical" href="http://jamaicans.com/love-and-harmony-cruise-diary/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Love and Harmony Diary: Caribbean Cultural Cruise - Jamaicans.com" />
<meta property="og:description" content="When I requested the assignment to cover Beres Hammond &quot;Love and Harmony&quot; cruise, I anticipated having a good time. My expectations were greatly exceeded." />
<meta property="og:url" content="http://jamaicans.com/love-and-harmony-cruise-diary/" />
<meta property="og:site_name" content="Jamaicans.com" />
<meta property="article:tag" content="Beres Hamm" />
<meta property="article:tag" content="Love and Harmony Cruise" />
<meta property="article:section" content="General" />
<meta property="article:published_time" content="2018-07-06T15:00:23-04:00" />
<meta property="article:modified_time" content="2018-07-06T12:02:55-04:00" />
<meta property="og:updated_time" content="2018-07-06T12:02:55-04:00" />
<meta property="og:image" content="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="600" />
<meta property="og:image:alt" content="Beres Hammond Love and Harmony Cruise 2018" />

<link rel='dns-prefetch' href='//static.mailerlite.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Feed" href="http://jamaicans.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Comments Feed" href="http://jamaicans.com/comments/feed/" />
<script type="c0672d000a142b37ecb9e033-text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/jamaicans.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=f9dfde8fde9d0f65cf47c424dc1c938f"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='http://jamaicans.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='mailerlite_forms.css-css' href='http://jamaicans.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/css/mailerlite_forms.css?ver=1.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='wpProQuiz_front_style-css' href='http://jamaicans.com/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all' />
<link rel='stylesheet' id='vce_font_0-css' href='http://fonts.googleapis.com/css?family=Open+Sans%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.7' type='text/css' media='screen' />
<link rel='stylesheet' id='vce_font_1-css' href='http://fonts.googleapis.com/css?family=Roboto+Slab%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.7' type='text/css' media='screen' />
<link rel='stylesheet' id='vce_font_2-css' href='http://fonts.googleapis.com/css?family=Oswald%3A400&#038;subset=latin&#038;ver=2.7' type='text/css' media='screen' />
<link rel='stylesheet' id='vce_style-css' href='http://jamaicans.com/wp-content/themes/voice/css/min.css?ver=2.7' type='text/css' media='screen, print' />
<style id='vce_style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='vce_child_load_scripts-css' href='http://jamaicans.com/wp-content/themes/voice-child/style.css?ver=2.7' type='text/css' media='screen' />
<link rel='stylesheet' id='meks-ads-widget-css' href='http://jamaicans.com/wp-content/plugins/meks-easy-ads-widget/css/style.css?ver=2.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='meks-author-widget-css' href='http://jamaicans.com/wp-content/plugins/meks-smart-author-widget/css/style.css?ver=1.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='meks-social-widget-css' href='http://jamaicans.com/wp-content/plugins/meks-smart-social-widget/css/style.css?ver=1.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css' href='http://jamaicans.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=f9dfde8fde9d0f65cf47c424dc1c938f' type='text/css' media='all' />
<script type="c0672d000a142b37ecb9e033-text/javascript" src='http://jamaicans.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type="c0672d000a142b37ecb9e033-text/javascript" src='http://jamaicans.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type="c0672d000a142b37ecb9e033-text/javascript" src='https://static.mailerlite.com/js/jquery.validate.min.js?ver=f9dfde8fde9d0f65cf47c424dc1c938f'></script>
<link rel='https://api.w.org/' href='http://jamaicans.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://jamaicans.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://jamaicans.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='http://jamaicans.com/?p=118483' />
<link rel="alternate" type="application/json+oembed" href="http://jamaicans.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fjamaicans.com%2Flove-and-harmony-cruise-diary%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://jamaicans.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fjamaicans.com%2Flove-and-harmony-cruise-diary%2F&#038;format=xml" />
<meta name="thumbnail" content="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3-150x150.jpg" />
<script type="c0672d000a142b37ecb9e033-">
(function(m,a,i,l,e,r){ m['MailerLiteObject']=e;function f(){
var c={ a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?v'+(~~(new Date().getTime()/1000000));
_.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');
</script>
 
<script type="c0672d000a142b37ecb9e033-">
        (function(m,a,i,l,e,r){m['MailerLiteObject']=e;function f(){
        var c={a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
        f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
        var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?'+(~~(new Date().getTime()/10000000));
        _.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

        var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');
    </script>

<link rel="shortcut icon" href="http://jamaicans.com/wp-content/uploads/2015/08/JA-favicon.png" type="image/x-icon" /><style type="text/css">div.sumome-share-client-wrapper.sumome-share-client-wrapper-left-page.sumome-share-client-counts.sumome-share-client-light.sumome-share-client-medium {top: 45%;} .page-id-207 #breadcrumbs {display: none;} .nav-menu .vce-mega-menu .sub-menu .sub-menu li, .nav-menu .vce-mega-menu .sub-menu a {line-height: 1.2em !important;} .main-navigation a {font-size: 19px; padding: 15px 21px 15px;} .vce-slider-pagination .owl-controls {background:#3b3b3a;} .vce-post {box-shadow: 0 1px 3px 0 rgba(0,0,0,0);} .main-navigation a {line-height: 39px; font-size: 18px; padding: 15px 10px 15px;} .main-box-title {border-top-width: 10px !important;} /* .main-header {background-color:#f3d45b;} .site-footer {background: url(http://jamaicans.com/wp-content/uploads/2015/02/footer-2.jpg) 0px 0px no-repeat;} */ .dp_pec_monthly.light, .dp_pec_weekly.light, .dp_pec_daily.light {margin:0 auto;} .vce-wrap-left {width: 65%;} .vce-wrap-right {width: 35%;} .header-sticky {height: 74px;} .header-sticky .site-title img {max-height: 69px;} li.feed-item {list-style: none; font-size: .9em;} li.feed-item a {font-size: 1.1em; font-weight: bold;} #rss-3 li a {font-size: 1.1em; color: #55ad4c;} #breadcrumbs {margin: 10px 0px; padding: 10px 20px; color: #393939; opacity: .8; background: #fff; border-left: #393939 solid 5px;} #breadcrumbs span {padding: 0px 5px;} #breadcrumbs a {font-size: .8em; color: #393939;} .breadcrumb_last {font-size: .9em; color:#55ad4c;} #mailerlite_widget-2 {background:rgba(243, 212, 91, 0.48);}</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2520621-1" type="c0672d000a142b37ecb9e033-"></script>
<script type="c0672d000a142b37ecb9e033-">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2520621-1');
</script>

<div class="wrapper-outer">
<div style="display:none;height:0;width:0;">
<script type="c0672d000a142b37ecb9e033-text/javascript" src="http://widgets.amung.us/small.js"></script>
<script type="c0672d000a142b37ecb9e033-text/javascript">WAU_small('jamaicans')</script>
</div>
</head>
<body class="post-template-default single single-post postid-118483 single-format-standard chrome vce-sid-right">
<div id="vce-main">
<header id="header" class="main-header">
<div class="top-header">
<div class="container">
<div class="vce-wrap-right">
<div class="menu-social-menu-container"><ul id="vce_social_menu" class="soc-nav-menu"><li id="menu-item-8" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8"><a href="http://www.facebook.com/pages/Jamaicanscom/128078147433"><span class="vce-social-name">Facebook</span></a></li>
<li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9"><a href="http://twitter.com/jamaicansdotcom"><span class="vce-social-name">Twitter</span></a></li>
<li id="menu-item-10" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10"><a href="http://google.com/+Jamaicans"><span class="vce-social-name">Google Plus</span></a></li>
<li id="menu-item-13" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13"><a href="http://instagram.com/jamaicans_com"><span class="vce-social-name">Instagram</span></a></li>
<li id="menu-item-76974" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76974"><a href="https://www.youtube.com/user/outofmanyonline"><span class="vce-social-name">YouTube</span></a></li>
<li id="menu-item-76975" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76975"><a href="https://www.pinterest.com/jamaicans/"><span class="vce-social-name">Pinterest</span></a></li>
<li id="menu-item-76976" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76976"><a href="http://jamaicansdotcom.tumblr.com/"><span class="vce-social-name">Tumblr</span></a></li>
</ul></div> </div>
</div>
</div><div class="container header-2-wrapper header-main-area">
<div class="vce-res-nav">
<a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a>
</div>
<div class="site-branding">
<span class="site-title">
<a href="http://jamaicans.com/" title="Jamaicans.com" class="has-logo"><img src="http://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png" alt="Jamaicans.com" /></a>
</span>
</div>
<div class="vce-header-ads">

<script type="c0672d000a142b37ecb9e033-text/javascript">// <![CDATA[
google_ad_client = "pub-1901173274277249"; google_alternate_ad_url = "http://www.jamaicans.com/images/ads/google_728X90.htm"; google_ad_width = 728; google_ad_height = 90; google_ad_format = "728x90_as"; google_ad_type = "text_image"; google_ad_channel = ""; google_color_border = "798DC2"; google_color_bg = "FFFFFF"; google_color_link = "5870AE"; google_color_text = "676768"; google_color_url = "2C2F4B";
// ]]></script>
<script src="http://pagead2.googlesyndication.com/pagead/show_ads.js" type="c0672d000a142b37ecb9e033-text/javascript"></script>
 </div>
</div>
<div class="header-bottom-wrapper header-left-nav">
<div class="container">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-79827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79827 vce-cat-40"><a href="http://jamaicans.com/jamaica/culture-jamaica/">Culture</a><li id="menu-item-61427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61427"><a href="http://jamaicans.com/travel-jamaica/">Travel</a><li id="menu-item-83497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83497"><a href="http://jamaicans.com/recipes/">Food</a><li id="menu-item-77663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77663"><a href="http://jamaicans.com/speak-jamaican/">Speak JA</a><li id="menu-item-79829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79829 vce-cat-265"><a href="http://jamaicans.com/jamaica/jamaican-music/">Music</a><li id="menu-item-118280" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-118280"><a href="#">Photos + Videos</a>
<ul class="sub-menu">
<li id="menu-item-118279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118279"><a href="http://jamaicans.com/photogallery/">Photos</a> <li id="menu-item-118281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118281"><a href="http://jamaicans.com/videos/%20">Videos</a></ul>
<li id="menu-item-79826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79826 vce-cat-276"><a href="http://jamaicans.com/jamaica/jamaica-magazine/">JA Mag</a><li id="menu-item-79856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79856 vce-cat-267"><a href="http://jamaicans.com/jamaica/news-announcements/">News</a><li id="menu-item-61425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61425"><a href="http://jamaicans.com/jamaican-information/">Research JA</a><li class="search-header-wrap"><a class="search_header" href="javascript:void(0)"><i class="fa fa-search"></i></a><ul class="search-header-form-ul"><li><form class="search-header-form" action="http://jamaicans.com/" method="get">
<script src="https://ajax.cloudflare.com/cdn-cgi/scripts/4f936b58/cloudflare-static/rocket-loader.min.js" data-cf-nonce="c0672d000a142b37ecb9e033-"></script><input name="s" class="search-input" size="20" type="text" value="Type here to search..." onfocus="(this.value == 'Type here to search...') && (this.value = '')" onblur="(this.value == '') && (this.value = 'Type here to search...')" placeholder="Type here to search..." /></form></li></ul></li></ul></nav> </div>
</div></header>
<div id="main-wrapper">
<div id="content" class="container site-content">
<div id=“breadcrumbs”>
</div>
<div id="primary" class="vce-main-content">
<main id="main" class="main-box main-box-single">
<article id="post-118483" class="vce-single post-118483 post type-post status-publish format-standard has-post-thumbnail hentry category-general tag-beres-hamm tag-love-and-harmony-cruise">
<header class="entry-header">
<span class="meta-category"><a href="http://jamaicans.com/jamaica/general/" class="category-1">General</a></span>
<h1 class="entry-title">Love and Harmony Diary: Caribbean Cultural Cruise</h1>
<div class="entry-meta"><div class="meta-item date"><span class="updated">1 hour ago</span></div><div class="meta-item author"><span class="vcard author"><span class="fn">by <a href="http://jamaicans.com/author/stanevansmith/">Stan Evan Smith</a></span></span></div></div>
</header>
<div class="meta-image">
<img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3.jpg" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="Beres Hammond Love and Harmony Cruise 2018" srcset="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3.jpg 800w, http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" />
</div>
<div class="entry-content">
<div class="at-above-post addthis_tool" data-url="http://jamaicans.com/love-and-harmony-cruise-diary/"></div><p>When I requested the assignment to cover Beres Hammond Love and Harmony <a href="https://loveandharmonycruise.com/">cruise</a>, I anticipated having a good time. My expectations were greatly exceeded.<br />
The Love and Harmony cruise was a One &#8211; Love Caribbean cultural experience full of fun. The six-day five nights Caribbean cruise left Fort Lauderdale, Florida to Montego Bay Jamaica, on to George Town, Grand Cayman then back to Florida. What made the &#8220;Love and Harmony cruise &#8221; special were the nonstop activities on board and, at sea. There were three nights of Reggae, Dancehall and Soca live concerts performances, the theme parties, sound systems DJ showcases, Domino tournaments, and two nights of Caribbean comedy.</p>
<p>The menu offerings were a fine mix Jamaican cuisine courtesy of New York Restaurant, the Door, and continental American cuisine. Some of the menu delectable offerings were Ital Stew, Bun and Cheese, Jerk Chicken, <a href="http://jamaicans.com/jerkpork/">Jerk Pork</a>, <a href="http://jamaicans.com/miss-gs-simple-jamaican-stew-peas-recipe/">Stew peas</a>, <a href="http://jamaicans.com/oxtail/">Oxtail</a>, <a href="http://jamaicans.com/miss-gs-simple-jamaican-escovitch-fish-recipe/">Escovitch Fish</a>, <a href="http://jamaicans.com/currygo/">Curry Goat</a>, <a href="http://jamaicans.com/currychi/">Curry Chicken</a>, <a href="http://jamaicans.com/cporridge/">Cornmeal Porridge</a>, Liver &amp; Banana,<a href="http://jamaicans.com/ackeesaltfishpatty/"> Ackee and Saltfish</a> w/fried or <a href="http://jamaicans.com/dumpling/">boiled Dumpling</a>, Yellow Yam &amp; Banana and banana porridge and an assortment of desserts.</p>
<div id='gallery-1' class='vce-gallery gallery galleryid-118483 gallery-columns-3 gallery-size-vce-lay-b'><div class="vce-gallery-big"><div class="big-gallery-item item-0">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Style-and-Fashion-at-the-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Style-and-Fashion-at-the-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Style-and-Fashion-at-the-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Style-and-Fashion-at-the-Love-and-Harmony-Cruise-2018-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Style-and-Fashion-at-the-Love-and-Harmony-Cruise-2018-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-1" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Stan-at-the-Caymans-Turtle-Center-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="547" src="http://jamaicans.com/wp-content/uploads/Stan-at-the-Caymans-Turtle-Center-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Stan-at-the-Caymans-Turtle-Center-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Stan-at-the-Caymans-Turtle-Center-Love-and-Harmony-Cruise-2018-300x205.jpg 300w, http://jamaicans.com/wp-content/uploads/Stan-at-the-Caymans-Turtle-Center-Love-and-Harmony-Cruise-2018-768x525.jpg 768w, http://jamaicans.com/wp-content/uploads/Stan-at-the-Caymans-Turtle-Center-Love-and-Harmony-Cruise-2018-145x100.jpg 145w, http://jamaicans.com/wp-content/uploads/Stan-at-the-Caymans-Turtle-Center-Love-and-Harmony-Cruise-2018-380x260.jpg 380w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-2" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Singer-Alaine-and-Stan-Smith-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Singer-Alaine-and-Stan-Smith-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Singer-Alaine-and-Stan-Smith-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Singer-Alaine-and-Stan-Smith-Love-and-Harmony-Cruise-2018-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Singer-Alaine-and-Stan-Smith-Love-and-Harmony-Cruise-2018-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-3" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Sanchez-on-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Sanchez-on-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Sanchez-on-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Sanchez-on-Love-and-Harmony-Cruise-2018-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Sanchez-on-Love-and-Harmony-Cruise-2018-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-4" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Marcia-Griffiths-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Marcia-Griffiths-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Marcia-Griffiths-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Marcia-Griffiths-Love-and-Harmony-Cruise-2018-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Marcia-Griffiths-Love-and-Harmony-Cruise-2018-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-5" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div></div><div class="vce-gallery-slider" data-columns="3"><figure class='gallery-item' data-item='0'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Style-and-Fashion-at-the-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Style-and-Fashion-at-the-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='1'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Stan-at-the-Caymans-Turtle-Center-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Stan-at-the-Caymans-Turtle-Center-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='2'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Singer-Alaine-and-Stan-Smith-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Singer-Alaine-and-Stan-Smith-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='3'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Sanchez-on-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Sanchez-on-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='4'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Marcia-Griffiths-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Marcia-Griffiths-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='5'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure></div></div>
<p><strong>Day 1</strong><br />
The festivities and activities were nonstop. They began with the Welcome on Board party during boarding from 11: am to 3: pm. The Celebrity cruise liner departed Fort Lauderdale at 4: pm amid the emergency drill. Cruisers, then moved to the Poolside Sailway party, featuring New York&#8217;s Hot 97 Massive B with Bobby Konders and Jabba on the high seas. There was something for everybody. The players tested their fortunes at Casino Open House, while others sampled complimentary Rum Punch for Players. The Build Your Bar offered complimentary liquor tasting, while free health assessments were conducted by Dr Raj. Others cruiser visited Rooftop Terrace 12 to enjoy the action comedy &#8220;Crocodile Dundee.&#8221;</p>
<p>The evening activities began in earnest at nightfall. With romance in the air, the single men and women made their way to Rendezvous 4 for the Singles and Solo Meet and Greet to get their groove on. At 8:00 pm the Celebrity Theater came alive with standup comedy. Comedian, actress, and writer Gina Brillion, a Comedy Central Alumni, well time witty brand of Nuyorican comedy had the audience in stitches.<br />
By 10: pm we had two choices, a movie on Rooftop Terrace 12 or dance the night into the morning to the music of Road International, Glamour Wayne, Ricky Platinum and DJ Excitement at the Sweet Dreams Pajama party. My date and I chose Pajama party. Many others did as well, the house was packed.</p>
<div id='gallery-2' class='vce-gallery gallery galleryid-118483 gallery-columns-3 gallery-size-vce-lay-b'><div class="vce-gallery-big"><div class="big-gallery-item item-0">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Relaxing.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Relaxing.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Relaxing.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Relaxing-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Relaxing-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-1" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-On-deck.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-On-deck.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-On-deck.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-On-deck-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-On-deck-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-2" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Nicole-and-Sandra-NYC-Ladies.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Nicole-and-Sandra-NYC-Ladies.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Nicole-and-Sandra-NYC-Ladies.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Nicole-and-Sandra-NYC-Ladies-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Nicole-and-Sandra-NYC-Ladies-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-3" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mr-Vegas.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mr-Vegas.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mr-Vegas.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mr-Vegas-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mr-Vegas-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-4" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mama-Alma.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mama-Alma.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mama-Alma.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mama-Alma-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mama-Alma-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-5" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Jamaican-Singer-Alaine.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Jamaican-Singer-Alaine.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Jamaican-Singer-Alaine.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Jamaican-Singer-Alaine-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Jamaican-Singer-Alaine-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div></div><div class="vce-gallery-slider" data-columns="3"><figure class='gallery-item' data-item='0'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Relaxing.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Relaxing-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='1'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-On-deck.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-On-deck-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='2'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Nicole-and-Sandra-NYC-Ladies.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Nicole-and-Sandra-NYC-Ladies-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='3'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mr-Vegas.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mr-Vegas-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='4'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mama-Alma.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Mama-Alma-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='5'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Jamaican-Singer-Alaine.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Jamaican-Singer-Alaine-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure></div></div>
<p><strong>Day 2</strong><br />
On route to Montego Bay, Jamaica my breakfast treat was Ackee and Saltfish with boiled Dumpling, Yellow Yam and Banana and Cornmeal porridge. My date spent the morning in the gym then had continental breakfast. The cruisers spent the morning pampering themselves in fitness and Zumba classes, engaged in the complimentary wine tasting of Mimosas and Bloody Mary&#8217;s, gym workout session with trainers, acupuncture, and rest and chillaxing in Jacuzzis. For the health conscious, they attended Life enhancement seminars on detox and weight loss. Others watched movies, then we all went poolside to feast and dance at the Jerk chicken pool party and participated in the Domino Tournament hosted by DJ Roy from Road International.</p>
<p>Sunday evening the Celebrity Theatre on deck 5 was the place to be. The comedy showcase featuring YouTube sensation Major Hype, the man with many Caribbean accents&#8221; and Jamaican comedy duo Ity and Fancy Cat was the buzz on the ship all day. Hosted by the tambourine man, Kingsley &#8216;Raggashanti&#8217; Stewart Ph.D., the stand-up comedy routine was worth the wait. Openers Ity and Fancy Cat ripped the place. Their tightly scripted, well timed comedic- skits, were delivered with intense high energy.<br />
Beres Hammond joined the audiences for the comedy set. At intervals, he gave several thumbs up approval to self-deprecating jokes about his songs. The most memorable line was Ity&#8217;s who called out Beres for lies in his song ‘Full Attention.’ “Beres … (I know) you nah stand in the middle of the road make no car run over him fi get nuh woman full attention. Yu too lie&#8221;</p>
<p>Major Hype&#8217;s comedic flow and timing were delivered in typical Caribbean laid-back fashion. From a sanitized version of Mitzie and the Rass, he was funny and well received by the standing room only audience.</p>
<p>The poolside Soca concert at International (Caribbean) Flag Night closed the evening. Caribbean America was in full effect. They waved the flags and ‘wine’ and Get on Bad to Soca music’s biggest stars. Kevin Lyttle asked them to stop ‘Drive Me Crazy’ and ‘Turn Me On’ the come ‘Dance with Me.’ Patrice Roberts&#8217; made things ‘Sweet Fuh Days as Rupee was ‘Tempted 2 Touch.&#8217; The after party closed flag night on deck 12.</p>
<div id='gallery-3' class='vce-gallery gallery galleryid-118483 gallery-columns-3 gallery-size-vce-lay-b'><div class="vce-gallery-big"><div class="big-gallery-item item-0">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-hanging-on-deck.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-hanging-on-deck.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-hanging-on-deck.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-hanging-on-deck-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-hanging-on-deck-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-1" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Devils-hangout.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Devils-hangout.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Devils-hangout.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Devils-hangout-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Devils-hangout-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-2" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Deck.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Deck.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Deck.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Deck-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Deck-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-3" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Chaaka-Demus-and-Pliers.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Chaaka-Demus-and-Pliers.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Chaaka-Demus-and-Pliers.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Chaaka-Demus-and-Pliers-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Chaaka-Demus-and-Pliers-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-4" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Cabin.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Cabin.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Cabin.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Cabin-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Cabin-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-5" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div></div><div class="vce-gallery-slider" data-columns="3"><figure class='gallery-item' data-item='0'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-hanging-on-deck.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-hanging-on-deck-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='1'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Devils-hangout.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Devils-hangout-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='2'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Deck.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Deck-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='3'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Chaaka-Demus-and-Pliers.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Chaaka-Demus-and-Pliers-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='4'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Cabin.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Cabin-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='5'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
 </div></figure></div></div>
<p><strong>Day 3</strong><br />
We docked at Montego Bay pier at 9:45 am, After five hours of sight-seeing, shopping and a swimming at Doctors Cave we boarded for the Mo-Bay Concert Pool Party. Singer/DJ duo, Chaka Demus and Pliers, got the music vibes rolling. With a medley of their hits, including ‘I want to be your man&#8217; ‘Murder She Wrote&#8217; ‘Workie Workie /Young Gal Business&#8217;, &#8221; Dem a Bleach&#8217;, ‘Bam Bam&#8217;, ‘Tease Me&#8217;, ‘She don&#8217;t let nobody&#8217; and ‘She give me lovin&#8217;, they exited to crowd applause. Next up was Sanchez, who has one of the finest voices in music, along with his tightly knit band, wove a tapestry of great music. His song selections were a perfect blend of timeless classics from Reggae, Rocksteady, Dancehall and Rhythm and Blues.</p>
<p>His seamless transition and well-timed delivery between genres, paid tribute to Gregory Isaacs, Morgan Heritage, &#8221; Down by the river, Freddie McGregor&#8217;s &#8221; See it in You&#8217;, Dennis Brown&#8217;s ‘Here I come&#8217;, (which he owned) Barrington Levy &#8221; Every day I love her&#8217;, Alton Ellis, Sugar Minot ‘Mr. DC&#8217;, Jaheim ‘ Fabulous&#8217;, ‘The Dells &#8221; ‘The love we had&#8221;( stays on my mind), Tracy Chapman ‘Sorry&#8217;, ‘Sam Cooke You Send Me’, Freddy McKay ‘Picture on the Wall’ and Wayne Wade ‘Love you too much&#8217; (to ever start liking you). The singer melded his hit ‘You&#8217;re not alone&#8217;, ‘Lonely won&#8217;t leave me&#8217;, ‘This little girl&#8217;, ‘Let me love you Down&#8217;, ‘Missing you&#8217;, and ‘Never dis the man&#8217; into a brilliant set. He closed the set with the gospel track ‘He looked beyond my fault and saw my needs&#8217;. This was arguably the best performance of the evening and the audience loved it.<br />
The Doctor, Beenie Man delivered his catalogue of hits in his imitable style. His rapid-fire lyrical prose DJ style, showmanship totally captivated his audience. He took the fans where ever he wanted to and had them in the palm of his hand. Beenie Man exited the stage and the Send of Party with Massive B sounds began.<br />
Dancehall concert Night featuring Mr Vegas, L.U.S.T and Elephant Man took centre stage at poolside and lasted for two hours. Mr Vegas spit firing the lyrics of his hits like ‘Hot gal today&#8217;, She&#8217;s a Hoe&#8217;, ‘Nike Air&#8217;, ‘Head High&#8217; ‘I am Blessed&#8217;, ‘Bruk it down&#8217;, ‘Hot Wuk&#8217;, ‘Tek Whey Yu-self’, and ‘Sweet Love Story.&#8217; It was dancehall energy to the max. He closed his set with the gospel track &#8220;Nobody Greater&#8221;.</p>
<p>The group L.U.S.T, the reggae version of the Temptations changed the vibe to a mellow energy. The vocal quartet of Luke D, Tony Curtis, Singing Melody and Thriller U opened with Beatles classics ‘Let it Be&#8217;. Melody launce into ‘Run Free&#8217;, then Lukie D belted out ‘Center of Attraction.&#8217; From that point on we have treated to music lessons a vocal styling with Reggae/Dancehall, Ska, Rocksteady and Rhythm @ Blues. Singing Melody closed with ‘Just as I am’. Elephant Man aka the ‘Energy Gad close the show. The highlight of his set was a Japanese caped dancehall mania named ‘Blackanese.&#8217; He almost stole Ele&#8217;s show. The energy god tried to throw him off the stage, Blackanese dance his way to centre stage. Ele then challenged him to dance off. Blackanese went toe to toe with Ele and then some. Ele simply lets him dance his way off stage, but not before taking Blackanese black cape.</p>
<div id='gallery-4' class='vce-gallery gallery galleryid-118483 gallery-columns-3 gallery-size-vce-lay-b'><div class="vce-gallery-big"><div class="big-gallery-item item-0">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond-Marcia-Griffiths.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond-Marcia-Griffiths.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond-Marcia-Griffiths.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond-Marcia-Griffiths-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond-Marcia-Griffiths-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-1" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Bahamian-twins.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Bahamian-twins.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Bahamian-twins.jpg 800w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Bahamian-twins-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Bahamian-twins-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-2" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Jamaican-breakfast-ackee-saltfish-dumpling-yam-and-porrige-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Jamaican-breakfast-ackee-saltfish-dumpling-yam-and-porrige-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Jamaican-breakfast-ackee-saltfish-dumpling-yam-and-porrige-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Jamaican-breakfast-ackee-saltfish-dumpling-yam-and-porrige-Love-and-Harmony-Cruise-2018-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Jamaican-breakfast-ackee-saltfish-dumpling-yam-and-porrige-Love-and-Harmony-Cruise-2018-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-3" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Elephant-man-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="734" src="http://jamaicans.com/wp-content/uploads/Elephant-man-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Elephant-man-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Elephant-man-Love-and-Harmony-Cruise-2018-300x275.jpg 300w, http://jamaicans.com/wp-content/uploads/Elephant-man-Love-and-Harmony-Cruise-2018-768x705.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-4" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Domino-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Domino-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Domino-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Domino-Love-and-Harmony-Cruise-2018-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Domino-Love-and-Harmony-Cruise-2018-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-5" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Dolphins-at-Cayman-Islands-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Dolphins-at-Cayman-Islands-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Dolphins-at-Cayman-Islands-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Dolphins-at-Cayman-Islands-Love-and-Harmony-Cruise-2018-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Dolphins-at-Cayman-Islands-Love-and-Harmony-Cruise-2018-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-6" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Doctors-Cave-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Doctors-Cave-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Doctors-Cave-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Doctors-Cave-Love-and-Harmony-Cruise-2018-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Doctors-Cave-Love-and-Harmony-Cruise-2018-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div></div><div class="vce-gallery-slider" data-columns="3"><figure class='gallery-item' data-item='0'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond-Marcia-Griffiths.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Beres-Hammond-Marcia-Griffiths-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='1'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Bahamian-twins.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Love-and-Harmony-Cruise-2018-Bahamian-twins-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='2'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Jamaican-breakfast-ackee-saltfish-dumpling-yam-and-porrige-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Jamaican-breakfast-ackee-saltfish-dumpling-yam-and-porrige-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='3'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Elephant-man-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Elephant-man-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='4'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Domino-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Domino-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='5'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Dolphins-at-Cayman-Islands-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Dolphins-at-Cayman-Islands-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='6'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Doctors-Cave-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Doctors-Cave-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure></div></div>
<p><strong>Day 4</strong><br />
After early morning Fitness Abs class, Sunrise stretch and meditation, morning stretch and Soca Body Movement, and a sumptuous breakfast as we anchored at Hog Sty Bay, George Town Grand Cayman. We visited Devil Hang Out, got up close the Dolphins at The Cayman Turtle Center. Others visited the Atlantis Submarine Expedition and Queen Elizabeth Botanic Gardens. We shopped for rum cake, rum cream and souvenirs before boarding a tender back to the ship. The Send of Party with DJ Excitement, Ricky Platinum, and DJ Sallie welcomed us onboard. There was the ladies Pamper Party, the Captain&#8217;s Toast show. At 10:00 pm we dressed in formal attire the Captains Ball on Deck 4 and 11. We danced to the music of Steelie Basement, Ricky Platinum, Karim Hype, Platinum Kids, Massive B, and Glamour Wayne.</p>
<div id='gallery-5' class='vce-gallery gallery galleryid-118483 gallery-columns-3 gallery-size-vce-lay-b'><div class="vce-gallery-big"><div class="big-gallery-item item-0">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/DJ-Bones-Irie-FM-and-Drew-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/DJ-Bones-Irie-FM-and-Drew-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/DJ-Bones-Irie-FM-and-Drew-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/DJ-Bones-Irie-FM-and-Drew-Love-and-Harmony-Cruise-2018-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/DJ-Bones-Irie-FM-and-Drew-Love-and-Harmony-Cruise-2018-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-1" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-2" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018-Welcome-Party.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018-Welcome-Party.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018-Welcome-Party.jpg 800w, http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018-Welcome-Party-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018-Welcome-Party-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-3" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-4" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3.jpg'><img width="800" height="600" src="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="Beres Hammond Love and Harmony Cruise 2018" srcset="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3.jpg 800w, http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3-300x225.jpg 300w, http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3-768x576.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div>
<figcaption class='wp-caption-text gallery-caption'>
Beres Hammond Love and Harmony Cruise 2018
</figcaption></div><div class="big-gallery-item item-5" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-2.jpg'><img width="800" height="905" src="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-2.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-2.jpg 800w, http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-2-265x300.jpg 265w, http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-2-768x869.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-6" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Beres-Hammond-all-white-concert-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Beres-Hammond-all-white-concert-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Beres-Hammond-all-white-concert-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Beres-Hammond-all-white-concert-Love-and-Harmony-Cruise-2018-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Beres-Hammond-all-white-concert-Love-and-Harmony-Cruise-2018-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-7" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Bennie-Man-Love-and-Harmony-Cruise-2018-4.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Bennie-Man-Love-and-Harmony-Cruise-2018-4.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Bennie-Man-Love-and-Harmony-Cruise-2018-4.jpg 800w, http://jamaicans.com/wp-content/uploads/Bennie-Man-Love-and-Harmony-Cruise-2018-4-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Bennie-Man-Love-and-Harmony-Cruise-2018-4-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div><div class="big-gallery-item item-8" style="display:none;">
<div class='gallery-icon'>
<a href='http://jamaicans.com/wp-content/uploads/Beenie-man-Love-and-Harmony-Cruise-2018.jpg'><img width="800" height="1067" src="http://jamaicans.com/wp-content/uploads/Beenie-man-Love-and-Harmony-Cruise-2018.jpg" class="attachment-vce-lay-a size-vce-lay-a" alt="" srcset="http://jamaicans.com/wp-content/uploads/Beenie-man-Love-and-Harmony-Cruise-2018.jpg 800w, http://jamaicans.com/wp-content/uploads/Beenie-man-Love-and-Harmony-Cruise-2018-225x300.jpg 225w, http://jamaicans.com/wp-content/uploads/Beenie-man-Love-and-Harmony-Cruise-2018-768x1024.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
</div></div></div><div class="vce-gallery-slider" data-columns="3"><figure class='gallery-item' data-item='0'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/DJ-Bones-Irie-FM-and-Drew-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/DJ-Bones-Irie-FM-and-Drew-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='1'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='2'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018-Welcome-Party.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Bobby-Konder-and-Jabba-Love-and-Harmony-Cruise-2018-Welcome-Party-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='3'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='4'>
<div class='gallery-icon landscape'>
<a href='http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-3-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="Beres Hammond Love and Harmony Cruise 2018" /></a>
</div></figure><figure class='gallery-item' data-item='5'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-2.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Beres-Hammond-Love-and-Harmony-Cruise-2018-2-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='6'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Beres-Hammond-all-white-concert-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Beres-Hammond-all-white-concert-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='7'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Bennie-Man-Love-and-Harmony-Cruise-2018-4.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Bennie-Man-Love-and-Harmony-Cruise-2018-4-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure><figure class='gallery-item' data-item='8'>
<div class='gallery-icon portrait'>
<a href='http://jamaicans.com/wp-content/uploads/Beenie-man-Love-and-Harmony-Cruise-2018.jpg'><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Beenie-man-Love-and-Harmony-Cruise-2018-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b" alt="" /></a>
</div></figure></div></div>
<p><strong>Day 5</strong><br />
The final day was the grand finale with All White Concert featuring the legendary Beres Hammond and the Queen of Reggae Marcia Griffith. The day began with indoor cycling and Wet Fete Cardio. At midday the poolside Shorts and Shade party, then Karaoke and Silent Disco at the Martini Bar. When the regally dressed Queen of Reggae hit the stage she gave a classic Marcia Griffith, performance. The electric slide queen drew from her five decades of hit songs and kept us entertained. All while fighting a headwind that refuses to cooperate. Great men who transcend their craft have the distinction of being known by one name, like Pele, Jordon, Magic, Michael or Prince. In reggae, it is simply Beres. Before he hit the stage there’s a little feeling in his stomach. Beres all-white concert was a great performance. Beres gave a first class show. From his opening song “I Feel Good&#8221;, until he exited the stage with ‘Rockaway’ we were thoroughly entertained, well pleased and satisfied.</p>
<p><iframe width="810" height="456" src="https://www.youtube.com/embed/KKpFHupjsN8?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.youtube.com/embed/KKpFHupjsN8?feature=oembed"></iframe><noscript><iframe width="810" height="456" src="https://www.youtube.com/embed/KKpFHupjsN8?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></noscript></p>
<div class="at-below-post addthis_tool" data-url="http://jamaicans.com/love-and-harmony-cruise-diary/"></div><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<script id="mNCC" language="javascript" type="c0672d000a142b37ecb9e033-">
   medianet_width = "336";
   medianet_height = "280";
   medianet_crid = "849612493";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div>
</div>
<footer class="entry-footer">
<div class="meta-tags">
<a href="http://jamaicans.com/tag/beres-hamm/" rel="tag">Beres Hamm</a> <a href="http://jamaicans.com/tag/love-and-harmony-cruise/" rel="tag">Love and Harmony Cruise</a> </div>
</footer>
<div class="vce-share-bar">
<ul class="vce-share-items">
<li><a class="fa fa-facebook" href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=http://jamaicans.com/love-and-harmony-cruise-diary/&amp;t=Love+and+Harmony+Diary%3A+Caribbean+Cultural+Cruise"></a></li><li><a class="fa fa-twitter" href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=http://jamaicans.com/love-and-harmony-cruise-diary/&amp;text=Love+and+Harmony+Diary%3A+Caribbean+Cultural+Cruise"></a></li><li><a class="fa fa-google-plus" href="javascript:void(0);" data-url="https://plus.google.com/share?url=http://jamaicans.com/love-and-harmony-cruise-diary/"></a></li><li><a class="fa fa-pinterest" href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=http://jamaicans.com/love-and-harmony-cruise-diary/&amp;media=http%3A%2F%2Fjamaicans.com%2Fwp-content%2Fuploads%2FBeres-Hammond-Love-and-Harmony-Cruise-2018-3.jpg&amp;description=Love+and+Harmony+Diary%3A+Caribbean+Cultural+Cruise"></a></li><li><a class="fa fa-linkedin" href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://jamaicans.com/love-and-harmony-cruise-diary/&amp;title=Love+and+Harmony+Diary%3A+Caribbean+Cultural+Cruise"></a></li> </ul>
</div>
</article>
<nav class="prev-next-nav">
<div class="vce-next-link">
<a href="http://jamaicans.com/top-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-july-6th-2018/" rel="prev"><span class="img-wrp"><img width="375" height="195" src="http://jamaicans.com/wp-content/uploads/Jamaican-and-Caribbean-top-news-summary-375x195.png" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="Jamaican and Caribbean weekly news stories you missed this week" /><span class="vce-pn-ico"><i class="fa fa fa-chevron-right"></i></span></span><span class="vce-prev-next-link">Top 7 Jamaican &#038; Caribbean News Stories You Missed The Week Ending July 6th, 2018</span></a> </div>
</nav>
</main>
<section class="main-box mbt-border-top author-box">
<h3 class="main-box-title">About the author</h3>
<div class="main-box-inside">
<div class="data-image">
<img alt='' src='http://1.gravatar.com/avatar/aba16a7853f4f5263a1f1678f3bbfa3e?s=112&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/aba16a7853f4f5263a1f1678f3bbfa3e?s=224&#038;d=mm&#038;r=g 2x' class='avatar avatar-112 photo' height='112' width='112' /> </div>
<div class="data-content">
<h4 class="author-title">Stan Evan Smith</h4>
<div class="data-entry-content">
<p>Senior Editor and North East Media Coordinator for Jamaicans.com</p>
</div>
</div>
</div>
<div class="vce-content-outside">
<div class="data-links">
<a href="http://jamaicans.com/author/stanevansmith/" class="vce-author-link vce-button">View all posts</a>
</div>
<div class="vce-author-links">
<a href="http://www.jamaicans.com" target="_blank" class="fa fa-link vce-author-website"></a>
</div>
</div>
</section>
<div class="main-box vce-related-box">
<h3 class="main-box-title">You may also like</h3>
<div class="main-box-inside">
<article class="vce-post vce-lay-d post-87761 post type-post status-publish format-standard has-post-thumbnail hentry category-general tag-jamaican-waterfalls">
<div class="meta-image">
<a href="http://jamaicans.com/9-must-see-jamaican-waterfalls-that-you-have-never-heard-about/" title="9 Must See Jamaican Waterfalls That You Have Never Heard About">
<img width="145" height="100" src="http://jamaicans.com/wp-content/uploads/2015/11/Reach-Falls-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Reach Falls, Jamaica" srcset="http://jamaicans.com/wp-content/uploads/2015/11/Reach-Falls-145x100.jpg 145w, http://jamaicans.com/wp-content/uploads/2015/11/Reach-Falls-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="http://jamaicans.com/jamaica/general/" class="category-1">General</a></span>
<h2 class="entry-title"><a href="http://jamaicans.com/9-must-see-jamaican-waterfalls-that-you-have-never-heard-about/" title="9 Must See Jamaican Waterfalls That You Have Never Heard About">9 Must See Jamaican Waterfalls That You Have Never...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-83067 post type-post status-publish format-standard has-post-thumbnail hentry category-general tag-blue-hole tag-glistening-waters-luminous-lagoon tag-green-grotto-caves tag-negril tag-ocho-rios">
<div class="meta-image">
<a href="http://jamaicans.com/8-most-amazing-places-in-jamaica/" title="8 Most Amazing Places In Jamaica">
<img width="145" height="100" src="http://jamaicans.com/wp-content/uploads/2015/07/Negril-Cliff-Diving-Photo-by-Kessler_jacueline-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="http://jamaicans.com/wp-content/uploads/2015/07/Negril-Cliff-Diving-Photo-by-Kessler_jacueline-145x100.jpg 145w, http://jamaicans.com/wp-content/uploads/2015/07/Negril-Cliff-Diving-Photo-by-Kessler_jacueline-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="http://jamaicans.com/jamaica/general/" class="category-1">General</a></span>
<h2 class="entry-title"><a href="http://jamaicans.com/8-most-amazing-places-in-jamaica/" title="8 Most Amazing Places In Jamaica">8 Most Amazing Places In Jamaica</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-37959 post type-post status-publish format-standard hentry category-general">
<div class="meta-image">
<a href="http://jamaicans.com/bush/" title="Jamaican Herbal Remedies">
<img width="145" height="100" src="http://jamaicans.com/wp-content/uploads/2015/03/jadotcom_default-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d" alt="" srcset="http://jamaicans.com/wp-content/uploads/2015/03/jadotcom_default-145x100.jpg 145w, http://jamaicans.com/wp-content/uploads/2015/03/jadotcom_default-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="http://jamaicans.com/jamaica/general/" class="category-1">General</a></span>
<h2 class="entry-title"><a href="http://jamaicans.com/bush/" title="Jamaican Herbal Remedies">Jamaican Herbal Remedies</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-29344 post type-post status-publish format-standard has-post-thumbnail hentry category-general tag-jamaica-customs tag-jamaican-traditions tag-marriage">
<div class="meta-image">
<a href="http://jamaicans.com/jamaicanmarriagecustoms/" title="Traditional Jamaican Marriage Customs">
<img width="145" height="100" src="http://jamaicans.com/wp-content/uploads/Traditional-Jamaican-Marriage-Customs-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="http://jamaicans.com/wp-content/uploads/Traditional-Jamaican-Marriage-Customs-145x100.jpg 145w, http://jamaicans.com/wp-content/uploads/Traditional-Jamaican-Marriage-Customs-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="http://jamaicans.com/jamaica/general/" class="category-1">General</a></span>
<h2 class="entry-title"><a href="http://jamaicans.com/jamaicanmarriagecustoms/" title="Traditional Jamaican Marriage Customs">Traditional Jamaican Marriage Customs</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-22070 post type-post status-publish format-standard hentry category-culture-jamaica category-general tag-granny">
<div class="meta-image">
<a href="http://jamaicans.com/granny-3/" title="Mi granny always used to seh&#8230;Jamaican Proverbs">
<img width="145" height="100" src="http://jamaicans.com/wp-content/uploads/2015/03/jadotcom_default-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d" alt="" srcset="http://jamaicans.com/wp-content/uploads/2015/03/jadotcom_default-145x100.jpg 145w, http://jamaicans.com/wp-content/uploads/2015/03/jadotcom_default-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="http://jamaicans.com/jamaica/culture-jamaica/" class="category-40">Culture</a> <span>&bull;</span> <a href="http://jamaicans.com/jamaica/general/" class="category-1">General</a></span>
<h2 class="entry-title"><a href="http://jamaicans.com/granny-3/" title="Mi granny always used to seh&#8230;Jamaican Proverbs">Mi granny always used to seh&#8230;Jamaican Proverbs</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-22722 post type-post status-publish format-standard has-post-thumbnail hentry category-general">
<div class="meta-image">
<a href="http://jamaicans.com/busnames/" title="Jamaican Bus Names">
<img width="135" height="100" src="http://jamaicans.com/wp-content/uploads/a586~s800x800-135x100.gif" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="http://jamaicans.com/jamaica/general/" class="category-1">General</a></span>
<h2 class="entry-title"><a href="http://jamaicans.com/busnames/" title="Jamaican Bus Names">Jamaican Bus Names</a></h2>
</header>
</article>
</div>
</div>
</div>
<aside id="sidebar" class="sidebar right">
<div id="search-4" class="widget widget_search"><form action="http://jamaicans.com/search-results/" class="search-form" method="get" role="search">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" title="Search for:" name="q" value="" placeholder="Search ..." class="search-field" />
</label>
<input type="submit" value="Search" class="search-submit" />
</form></div><div id="mailerlite_widget-2" class="widget widget_mailerlite_widget">
<div id="mailerlite-form_1" data-temp-id="5b3fcaacd0bdc">
<div class="mailerlite-form">
<form action="" method="post">
<div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div>
<div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p>
</div>
<div class="mailerlite-form-inputs">
<div class="mailerlite-form-field">
<label for="mailerlite-1-field-email">Email</label>
<input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" />
</div>
<div class="mailerlite-form-loader">Please wait...</div>
<div class="mailerlite-subscribe-button-container">
<input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" />
</div>
<input type="hidden" name="form_id" value="1" />
<input type="hidden" name="action" value="mailerlite_subscribe_form" />
</div>
<div class="mailerlite-form-response">
<h4><p><span style="color: #339966;">Thank you for sign up!</span></p>
</h4>
</div>
</form>
</div>
</div>
<script type="c0672d000a142b37ecb9e033-text/javascript">
    (function() {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=5b3fcaacd0bdc] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                    submitHandler: function (form) {

                        jQuery(this.submitButton).prop('disabled', true);

                        form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                            form_container.find('.mailerlite-form-loader').fadeIn()
                                        });

                        var data = jQuery(form).serialize();

                        jQuery.post('http://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                            form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                                form_container.find('.mailerlite-form-response').fadeIn()
                                            });
                        });
                    }
            });
        });
    })();
</script>
</div><div id="vce_adsense_widget-8" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">

<script language='JavaScript' type="c0672d000a142b37ecb9e033-text/javascript" src='http://www.simbis.com/tools/phpAdsNew/adx.js'></script>
<script language='JavaScript' type="c0672d000a142b37ecb9e033-text/javascript">
<!--
   if (!document.phpAds_used) document.phpAds_used = ',';
   phpAds_random = new String (Math.random()); phpAds_random = phpAds_random.substring(2,11);
   
   document.write ("<" + "script language='JavaScript' type='text/javascript' src='");
   document.write ("http://www.simbis.com/tools/phpAdsNew/adjs.php?n=" + phpAds_random);
   document.write ("&what=zone:5");
   document.write ("&exclude=" + document.phpAds_used);
   if (document.referrer)
      document.write ("&referer=" + escape(document.referrer));
   document.write ("'><" + "/script>");
//-->
</script><noscript><a href='http://www.simbis.com/tools/phpAdsNew/adclick.php?n=a141ee70' target='_blank'><img 

src='http://www.simbis.com/tools/phpAdsNew/adview.php?what=zone:5&n=a141ee70' border='0' alt=''></a></noscript>
 </div>
</div><div id="vce_adsense_widget-15" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">

<script id="mNCC" language="javascript" type="c0672d000a142b37ecb9e033-">
   medianet_width = "300";
   medianet_height = "250";
   medianet_crid = "966658449";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
</div><div id="vce_adsense_widget-2" class="widget vce_adsense_widget vce_adsense_expand"> <div class="vce_adsense_wrapper">
<script type="c0672d000a142b37ecb9e033-text/javascript"><!--
google_ad_client = "pub-1901173274277249";
google_ad_width = 300;
google_ad_height = 250;
google_ad_format = "300x250_as";
google_ad_type = "text";
google_ad_channel = "";
google_color_border = "798DC2";
google_color_bg = "FFFFFF";
google_color_link = "5870AE";
google_color_text = "676768";
google_color_url = "2C2F4B";
//-->
</script>
<script type="c0672d000a142b37ecb9e033-text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script> </div>
</div><div id="vce_adsense_widget-13" class="widget vce_adsense_widget vce_adsense_expand"> <div class="vce_adsense_wrapper">
<a href="http://blog.amerijet.com/amerijet-easy-fast-reliable/?lrx=ibmwxo1476296317"><img src="http://www.jamaicans.com/images/ads/AmeriJet-Logo-3002.jpg" /></a>
<iframe width="300" height="102" src="https://www.youtube.com/embed/2XFghsPeJ9Q" frameborder="0" allowfullscreen data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.youtube.com/embed/2XFghsPeJ9Q"></iframe><noscript><iframe width="300" height="102" src="https://www.youtube.com/embed/2XFghsPeJ9Q" frameborder="0" allowfullscreen></iframe></noscript> </div>
</div><div id="rss-5" class="widget widget_rss"><h4 class="widget-title"><a class="rsswidget" href="http://jamaicans.com/videos/?feed=rss2"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://jamaicans.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://jamaicans.com/videos">Videos</a></h4><ul><li><a class='rsswidget' href='http://jamaicans.com/videos/jamaican-doctors-heart-condition-cured-in-the-cayman-islands/'>Jamaican Doctor’s Heart Condition Cured In The Cayman Islands</a></li><li><a class='rsswidget' href='http://jamaicans.com/videos/watch-getting-high-in-jamaica-amazing-drone-shots/'>WATCH: Getting High in Jamaica – Amazing Drone Shots</a></li></ul></div><div id="vce_adsense_widget-14" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">
<a href="http://blog.amerijet.com/amerijet-easy-fast-reliable/?lrx=ibmwxo1476296317"><img src="http://news.jamaicans.com/wp-content/uploads/2018/03/amerijet-160x600.jpg" /></a>
<br><br>

<script id="mNCC" language="javascript" type="c0672d000a142b37ecb9e033-">
   medianet_width = "160";
   medianet_height = "90";
   medianet_crid = "441244783";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
</div><div id="vce_adsense_widget-16" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">
<script type="c0672d000a142b37ecb9e033-text/javascript" src="//ap.lijit.com/www/delivery/fpi.js?z=406528&u=jamaicans&width=300&height=250"></script> </div>
</div><div id="vce_adsense_widget-7" class="widget vce_adsense_widget vce_adsense_expand"> <div class="vce_adsense_wrapper">

<script id="mNCC" language="javascript" type="c0672d000a142b37ecb9e033-">
   medianet_width = "300";
   medianet_height = "600";
   medianet_crid = "526552473";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script> </div>
</div><div id="vce_adsense_widget-4" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">

<script type="c0672d000a142b37ecb9e033-text/javascript">var vclk_options = {sid:4905,media_id:3,media_type:7,version:"1.4"};</script><script class="vclk_pub_code" type="c0672d000a142b37ecb9e033-text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=4905&media_id=3&media_type=7&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=4905&m=3&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=4905&m=3&tp=7&d=s&c=1&vcm_acv=1.4" width="160" height="600" border="1"></a></noscript>

</div>
</div><div class="vce-sticky"><div id="text-3" class="widget widget_text"><h4 class="widget-title">Our Facebook Page</h4> <div class="textwidget"><script src="http://connect.facebook.net/en_US/all.js#xfbml=1" type="c0672d000a142b37ecb9e033-"></script><fb:like-box href="http://www.facebook.com/onelovejamaica" width="270" show_faces="true" stream="false" header="false"></fb:like-box>
</div>
</div></div> </aside>
</div>
<footer id="footer" class="site-footer">
<div class="container">
<div class="container-fix">
<div class="bit-3">
<div id="mks_social_widget-2" class="widget mks_social_widget"><h4 class="widget-title">Socially Speaking</h4>
<ul class="mks_social_widget_ul">
<li><a href="http://www.facebook.com/onelovejamaica" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>facebook</span></a></li>
<li><a href="https://plus.google.com/+Jamaicans/" title="" class="googleplus_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>googleplus</span></a></li>
<li><a href="http://instagram.com/jamaicans_com" title="Instagram" class="instagram_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>instagram</span></a></li>
<li><a href="http://twitter.com/jamaicansdotcom" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>twitter</span></a></li>
<li><a href="https://www.youtube.com/user/outofmanyonline" title="Youtube" class="youtube_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>youtube</span></a></li>
<li><a href="http://jamaicans.com/?feed=rss" title="RSS" class="rss_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>rss</span></a></li>
<li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="pinterest_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>pinterest</span></a></li>
<li><a href="http://jamaicansdotcom.tumblr.com/" title="Tumblr" class="tumblr_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>tumblr</span></a></li>
</ul>
</div><div id="vce_adsense_widget-9" class="widget vce_adsense_widget vce_adsense_expand"> <div class="vce_adsense_wrapper">

<script type="c0672d000a142b37ecb9e033-text/javascript"><!--
google_ad_client = "pub-1901173274277249";
google_ad_width = 300;
google_ad_height = 250;
google_ad_format = "300x250_as";
google_ad_type = "text";
google_ad_channel = "";
google_color_border = "798DC2";
google_color_bg = "FFFFFF";
google_color_link = "5870AE";
google_color_text = "676768";
google_color_url = "2C2F4B";
//-->
</script>
<script type="c0672d000a142b37ecb9e033-text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script>
 </div>
</div> </div>
<div class="bit-3">
<div id="vce_posts_widget-2" class="widget vce_posts_widget"><h4 class="widget-title">Random Jamaican Recipes</h4>
<ul class="vce-post-list" data-autoplay="">
<li>
<a href="http://jamaicans.com/5-quick-one-pot-meals-from-jamaica/" class="featured_image_sidebar" title="5 Quick One Pot Meals From Jamaica"><span class="vce-post-img"><img width="145" height="100" src="http://jamaicans.com/wp-content/uploads/2016/09/5-Quick-One-Pot-Meals-From-Jamaica-2-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="http://jamaicans.com/wp-content/uploads/2016/09/5-Quick-One-Pot-Meals-From-Jamaica-2-145x100.jpg 145w, http://jamaicans.com/wp-content/uploads/2016/09/5-Quick-One-Pot-Meals-From-Jamaica-2-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="http://jamaicans.com/5-quick-one-pot-meals-from-jamaica/" title="5 Quick One Pot Meals From Jamaica" class="vce-post-link">5 Quick One Pot Meals From Jamaica</a>
<div class="entry-meta"><div class="meta-item comments"><a href="http://jamaicans.com/5-quick-one-pot-meals-from-jamaica/#respond"><span class="dsq-postid" data-dsqidentifier="100247 http://jamaicans.com/?p=100247">Add Comment</span></a></div></div>
</div>
</li>
<li>
<a href="http://jamaicans.com/chef-sians-conch-salad-recipe/" class="featured_image_sidebar" title="Chef Sian&#8217;s Conch Salad Recipe"><span class="vce-post-img"><img width="145" height="100" src="http://jamaicans.com/wp-content/uploads/2016/09/conch-salad-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="http://jamaicans.com/wp-content/uploads/2016/09/conch-salad-145x100.jpg 145w, http://jamaicans.com/wp-content/uploads/2016/09/conch-salad-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="http://jamaicans.com/chef-sians-conch-salad-recipe/" title="Chef Sian&#8217;s Conch Salad Recipe" class="vce-post-link">Chef Sian&#8217;s Conch Salad Recipe</a>
<div class="entry-meta"><div class="meta-item comments"><a href="http://jamaicans.com/chef-sians-conch-salad-recipe/#respond"><span class="dsq-postid" data-dsqidentifier="98661 http://jamaicans.com/?p=98661">Add Comment</span></a></div></div>
</div>
</li>
<li>
<a href="http://jamaicans.com/jamaican-foods-listed-essential-caribbean/" class="featured_image_sidebar" title="Four Jamaican Foods Listed in Saveur Magazine’s List of 17 Essential Caribbean Dishes"><span class="vce-post-img"><img width="145" height="100" src="http://jamaicans.com/wp-content/uploads/Saltfish-Fritters-Essential-Caribbean-Dishes-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Saltfish Fritters Essential Caribbean Dishes" srcset="http://jamaicans.com/wp-content/uploads/Saltfish-Fritters-Essential-Caribbean-Dishes-145x100.jpg 145w, http://jamaicans.com/wp-content/uploads/Saltfish-Fritters-Essential-Caribbean-Dishes-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="http://jamaicans.com/jamaican-foods-listed-essential-caribbean/" title="Four Jamaican Foods Listed in Saveur Magazine’s List of 17 Essential Caribbean Dishes" class="vce-post-link">Four Jamaican Foods Listed in Saveur Magazine’s List...</a>
<div class="entry-meta"><div class="meta-item comments"><a href="http://jamaicans.com/jamaican-foods-listed-essential-caribbean/#respond"><span class="dsq-postid" data-dsqidentifier="112453 http://jamaicans.com/?p=112453">Add Comment</span></a></div></div>
</div>
</li>
<li>
<a href="http://jamaicans.com/7-amazing-jamaican-street-foods-you-must-try/" class="featured_image_sidebar" title="7 Amazing Jamaican Street Foods You Must Try"><span class="vce-post-img"><img width="145" height="100" src="http://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-145x100.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Peppered Shrimps by kwesianthony" srcset="http://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-145x100.png 145w, http://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-380x260.png 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="http://jamaicans.com/7-amazing-jamaican-street-foods-you-must-try/" title="7 Amazing Jamaican Street Foods You Must Try" class="vce-post-link">7 Amazing Jamaican Street Foods You Must Try</a>
<div class="entry-meta"><div class="meta-item comments"><a href="http://jamaicans.com/7-amazing-jamaican-street-foods-you-must-try/#respond"><span class="dsq-postid" data-dsqidentifier="94605 http://jamaicans.com/?p=94605">Add Comment</span></a></div></div>
</div>
</li>
<li>
<a href="http://jamaicans.com/chef-sians-peanut-porridge-recipe/" class="featured_image_sidebar" title="Chef Sian&#8217;s Peanut Porridge Recipe"><span class="vce-post-img"><img width="145" height="100" src="http://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="http://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-145x100.jpg 145w, http://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="http://jamaicans.com/chef-sians-peanut-porridge-recipe/" title="Chef Sian&#8217;s Peanut Porridge Recipe" class="vce-post-link">Chef Sian&#8217;s Peanut Porridge Recipe</a>
<div class="entry-meta"><div class="meta-item comments"><a href="http://jamaicans.com/chef-sians-peanut-porridge-recipe/#respond"><span class="dsq-postid" data-dsqidentifier="101450 http://jamaicans.com/?p=101450">Add Comment</span></a></div></div>
</div>
</li>
</ul>
</div> </div>
<div class="bit-3">
<div id="vce_adsense_widget-3" class="widget vce_adsense_widget vce_adsense_expand"><h4 class="widget-title">Advertisement</h4> <div class="vce_adsense_wrapper">

<script type="c0672d000a142b37ecb9e033-text/javascript">var vclk_options = {sid:4905,media_id:6,media_type:8,version:"1.4"};</script><script class="vclk_pub_code" type="c0672d000a142b37ecb9e033-text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=4905&media_id=6&media_type=8&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=4905&m=6&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=4905&m=6&tp=8&d=s&c=1&vcm_acv=1.4" width="300" height="250" border="1"></a></noscript>
 </div>
</div> </div>
</div>
</div>
<div class="container-full site-info">
<div align="center" style="padding-bottom: 20px;"> 
<script type="c0672d000a142b37ecb9e033-text/javascript">

<!--

google_ad_client = "pub-1901173274277249";

google_alternate_ad_url = "http://www.jamaicans.com/images/ads/google_728X90.htm";

google_ad_width = 728;

google_ad_height = 90;

google_ad_format = "728x90_as";

google_ad_type = "text_image";

google_ad_channel = "";

google_color_border = "798DC2";

google_color_bg = "FFFFFF";

google_color_link = "5870AE";

google_color_text = "676768";

google_color_url = "2C2F4B";

//-->

</script>
<script type="c0672d000a142b37ecb9e033-text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script>

</div>
<div class="container">
<div class="vce-wrap-left">
<p>Copyright © 2015 Simbis Inc. All rights reserved. <a href="http://jamaicans.com/privacy/">Privacy Policy &amp; Terms of use</a>.</p> </div>
<div class="vce-wrap-right">
<ul id="vce_footer_menu" class="bottom-nav-menu"><li id="menu-item-529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-529 vce-cat-40"><a href="http://jamaicans.com/jamaica/culture-jamaica/">Culture</a></li>
<li id="menu-item-532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532 vce-cat-45"><a href="http://jamaicans.com/jamaica/travel/">Travel</a></li>
<li id="menu-item-527" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-527"><a href="http://jamaicans.com/about-us/">About Us</a></li>
<li id="menu-item-457" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-457"><a href="http://jamaicans.com/our-contact/">Contact</a></li>
</ul> </div>
</div>
</div>
</footer>
</div>
</div>
<a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a>
<script async type="c0672d000a142b37ecb9e033-">(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='433af38b6e2402a24dab9aa3d747b3033cf5bc5d8ebe9c002919c18dd0789a50';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script><script type="c0672d000a142b37ecb9e033-text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "http://jamaicans.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "69bf6d42aa", post_id : 118483 } ); } ); /* ]]> */</script>
<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.1.6"; } if (window.wp_blog_version === undefined) { window.wp_blog_version = "4.9.7"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":"300"}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.1.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-bf34677b4718a8fdb8e7d271cfbb868e","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=wp-bf34677b4718a8fdb8e7d271cfbb868e" async="async"></script><script type="c0672d000a142b37ecb9e033-text/javascript">
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/jamaicans.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type="c0672d000a142b37ecb9e033-text/javascript" src='http://jamaicans.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.2'></script>
<script type="c0672d000a142b37ecb9e033-text/javascript">
/* <![CDATA[ */
var countVars = {"disqusShortname":"jamaicanscom"};
/* ]]> */
</script>
<script type="c0672d000a142b37ecb9e033-text/javascript" src='http://jamaicans.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type="c0672d000a142b37ecb9e033-text/javascript">
/* <![CDATA[ */
var vce_js_settings = {"sticky_header":"","sticky_header_offset":"200","sticky_header_logo":"http:\/\/jamaicans.com\/wp-content\/uploads\/2015\/08\/final-logo-abbr.png","logo":"http:\/\/jamaicans.com\/wp-content\/uploads\/2015\/01\/jamaicans_logo.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"http:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"1","full_slider_autoplay":"","grid_slider_autoplay":"","grid_big_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"1","top_bar_mobile_group":"1","top_bar_more_link":null};
/* ]]> */
</script>
<script type="c0672d000a142b37ecb9e033-text/javascript" src='http://jamaicans.com/wp-content/themes/voice/js/min.js?ver=2.7'></script>
<script type="c0672d000a142b37ecb9e033-text/javascript">
/* <![CDATA[ */
var fcaPcEvents = [];
var fcaPcDebug = {"debug":""};
var fcaPcPost = {"title":"Love and Harmony Diary: Caribbean Cultural Cruise","type":"post","id":"118483","categories":["General"],"utm_support":"","user_parameters":"","edd_delay":"0","woo_delay":"0","edd_enabled":"","woo_enabled":""};
/* ]]> */
</script>
<script type="c0672d000a142b37ecb9e033-text/javascript" src='http://jamaicans.com/wp-content/plugins/facebook-conversion-pixel/pixel-cat.min.js?ver=2.4.0'></script>
<script type="c0672d000a142b37ecb9e033-text/javascript" src='http://jamaicans.com/wp-includes/js/wp-embed.min.js?ver=f9dfde8fde9d0f65cf47c424dc1c938f'></script>
<script type="c0672d000a142b37ecb9e033-">(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	var v = !("IntersectionObserver" in w) ? "8.7.1" : "10.5.2";
	s.src = "http://jamaicans.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-" + v + ".min.js";
	w.lazyLoadOptions = {
		elements_selector: "img, iframe",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );
	
	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };
	
	observer.observe(b, config);
}, false);
</script>
<script src="https://ajax.cloudflare.com/cdn-cgi/scripts/4f936b58/cloudflare-static/rocket-loader.min.js" data-cf-nonce="c0672d000a142b37ecb9e033-" defer=""></script></body>
</html>
