<!DOCTYPE html>
<!--[if IE 8]><html class="ie8"><![endif]-->
<!--[if IE 9]><html class="ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1">
<title>Jamaican Restaurant Chain Opens New Eatery In Rochester, Minnesota - Jamaicans.com</title>
<!--[if lt IE 9]>
	<script src="https://jamaicans.com/wp-content/themes/voice/js/html5.js"></script>
<![endif]-->

<script type="text/javascript">
if(document.location.protocol=='http:'){
 var Tynt=Tynt||[];Tynt.push('abWrx44JCr4z2Wacwqm_6r');
 (function(){var s=document.createElement('script');s.async="async";s.type="text/javascript";s.src='https://tcr.tynt.com/ti.js';var h=document.getElementsByTagName('script')[0];h.parentNode.insertBefore(s,h);})();
}
</script>

<title>Jamaican Restaurant Chain Opens New Eatery In Rochester, Minnesota - Jamaicans.com</title>

<script>
			!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
			n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
			document,'script','https://connect.facebook.net/en_US/fbevents.js');
			fbq('init', '1055480241142713' );			fbq('track', 'PageView');
			
			</script>
<noscript><img height="1" width="1" style="display:none"
			src="https://www.facebook.com/tr?id=1055480241142713&ev=PageView&noscript=1"
			/></noscript>



<link rel="canonical" href="https://jamaicans.com/jamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Jamaican Restaurant Chain Opens New Eatery In Rochester, Minnesota - Jamaicans.com" />
<meta property="og:description" content="The new Jerk King restaurant, which is one of a chain that includes five restaurants in Canada, has opened in Peace Plaza on 1st Street in Rochester, Minnesota. The space is already being renovated, and the plan is to open the dining venue by the Christmas holiday. The restaurant chain is known for its Jamaican &hellip;" />
<meta property="og:url" content="http://jamaicans.com/jamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota/" />
<meta property="og:site_name" content="Jamaicans.com" />
<meta property="article:author" content="http://www.facebook.com/onelovejamaica" />
<meta property="article:tag" content="Jamaican Restaurant" />
<meta property="article:section" content="Announcements" />
<meta property="article:published_time" content="2018-11-11T19:00:31+00:00" />
<meta property="article:modified_time" content="2018-11-10T16:41:55+00:00" />
<meta property="og:updated_time" content="2018-11-10T16:41:55+00:00" />
<meta property="og:image" content="https://jamaicans.com/wp-content/uploads/Jamaican-Restaurant-Chain-Opens-New-Eatery-In-Rochester-Minnesota.jpg" />
<meta property="og:image:secure_url" content="https://jamaicans.com/wp-content/uploads/Jamaican-Restaurant-Chain-Opens-New-Eatery-In-Rochester-Minnesota.jpg" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="800" />
<meta property="og:image:alt" content="Jamaican Restaurant Chain Opens New Eatery In Rochester Minnesota" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The new Jerk King restaurant, which is one of a chain that includes five restaurants in Canada, has opened in Peace Plaza on 1st Street in Rochester, Minnesota. The space is already being renovated, and the plan is to open the dining venue by the Christmas holiday. The restaurant chain is known for its Jamaican [&hellip;]" />
<meta name="twitter:title" content="Jamaican Restaurant Chain Opens New Eatery In Rochester, Minnesota - Jamaicans.com" />
<meta name="twitter:image" content="https://jamaicans.com/wp-content/uploads/Jamaican-Restaurant-Chain-Opens-New-Eatery-In-Rochester-Minnesota.jpg" />
<meta name="twitter:creator" content="@jamaicansdotcom" />

<link rel='dns-prefetch' href='//static.mailerlite.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Feed" href="https://jamaicans.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Comments Feed" href="https://jamaicans.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jamaicans.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=c914dae6e91b355e909bee01f0978470"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://jamaicans.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='mailerlite_forms.css-css' href='https://jamaicans.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/css/mailerlite_forms.css?ver=1.2.8' type='text/css' media='all' />
<link rel='stylesheet' id='wpProQuiz_front_style-css' href='https://jamaicans.com/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all' />
<link rel='stylesheet' id='vce_font_0-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.8.1' type='text/css' media='screen' />
<link rel='stylesheet' id='vce_font_1-css' href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.8.1' type='text/css' media='screen' />
<link rel='stylesheet' id='vce_font_2-css' href='https://fonts.googleapis.com/css?family=Oswald%3A400&#038;subset=latin&#038;ver=2.8.1' type='text/css' media='screen' />
<link rel='stylesheet' id='vce_style-css' href='https://jamaicans.com/wp-content/themes/voice/css/min.css?ver=2.8.1' type='text/css' media='screen, print' />
<style id='vce_style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='vce_child_load_scripts-css' href='https://jamaicans.com/wp-content/themes/voice-child/style.css?ver=2.8.1' type='text/css' media='screen' />
<link rel='stylesheet' id='meks-ads-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-easy-ads-widget/css/style.css?ver=2.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='meks-author-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-smart-author-widget/css/style.css?ver=1.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='meks-social-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-smart-social-widget/css/style.css?ver=1.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css' href='https://jamaicans.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=c914dae6e91b355e909bee01f0978470' type='text/css' media='all' />
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://static.mailerlite.com/js/jquery.validate.min.js?ver=c914dae6e91b355e909bee01f0978470'></script>
<link rel='https://api.w.org/' href='https://jamaicans.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jamaicans.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jamaicans.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://jamaicans.com/?p=121053' />
<link rel="alternate" type="application/json+oembed" href="https://jamaicans.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicans.com%2Fjamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://jamaicans.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicans.com%2Fjamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota%2F&#038;format=xml" />
<meta name="thumbnail" content="https://jamaicans.com/wp-content/uploads/Jamaican-Restaurant-Chain-Opens-New-Eatery-In-Rochester-Minnesota-150x150.jpg" />
<script>
(function(m,a,i,l,e,r){ m['MailerLiteObject']=e;function f(){
var c={ a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?v'+(~~(new Date().getTime()/1000000));
_.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');
</script>
 
<script>
        (function(m,a,i,l,e,r){m['MailerLiteObject']=e;function f(){
        var c={a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
        f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
        var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?'+(~~(new Date().getTime()/10000000));
        _.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

        var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');
    </script>

<script type="text/javascript">
                var rsssl_share_url = window.location.href.replace('https://', 'http://');
                var addthis_share = {url: '' + rsssl_share_url + ''};
            </script>
<link rel="shortcut icon" href="https://jamaicans.com/wp-content/uploads/2015/08/JA-favicon.png" type="image/x-icon" /><style type="text/css">div.sumome-share-client-wrapper.sumome-share-client-wrapper-left-page.sumome-share-client-counts.sumome-share-client-light.sumome-share-client-medium {top: 45%;} .page-id-207 #breadcrumbs {display: none;} .nav-menu .vce-mega-menu .sub-menu .sub-menu li, .nav-menu .vce-mega-menu .sub-menu a {line-height: 1.2em !important;} .main-navigation a {font-size: 19px; padding: 15px 21px 15px;} .vce-slider-pagination .owl-controls {background:#ffde00;} .vce-post {box-shadow: 0 1px 3px 0 rgba(0,0,0,0);} .main-navigation a {line-height: 39px; font-size: 18px; padding: 15px 10px 15px;} .main-box-title {border-top-width: 8px !important;} /* .main-header {background-color:#f3d45b;} .site-footer {background: url(https://jamaicans.com/wp-content/uploads/2015/02/footer-2.jpg) 0px 0px no-repeat;} */ .dp_pec_monthly.light, .dp_pec_weekly.light, .dp_pec_daily.light {margin:0 auto;} .vce-wrap-left {width: 65%;} .vce-wrap-right {width: 35%;} .header-sticky {height: 74px;} .header-sticky .site-title img {max-height: 69px;} li.feed-item {list-style: none; font-size: .9em;} li.feed-item a {font-size: 1.1em; font-weight: bold;} #rss-3 li a {font-size: 1.1em; color: #55ad4c;} #breadcrumbs {margin: 10px 0px; padding: 10px 20px; color: #393939; opacity: .8; background: #fff; border-left: #393939 solid 5px;} #breadcrumbs span {padding: 0px 5px;} #breadcrumbs a {font-size: .8em; color: #393939;} .breadcrumb_last {font-size: .9em; color:#55ad4c;} #mailerlite_widget-2 {background:rgba(243, 212, 91, 0.48);} .main-box-title.cat-348 {border-top:8px solid #f34d28 !important;} .meta-category a {font-weight:bold;}</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2520621-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2520621-1');
</script>

<div class="wrapper-outer">
<div style="display:none;height:0;width:0;">
<script type="text/javascript" src="https://widgets.amung.us/small.js"></script>
<script type="text/javascript">WAU_small('jamaicans')</script>
</div>
</head>
<body data-rssslsocial=1 data-rsssl=1 class="post-template-default single single-post postid-121053 single-format-standard unknown vce-sid-right">
<div id="vce-main">
<header id="header" class="main-header">
<div class="container header-2-wrapper header-main-area">
<div class="vce-res-nav">
<a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a>
</div>
<div class="site-branding">
<span class="site-title"><a href="https://jamaicans.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><source srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><img src="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png" alt="Jamaicans.com"></picture></a></span></div>
<div class="vce-header-ads">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="5539842733" data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</div>
<div class="header-bottom-wrapper header-left-nav">
<div class="container">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-79827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79827 vce-cat-40"><a href="https://jamaicans.com/jamaica/culture-jamaica/">Culture</a><li id="menu-item-61427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61427"><a href="https://jamaicans.com/travel-jamaica/">Travel</a><li id="menu-item-83497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83497"><a href="https://jamaicans.com/recipes/">Food</a><li id="menu-item-77663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77663"><a href="https://jamaicans.com/speak-jamaican/">Speak JA</a><li id="menu-item-79829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79829 vce-cat-265"><a href="https://jamaicans.com/jamaica/jamaican-music/">Music</a><li id="menu-item-118280" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-118280"><a href="#">Photos + Videos</a>
<ul class="sub-menu">
<li id="menu-item-118279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118279"><a href="https://jamaicans.com/photogallery/">Photos</a> <li id="menu-item-118281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118281"><a href="https://jamaicans.com/videos/%20">Videos</a></ul>
<li id="menu-item-79826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79826 vce-cat-276"><a href="https://jamaicans.com/jamaica/jamaica-magazine/">JA Mag</a><li id="menu-item-79856" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-79856 vce-cat-267"><a href="https://jamaicans.com/jamaica/news-announcements/">News</a><li id="menu-item-61425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61425"><a href="https://jamaicans.com/jamaican-information/">Research JA</a><li class="search-header-wrap"><a class="search_header" href="javascript:void(0)"><i class="fa fa-search"></i></a><ul class="search-header-form-ul"><li><form action="https://jamaicans.com/search-results/" class="search-form" method="get" role="search">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" title="Search for:" name="q" value="" placeholder="Search ..." class="search-field" />
</label>
<input type="submit" value="Search" class="search-submit" />
</form></li></ul></li></ul></nav> </div>
</div></header>
<div id="main-wrapper">
<div id="content" class="container site-content">
<div id=“breadcrumbs”>
</div>
<div id="primary" class="vce-main-content">
<main id="main" class="main-box main-box-single">
<article id="post-121053" class="vce-single post-121053 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-jamaican-restaurant">
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h1 class="entry-title">Jamaican Restaurant Chain Opens New Eatery In Rochester, Minnesota</h1>
<div class="entry-meta"><div class="meta-item date"><span class="updated">3 hours ago</span></div><div class="meta-item author"><span class="vcard author"><span class="fn">by <a href="https://jamaicans.com/author/staffwriter/">Staff Writer</a></span></span></div></div>
</header>
<div class="meta-image">
<img width="810" height="648" src="https://jamaicans.com/wp-content/uploads/Jamaican-Restaurant-Chain-Opens-New-Eatery-In-Rochester-Minnesota-810x648.jpg" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="Jamaican Restaurant Chain Opens New Eatery In Rochester Minnesota" srcset="https://jamaicans.com/wp-content/uploads/Jamaican-Restaurant-Chain-Opens-New-Eatery-In-Rochester-Minnesota-810x648.jpg 810w, https://jamaicans.com/wp-content/uploads/Jamaican-Restaurant-Chain-Opens-New-Eatery-In-Rochester-Minnesota-300x240.jpg 300w, https://jamaicans.com/wp-content/uploads/Jamaican-Restaurant-Chain-Opens-New-Eatery-In-Rochester-Minnesota-768x614.jpg 768w, https://jamaicans.com/wp-content/uploads/Jamaican-Restaurant-Chain-Opens-New-Eatery-In-Rochester-Minnesota.jpg 1000w" sizes="(max-width: 810px) 100vw, 810px" />
</div>
<div class="entry-content">
<div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="1532314968" data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="at-above-post addthis_tool" data-url="http://jamaicans.com/jamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota/"></div><p>The new Jerk King restaurant, which is one of a chain that includes five restaurants in Canada, has opened in Peace Plaza on 1st Street in Rochester, Minnesota. The space is already being renovated, and the plan is to open the dining venue by the Christmas holiday. The restaurant chain is known for its Jamaican<a href="https://jamaicans.com/oven-roasted-jerk-chicken-recipe/"> jerk chicken</a> and other Caribbean-style dishes. According to Johnson Osel, the president of the Jerk King chain, plans are also in the works to offer standard American dishes as well. The 11,500-square-foot space will include a bar featuring Jamaican cocktails, with a great amount of rum. The restaurant is one of the first outside of Canada, although the chain expects to open a few of the eateries in the Twin Cities area in Minnesota as well. While Rochester is smaller than other locales considered for expansion, Ossie believes the restaurant is a good fit for the city as many people from around the world visit there. The expansion will cost about $135,000. The space has been empty since its former tenant Mac’s Café closed down.</p>
<div class="at-below-post addthis_tool" data-url="http://jamaicans.com/jamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota/"></div><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<script id="mNCC" language="javascript">
   medianet_width = "336";
   medianet_height = "280";
   medianet_crid = "849612493";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div>
</div>
<footer class="entry-footer">
<div class="meta-tags">
<a href="https://jamaicans.com/tag/jamaican-restaurant/" rel="tag">Jamaican Restaurant</a> </div>
</footer>
<div class="vce-share-bar">
<ul class="vce-share-items">
<li><a class="fa fa-facebook" href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fjamaicans.com%2Fjamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota%2F&amp;t=Jamaican%20Restaurant%20Chain%20Opens%20New%20Eatery%20In%20Rochester%2C%20Minnesota"></a></li><li><a class="fa fa-twitter" href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fjamaicans.com%2Fjamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota%2F&amp;text=Jamaican%20Restaurant%20Chain%20Opens%20New%20Eatery%20In%20Rochester%2C%20Minnesota"></a></li><li><a class="fa fa-google-plus" href="javascript:void(0);" data-url="https://plus.google.com/share?url=https%3A%2F%2Fjamaicans.com%2Fjamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota%2F"></a></li><li><a class="fa fa-pinterest" href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fjamaicans.com%2Fjamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota%2F&amp;media=https%3A%2F%2Fjamaicans.com%2Fwp-content%2Fuploads%2FJamaican-Restaurant-Chain-Opens-New-Eatery-In-Rochester-Minnesota.jpg&amp;description=Jamaican%20Restaurant%20Chain%20Opens%20New%20Eatery%20In%20Rochester%2C%20Minnesota"></a></li><li><a class="fa fa-linkedin" href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fjamaicans.com%2Fjamaican-restaurant-chain-opens-new-eatery-in-rochester-minnesota%2F&amp;title=Jamaican%20Restaurant%20Chain%20Opens%20New%20Eatery%20In%20Rochester%2C%20Minnesota"></a></li> </ul>
</div>
</article>
<nav class="prev-next-nav">
<div class="vce-next-link">
<a href="https://jamaicans.com/jamaican-males-bleaching-skin-more-than-women/" rel="prev"><span class="img-wrp"><img width="375" height="195" src="https://jamaicans.com/wp-content/uploads/Jamaican-Males-Bleaching-Skin-More-Than-Women-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="Jamaican Males Bleaching Skin More Than Women" /><span class="vce-pn-ico"><i class="fa fa fa-chevron-right"></i></span></span><span class="vce-prev-next-link">Jamaican Males Bleaching Skin More Than Women</span></a> </div>
</nav>
</main>
<section class="main-box mbt-border-top author-box">
<h3 class="main-box-title">About the author</h3>
<div class="main-box-inside">
<div class="data-image">
<img alt='' src='https://secure.gravatar.com/avatar/e2da7c869d4a6c93cae5e8d151fc0f2d?s=112&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e2da7c869d4a6c93cae5e8d151fc0f2d?s=224&#038;d=mm&#038;r=g 2x' class='avatar avatar-112 photo' height='112' width='112' /> </div>
<div class="data-content">
<h4 class="author-title">Staff Writer</h4>
<div class="data-entry-content">
</div>
</div>
</div>
<div class="vce-content-outside">
<div class="data-links">
<a href="https://jamaicans.com/author/staffwriter/" class="vce-author-link vce-button">View all posts</a>
</div>
<div class="vce-author-links">
<a href="https://www.jamaicans.com" target="_blank" class="fa fa-link vce-author-website"></a>
<a href="https://www.facebook.com/onelovejamaica" target="_blank" class="fa fa-facebook"></a>
<a href="https://google.com/+Jamaicans" target="_blank" class="fa fa-google"></a>
<a href="https://instagram.com/jamaicans_com" target="_blank" class="fa fa-instagram"></a>
<a href="https://twitter.com/jamaicansdotcom" target="_blank" class="fa fa-twitter"></a>
</div>
</div>
</section>
<div class="main-box vce-related-box">
<h3 class="main-box-title">You may also like</h3>
<div class="main-box-inside">
<article class="vce-post vce-lay-d post-115575 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-jamaican tag-marjory-stoneman-douglas-high-school tag-parkland tag-stoneman-douglas">
<div class="meta-image">
<a href="https://jamaicans.com/jamaican-17-teens-died-florida-school-shooting/" title="Jamaican Among 17 Teens Who Died in Florida School Shooting">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Jamaican-helena-ramsey-parkland-shooting-victim-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Jamaican Helena Ramsey Parkland Shooting victim" srcset="https://jamaicans.com/wp-content/uploads/Jamaican-helena-ramsey-parkland-shooting-victim-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Jamaican-helena-ramsey-parkland-shooting-victim-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/jamaican-17-teens-died-florida-school-shooting/" title="Jamaican Among 17 Teens Who Died in Florida School Shooting">Jamaican Among 17 Teens Who Died in Florida School...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-102100 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-dudus tag-portia-simpson-miller">
<div class="meta-image">
<a href="https://jamaicans.com/dudus-coke-and-portia-simpson-miller-are-not-dead/" title="Dudus Coke and Portia Simpson Miller Are Not Dead">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/11/Portia-Miller-Simpson-and-Dudus-Coke-Not-Dead-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Portia Miller-Simpson and Dudus Coke Not Dead" srcset="https://jamaicans.com/wp-content/uploads/2016/11/Portia-Miller-Simpson-and-Dudus-Coke-Not-Dead-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/11/Portia-Miller-Simpson-and-Dudus-Coke-Not-Dead-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/dudus-coke-and-portia-simpson-miller-are-not-dead/" title="Dudus Coke and Portia Simpson Miller Are Not Dead">Dudus Coke and Portia Simpson Miller Are Not Dead</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-114104 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-aidonia tag-barrington-levy tag-bunji-garlin tag-bustamante-hospital-for-children tag-capleton tag-chaka-demus-and-pliers tag-christopher-martin tag-dexta-daps tag-fay-ann-lyons tag-fetty-wap tag-junior-reid tag-professor-nuts tag-shaggy tag-shenseea tag-sting tag-third-world tag-wayne-wonder tag-wyclef-jean">
<div class="meta-image">
<a href="https://jamaicans.com/shaggy-friends-announce-2018-concert-date-line/" title="Shaggy &#038; Friends Announce 2018 Concert Date And Line-Up">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Shaggy-Friends-Announce-2018-Concert-Date-And-Line-Up-Jamaica-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Shaggy &amp; Friends Announce 2018 Concert Date And Line-Up Jamaica" srcset="https://jamaicans.com/wp-content/uploads/Shaggy-Friends-Announce-2018-Concert-Date-And-Line-Up-Jamaica-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Shaggy-Friends-Announce-2018-Concert-Date-And-Line-Up-Jamaica-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/shaggy-friends-announce-2018-concert-date-line/" title="Shaggy &#038; Friends Announce 2018 Concert Date And Line-Up">Shaggy &#038; Friends Announce 2018 Concert Date And...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-111833 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-fake-news tag-hurricane-harvey tag-usain-bolt">
<div class="meta-image">
<a href="https://jamaicans.com/fake-news-story-says-usain-bolt-donating-150-million-victims-hurricane-harvey/" title="Fake News Story Says Usain Bolt Donating $150 Million to Victims of Hurricane Harvey">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Usain-Bolt-Fake-News-Story-Hurricane-Harvey-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Usain Bolt Fake News Story Hurricane Harvey" srcset="https://jamaicans.com/wp-content/uploads/Usain-Bolt-Fake-News-Story-Hurricane-Harvey-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Usain-Bolt-Fake-News-Story-Hurricane-Harvey-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/fake-news-story-says-usain-bolt-donating-150-million-victims-hurricane-harvey/" title="Fake News Story Says Usain Bolt Donating $150 Million to Victims of Hurricane Harvey">Fake News Story Says Usain Bolt Donating $150 Million...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-120558 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-usain-bolt">
<div class="meta-image">
<a href="https://jamaicans.com/usain-bolt-opens-jamaican-restaurant-in-london/" title="Usain Bolt Opens Jamaican Restaurant in London">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Usain-Bolt-Opens-Jamaican-Restaurant-in-London-Jamaican-Steamed-Fish-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Usain Bolt Opens Jamaican Restaurant in London - Jamaican Steamed Fish" srcset="https://jamaicans.com/wp-content/uploads/Usain-Bolt-Opens-Jamaican-Restaurant-in-London-Jamaican-Steamed-Fish-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Usain-Bolt-Opens-Jamaican-Restaurant-in-London-Jamaican-Steamed-Fish-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/usain-bolt-opens-jamaican-restaurant-in-london/" title="Usain Bolt Opens Jamaican Restaurant in London">Usain Bolt Opens Jamaican Restaurant in London</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-105593 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-marley">
<div class="meta-image">
<a href="https://jamaicans.com/rohan-marley-lauryn-hill-welcome-birth-grandchild/" title="Rohan Marley and Lauryn Hill Welcome Birth of Grandchild">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2017/02/Zephaniah-Nesta-Marley-with-Rohan-Marley-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Rohan Marley with baby Zephaniah Nesta Marley" srcset="https://jamaicans.com/wp-content/uploads/2017/02/Zephaniah-Nesta-Marley-with-Rohan-Marley-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2017/02/Zephaniah-Nesta-Marley-with-Rohan-Marley-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/rohan-marley-lauryn-hill-welcome-birth-grandchild/" title="Rohan Marley and Lauryn Hill Welcome Birth of Grandchild">Rohan Marley and Lauryn Hill Welcome Birth of...</a></h2>
</header>
</article>
</div>
</div>
</div>
<aside id="sidebar" class="sidebar right">
<div id="search-4" class="widget widget_search"><form action="https://jamaicans.com/search-results/" class="search-form" method="get" role="search">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" title="Search for:" name="q" value="" placeholder="Search ..." class="search-field" />
</label>
<input type="submit" value="Search" class="search-submit" />
</form></div><div id="mks_social_widget-3" class="widget mks_social_widget"><h4 class="widget-title">Follow Us</h4>
<ul class="mks_social_widget_ul">
<li><a href="https://www.facebook.com/pages/Jamaicanscom/128078147433" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>facebook</span></a></li>
<li><a href="https://twitter.com/jamaicansdotcom" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>twitter</span></a></li>
<li><a href="https://google.com/+Jamaicans" title="Google Plus" class="google-plus_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>google-plus</span></a></li>
<li><a href="https://instagram.com/jamaicans_com" title="Instagram" class="instagram_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>instagram</span></a></li>
<li><a href="https://www.youtube.com/user/outofmanyonline" title="Youtube" class="youtube_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>youtube</span></a></li>
<li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="pinterest_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>pinterest</span></a></li>
<li><a href="https://jamaicansdotcom.tumblr.com/" title="Tumblr" class="tumblr_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>tumblr</span></a></li>
</ul>
</div><div id="mailerlite_widget-2" class="widget widget_mailerlite_widget">
<div id="mailerlite-form_1" data-temp-id="5be8ad4609cf2">
<div class="mailerlite-form">
<form action="" method="post">
<div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div>
<div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p>
</div>
<div class="mailerlite-form-inputs">
<div class="mailerlite-form-field">
<label for="mailerlite-1-field-email">Email</label>
<input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" />
</div>
<div class="mailerlite-form-loader">Please wait...</div>
<div class="mailerlite-subscribe-button-container">
<input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" />
</div>
<input type="hidden" name="form_id" value="1" />
<input type="hidden" name="action" value="mailerlite_subscribe_form" />
</div>
<div class="mailerlite-form-response">
<h4><p><span style="color: #339966;">Thank you for sign up!</span></p>
</h4>
</div>
</form>
</div>
</div>
<script type="text/javascript">
    (function() {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=5be8ad4609cf2] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                    submitHandler: function (form) {

                        jQuery(this.submitButton).prop('disabled', true);

                        form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                            form_container.find('.mailerlite-form-loader').fadeIn()
                                        });

                        var data = jQuery(form).serialize();

                        jQuery.post('https://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                            form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                                form_container.find('.mailerlite-form-response').fadeIn()
                                            });
                        });
                    }
            });
        });
    })();
</script>
</div><div id="vce_adsense_widget-8" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">
<a href='http://www.simbis.com/tools/phpAdsNew/adclick.php?n=a8466447' target='_blank'><img src='https://www.simbis.com/tools/phpAdsNew/adview.php?what=zone:5&amp;n=a8466447' border='0' alt=''></a> </div>
</div><div id="vce_adsense_widget-15" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">

<script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "250";
   medianet_crid = "966658449";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
</div><div id="vce_adsense_widget-2" class="widget vce_adsense_widget vce_adsense_expand"> <div class="vce_adsense_wrapper">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="3218061934"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</div><div id="vce_adsense_widget-13" class="widget vce_adsense_widget vce_adsense_expand"> <div class="vce_adsense_wrapper">
<a href="https://blog.amerijet.com/amerijet-easy-fast-reliable/?lrx=ibmwxo1476296317"><img src="https://www.jamaicans.com/images/ads/AmeriJet-Logo-3002.jpg" /></a>
<iframe width="300" height="102" src="about:blank" frameborder="0" allowfullscreen data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.youtube.com/embed/2XFghsPeJ9Q"></iframe><noscript><iframe width="300" height="102" src="https://www.youtube.com/embed/2XFghsPeJ9Q" frameborder="0" allowfullscreen></iframe></noscript> </div>
</div><div id="rss-5" class="widget widget_rss"><h4 class="widget-title"><a class="rsswidget" href="https://jamaicans.com/videos/?feed=rss2"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://jamaicans.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://jamaicans.com/videos">Videos</a></h4><ul><li><a class='rsswidget' href='https://jamaicans.com/videos/watch-fly-jamaica-flight-to-toronto-crash-lands-at-airport-in-guyana/'>WATCH: Fly Jamaica flight to Toronto crash lands at airport in Guyana</a></li><li><a class='rsswidget' href='https://jamaicans.com/videos/pressure-roasted-whole-chicken-recipe/'>Pressure Roasted Whole Chicken Recipe</a></li></ul></div><div id="vce_adsense_widget-14" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">
<a href="https://blog.amerijet.com/amerijet-easy-fast-reliable/?lrx=ibmwxo1476296317"><img src="https://news.jamaicans.com/wp-content/uploads/2018/03/amerijet-160x600.jpg" /></a>
<br><br>

<script id="mNCC" language="javascript">
    medianet_width = "250";
    medianet_height = "250";
    medianet_crid = "715859434";
    medianet_versionId = "3111299"; 
  </script>
<script src="//contextual.media.net/nmedianet.js?cid=8CUN66J27"></script> </div>
</div><div id="vce_adsense_widget-16" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">
<script src="//ap.lijit.com/www/delivery/fp?z=406528"></script> </div>
</div><div id="vce_adsense_widget-7" class="widget vce_adsense_widget vce_adsense_expand"> <div class="vce_adsense_wrapper">

<script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "600";
   medianet_crid = "526552473";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script> </div>
</div><div id="vce_adsense_widget-4" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">
<div id="amzn-assoc-ad-b16961e9-7a01-4871-a07e-eaeca02e8430"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=b16961e9-7a01-4871-a07e-eaeca02e8430"></script> </div>
</div><div id="vce_adsense_widget-10" class="widget vce_adsense_widget"> <div class="vce_adsense_wrapper">

<script id='x33x15351354282617836'>
var Tynt=Tynt||[];Tynt.push('abWrx44JCr4z2Wacwqm_6r');
Tynt.cmd=Tynt.cmd||[];Tynt.cmd.push(function(){
Tynt.ads.display('300x250','x33x15351354282617836','inpage');});
(function(){var h,s=document.createElement('script');
s.src=(window.location.protocol==='https:'?
'https':'http')+'://cdn.tynt.com/siab.js';
h=document.getElementsByTagName('script')[0];
h.parentNode.insertBefore(s,h);})();
</script>
 </div>
</div> </aside>
</div>
<footer id="footer" class="site-footer">
<div class="container">
<div class="container-fix">
<div class="bit-3">
<div id="mks_social_widget-2" class="widget mks_social_widget"><h4 class="widget-title">Socially Speaking</h4>
<ul class="mks_social_widget_ul">
<li><a href="https://www.facebook.com/onelovejamaica" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>facebook</span></a></li>
<li><a href="https://plus.google.com/+Jamaicans/" title="" class="googleplus_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>googleplus</span></a></li>
<li><a href="https://instagram.com/jamaicans_com" title="Instagram" class="instagram_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>instagram</span></a></li>
<li><a href="https://twitter.com/jamaicansdotcom" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>twitter</span></a></li>
<li><a href="https://www.youtube.com/user/outofmanyonline" title="Youtube" class="youtube_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>youtube</span></a></li>
<li><a href="https://jamaicans.com/?feed=rss" title="RSS" class="rss_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>rss</span></a></li>
<li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="pinterest_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>pinterest</span></a></li>
<li><a href="http://jamaicansdotcom.tumblr.com/" title="Tumblr" class="tumblr_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>tumblr</span></a></li>
</ul>
</div><div id="mailerlite_widget-3" class="widget widget_mailerlite_widget">
<div id="mailerlite-form_1" data-temp-id="5be8ad460b830">
<div class="mailerlite-form">
<form action="" method="post">
<div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div>
<div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p>
</div>
<div class="mailerlite-form-inputs">
<div class="mailerlite-form-field">
<label for="mailerlite-1-field-email">Email</label>
<input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" />
</div>
<div class="mailerlite-form-loader">Please wait...</div>
<div class="mailerlite-subscribe-button-container">
<input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" />
</div>
<input type="hidden" name="form_id" value="1" />
<input type="hidden" name="action" value="mailerlite_subscribe_form" />
</div>
<div class="mailerlite-form-response">
<h4><p><span style="color: #339966;">Thank you for sign up!</span></p>
</h4>
</div>
</form>
</div>
</div>
<script type="text/javascript">
    (function() {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=5be8ad460b830] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                    submitHandler: function (form) {

                        jQuery(this.submitButton).prop('disabled', true);

                        form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                            form_container.find('.mailerlite-form-loader').fadeIn()
                                        });

                        var data = jQuery(form).serialize();

                        jQuery.post('https://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                            form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                                form_container.find('.mailerlite-form-response').fadeIn()
                                            });
                        });
                    }
            });
        });
    })();
</script>
</div> </div>
<div class="bit-3">
<div id="vce_posts_widget-2" class="widget vce_posts_widget"><h4 class="widget-title">Random Jamaican Recipes</h4>
<ul class="vce-post-list" data-autoplay="">
<li>
<a href="https://jamaicans.com/chef-cunnys-jack-daniels-bbq-wings/" class="featured_image_sidebar" title="Chef Noel Cunningham BBQ Wings"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/chef-cunnys-jack-daniels-bbq-wings/" title="Chef Noel Cunningham BBQ Wings" class="vce-post-link">Chef Noel Cunningham BBQ Wings</a>
<div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/chef-cunnys-jack-daniels-bbq-wings/#respond"><span class="dsq-postid" data-dsqidentifier="97656 https://jamaicans.com/?p=97656">Add Comment</span></a></div></div>
</div>
</li>
<li>
<a href="https://jamaicans.com/non-pork-jamaican-stew-peas-recipe/" class="featured_image_sidebar" title="Miss G’s Simple Non-Pork Jamaican Stew Peas Recipe (Smoked Turkey)"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Miss-G-Simple-Non-Pork-Jamaican-Stew-Peas-Recipe-Smoked-Turkey-neck-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Miss G Simple Non-Pork Jamaican Stew Peas Recipe Smoked Turkey neck" srcset="https://jamaicans.com/wp-content/uploads/Miss-G-Simple-Non-Pork-Jamaican-Stew-Peas-Recipe-Smoked-Turkey-neck-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Miss-G-Simple-Non-Pork-Jamaican-Stew-Peas-Recipe-Smoked-Turkey-neck-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/non-pork-jamaican-stew-peas-recipe/" title="Miss G’s Simple Non-Pork Jamaican Stew Peas Recipe (Smoked Turkey)" class="vce-post-link">Miss G’s Simple Non-Pork Jamaican Stew Peas Recipe...</a>
</div>
</li>
<li>
<a href="https://jamaicans.com/jamaican-hardough-bread-recipe-2/" class="featured_image_sidebar" title="Chef Sian’s Jamaican Hardough Bread Recipe"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/07/hardough-bread-bread-cover-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://jamaicans.com/wp-content/uploads/2016/07/hardough-bread-bread-cover-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/07/hardough-bread-bread-cover-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/jamaican-hardough-bread-recipe-2/" title="Chef Sian’s Jamaican Hardough Bread Recipe" class="vce-post-link">Chef Sian’s Jamaican Hardough Bread Recipe</a>
<div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/jamaican-hardough-bread-recipe-2/#respond"><span class="dsq-postid" data-dsqidentifier="96191 https://jamaicans.com/?p=96191">Add Comment</span></a></div></div>
</div>
</li>
<li>
<a href="https://jamaicans.com/10-dishes-every-jamaican-should-know-how-to-cook/" class="featured_image_sidebar" title="10 Dishes Every Jamaican Should Know How to Cook"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2015/12/jamaican-ackee-and-salt-fish-recipe-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Jamaican Ackee and Saltfish Recipe" srcset="https://jamaicans.com/wp-content/uploads/2015/12/jamaican-ackee-and-salt-fish-recipe-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/12/jamaican-ackee-and-salt-fish-recipe-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/10-dishes-every-jamaican-should-know-how-to-cook/" title="10 Dishes Every Jamaican Should Know How to Cook" class="vce-post-link">10 Dishes Every Jamaican Should Know How to Cook</a>
<div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/10-dishes-every-jamaican-should-know-how-to-cook/#comments"><span class="dsq-postid" data-dsqidentifier="87765 https://jamaicans.com/?p=87765">4 Comments</span></a></div></div>
</div>
</li>
<li>
<a href="https://jamaicans.com/chefnels-caribbean-rum-wing-sauce/" class="featured_image_sidebar" title="ChefNel&#8217;s Caribbean Rum Wing Sauce"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="ChefNel&#039;s Caribbean Rum Sauce" srcset="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png 145w, https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-380x260.png 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/chefnels-caribbean-rum-wing-sauce/" title="ChefNel&#8217;s Caribbean Rum Wing Sauce" class="vce-post-link">ChefNel&#8217;s Caribbean Rum Wing Sauce</a>
</div>
</li>
</ul>
</div> </div>
<div class="bit-3">
<div id="vce_adsense_widget-9" class="widget vce_adsense_widget vce_adsense_expand"> <div class="vce_adsense_wrapper">
<div id="amzn-assoc-ad-e4689c20-dff8-4cad-9aa6-9cbb20113f59"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=e4689c20-dff8-4cad-9aa6-9cbb20113f59"></script> </div>
</div> </div>
</div>
</div>
<div class="container-full site-info">
<div align="center" style="padding-bottom: 20px;"> 
<script type="text/javascript">

<!--

google_ad_client = "pub-1901173274277249";

google_alternate_ad_url = "https://www.jamaicans.com/images/ads/google_728X90.htm";

google_ad_width = 728;

google_ad_height = 90;

google_ad_format = "728x90_as";

google_ad_type = "text_image";

google_ad_channel = "";

google_color_border = "798DC2";

google_color_bg = "FFFFFF";

google_color_link = "5870AE";

google_color_text = "676768";

google_color_url = "2C2F4B";

//-->

</script>
<script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script>

</div>
<div class="container">
<div class="vce-wrap-left">
<p>Copyright © Simbis Inc. All rights reserved. <a href="https://jamaicans.com/privacy/">Privacy Policy &amp; Terms of use</a>.</p> </div>
<div class="vce-wrap-right">
<ul id="vce_footer_menu" class="bottom-nav-menu"><li id="menu-item-76837" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76837"><a href="https://www.jamaicans.com/forums/">Forums</a></li>
<li id="menu-item-77461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77461"><a href="https://jamaicans.com/mobile-apps/">Mobile apps</a></li>
<li id="menu-item-76836" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76836"><a target="_blank" href="http://www.jamaicanstore.com">Shopping</a></li>
<li id="menu-item-459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-459"><a href="https://jamaicans.com/our-contact/">Contact</a></li>
<li id="menu-item-526" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-526"><a href="https://jamaicans.com/about-us/">About Us</a></li>
<li id="menu-item-77011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77011"><a href="https://jamaicans.com/advertise-with-us/">Advertise</a></li>
</ul> </div>
</div>
</div>
</footer>
</div>
</div>
<a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a>
<script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='433af38b6e2402a24dab9aa3d747b3033cf5bc5d8ebe9c002919c18dd0789a50';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script> <script type="application/javascript">
      var ajaxurl = "https://jamaicans.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }
    </script>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://jamaicans.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "ef05e177e0", post_id : 121053 } ); } ); /* ]]> */</script>
<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.1.8"; } if (window.wp_blog_version === undefined) { window.wp_blog_version = "4.9.8"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":"300"}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.1.8","plugin_mode":"WordPress","anonymous_profile_id":"wp-bf34677b4718a8fdb8e7d271cfbb868e","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=wp-bf34677b4718a8fdb8e7d271cfbb868e" async="async"></script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/jamaicans.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"jamaicanscom"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var vce_js_settings = {"sticky_header":"1","sticky_header_offset":"200","sticky_header_logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/08\/final-logo-abbr.png","logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/01\/jamaicans_logo.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"https:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"1","full_slider_autoplay":"","grid_slider_autoplay":"","grid_big_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"0","top_bar_mobile_group":"1","top_bar_more_link":null};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/themes/voice/js/min.js?ver=2.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fcaPcEvents = [];
var fcaPcDebug = {"debug":""};
var fcaPcPost = {"title":"Jamaican Restaurant Chain Opens New Eatery In Rochester, Minnesota","type":"post","id":"121053","categories":["Announcements"],"utm_support":"","user_parameters":"","edd_delay":"0","woo_delay":"0","edd_enabled":"","woo_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/facebook-conversion-pixel/pixel-cat.min.js?ver=2.4.0'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/wp-embed.min.js?ver=c914dae6e91b355e909bee01f0978470'></script>
<script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	s.src = !("IntersectionObserver" in w) ? "https://jamaicans.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-8.15.2.min.js" : "https://jamaicans.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-10.17.min.js";
	w.lazyLoadOptions = {
		elements_selector: "iframe",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		data_sizes: "lazy-sizes",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );
	
	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };
	
	observer.observe(b, config);
}, false);
</script>
</body>
</html>
