<!DOCTYPE html>
<!--[if IE 8]><html class="ie8"><![endif]-->
<!--[if IE 9]><html class="ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"> <!--<![endif]-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1, minimum-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />

<script>
			!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
			n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
			document,'script','https://connect.facebook.net/en_US/fbevents.js');
			fbq('init', '1055480241142713' );			fbq('track', 'PageView');

			</script>
<noscript><img height="1" width="1" style="display:none"
			src="https://www.facebook.com/tr?id=1055480241142713&ev=PageView&noscript=1"
			/></noscript>



<title>Top 7 Jamaican &amp; Caribbean News Stories You Missed The Week Ending January 22nd, 2021 - Jamaicans.com</title>
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://jamaicans.com/top-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Top 7 Jamaican &amp; Caribbean News Stories You Missed The Week Ending January 22nd, 2021 - Jamaicans.com" />
<meta property="og:description" content="THIS WEEK’S TOP NEWS STORIES JAMAICA’S MINISTER OF JUSTICE URGES SUPPORT FOR NATIONAL ID SYSTEM Delroy Chuck, Jamaica’s Minister of Justice, is calling on Jamaicans to lend their support to the National Identification System (NIDS), which is designed to prevent identity theft over cyber channels. Chuck described the critical nature of support for the system [&hellip;]" />
<meta property="og:url" content="http://jamaicans.com/top-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021/" />
<meta property="og:site_name" content="Jamaicans.com" />
<meta property="article:published_time" content="2021-01-22T14:45:13+00:00" />
<meta property="article:modified_time" content="2021-01-22T11:01:06+00:00" />
<meta property="og:image" content="https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3.png" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="480" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Staff Writer">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="5 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://jamaicans.com/#website","url":"https://jamaicans.com/","name":"Jamaicans.com","description":"Out of Many, One People Online","potentialAction":[{"@type":"SearchAction","target":"https://jamaicans.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://jamaicans.com/top-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021/#primaryimage","inLanguage":"en-US","url":"https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3.png","width":900,"height":480,"caption":"Top 7 Jamaican & Caribbean News Stories"},{"@type":"WebPage","@id":"https://jamaicans.com/top-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021/#webpage","url":"https://jamaicans.com/top-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021/","name":"Top 7 Jamaican & Caribbean News Stories You Missed The Week Ending January 22nd, 2021 - Jamaicans.com","isPartOf":{"@id":"https://jamaicans.com/#website"},"primaryImageOfPage":{"@id":"https://jamaicans.com/top-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021/#primaryimage"},"datePublished":"2021-01-22T14:45:13+00:00","dateModified":"2021-01-22T11:01:06+00:00","author":{"@id":"https://jamaicans.com/#/schema/person/95a513e9107a5911422833d07e6dddfc"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://jamaicans.com/top-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021/"]}]},{"@type":"Person","@id":"https://jamaicans.com/#/schema/person/95a513e9107a5911422833d07e6dddfc","name":"Staff Writer","image":{"@type":"ImageObject","@id":"https://jamaicans.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/77ecea7155e538bda1bbad3b3a6941cc?s=96&d=mm&r=g","caption":"Staff Writer"}}]}</script>

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Feed" href="https://jamaicans.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Comments Feed" href="https://jamaicans.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jamaicans.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=f98d59096dde3e8de0aae3f396c74601"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wgs2-css' href='https://jamaicans.com/wp-content/plugins/wp-google-search/wgs2.css?ver=f98d59096dde3e8de0aae3f396c74601' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://jamaicans.com/wp-includes/css/dist/block-library/style.min.css?ver=f98d59096dde3e8de0aae3f396c74601' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://jamaicans.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='kk-star-ratings-css' href='https://jamaicans.com/wp-content/plugins/kk-star-ratings/public/css/kk-star-ratings.css?ver=4.1.7' type='text/css' media='all' />
<style id='kk-star-ratings-inline-css' type='text/css'>
.kk-star-ratings .kksr-stars .kksr-star {
        margin-right: 4px;
    }
    [dir="rtl"] .kk-star-ratings .kksr-stars .kksr-star {
        margin-left: 4px;
        margin-right: 0;
    }
</style>
<link rel='stylesheet' id='mks_shortcodes_simple_line_icons-css' href='https://jamaicans.com/wp-content/plugins/meks-flexible-shortcodes/css/simple-line/simple-line-icons.css?ver=1.3.1' type='text/css' media='screen' />
<link rel='stylesheet' id='mks_shortcodes_css-css' href='https://jamaicans.com/wp-content/plugins/meks-flexible-shortcodes/css/style.css?ver=1.3.1' type='text/css' media='screen' />
<link rel='stylesheet' id='mailerlite_forms.css-css' href='https://jamaicans.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/css/mailerlite_forms.css?ver=1.4.8' type='text/css' media='all' />
<link rel='stylesheet' id='wpProQuiz_front_style-css' href='https://jamaicans.com/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all' />
<link rel='stylesheet' id='vce-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%7CRoboto+Slab%3A400%7COswald%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.9' type='text/css' media='all' />
<link rel='stylesheet' id='vce-style-css' href='https://jamaicans.com/wp-content/themes/voice/assets/css/min.css?ver=2.9' type='text/css' media='all' />
<style id='vce-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='meks-ads-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-easy-ads-widget/css/style.css?ver=2.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='meks_instagram-widget-styles-css' href='https://jamaicans.com/wp-content/plugins/meks-easy-instagram-widget/css/widget.css?ver=f98d59096dde3e8de0aae3f396c74601' type='text/css' media='all' />
<link rel='stylesheet' id='meks-flickr-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-simple-flickr-widget/css/style.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='meks-author-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-smart-author-widget/css/style.css?ver=1.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='meks-social-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-smart-social-widget/css/style.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='meks-themeforest-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-themeforest-smart-widget/css/style.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='meks_ess-main-css' href='https://jamaicans.com/wp-content/plugins/meks-easy-social-share/assets/css/main.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp_review-style-css' href='https://jamaicans.com/wp-content/plugins/wp-review/public/css/wp-review.css?ver=5.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css' href='https://jamaicans.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=f98d59096dde3e8de0aae3f396c74601' type='text/css' media='all' />
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-2520621-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-2520621-1", {"anonymize_ip":true});
</script>
<link rel="https://api.w.org/" href="https://jamaicans.com/wp-json/" /><link rel="alternate" type="application/json" href="https://jamaicans.com/wp-json/wp/v2/posts/146283" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jamaicans.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jamaicans.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://jamaicans.com/?p=146283' />
<link rel="alternate" type="application/json+oembed" href="https://jamaicans.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicans.com%2Ftop-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://jamaicans.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicans.com%2Ftop-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021%2F&#038;format=xml" />
<meta name="framework" content="Redux 4.1.24" /><meta name="generator" content="Site Kit by Google 1.24.0" />
<script>
(function(m,a,i,l,e,r){ m['MailerLiteObject']=e;function f(){
var c={ a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?v'+(~~(new Date().getTime()/1000000));
_.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');
</script>
 
<script>
        (function (m, a, i, l, e, r) {
            m['MailerLiteObject'] = e;

            function f() {
                var c = {a: arguments, q: []};
                var r = this.push(c);
                return "number" != typeof r ? r : f.bind(c.q);
            }

            f.q = f.q || [];
            m[e] = m[e] || f.bind(f.q);
            m[e].q = m[e].q || f.q;
            r = a.createElement(i);
            var _ = a.getElementsByTagName(i)[0];
            r.async = 1;
            r.src = l + '?' + (~~(new Date().getTime() / 10000000));
            _.parentNode.insertBefore(r, _);
        })(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

        var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');
    </script>

<script type="text/javascript">
                var rsssl_share_url = window.location.href.replace('https://', 'http://');
                var addthis_share = {url: '' + rsssl_share_url + ''};
            </script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-1901173274277249","enable_page_level_ads":true,"tag_partner":"site_kit"});</script> <style type="text/css" id="wp-custom-css">
			.main-box-head {display:none;}		</style>
<style>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
</head>
<body data-rssslsocial=1 data-rssslsocial=1 data-rsssl=1 class="post-template-default single single-post postid-146283 single-format-standard wp-embed-responsive vce-sid-right voice-v_2_9">
<div id="vce-main">
<header id="header" class="main-header">
<div class="container header-2-wrapper header-main-area">
<div class="vce-res-nav">
<a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a>
</div>
<div class="site-branding">
<span class="site-title"><a href="https://jamaicans.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><source srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><img src="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png" alt="Jamaicans.com"></picture></a></span></div>
<div class="vce-header-ads">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="5539842733" data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</div>
<div class="header-bottom-wrapper header-left-nav">
<div class="container">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-79827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79827 vce-cat-40"><a href="https://jamaicans.com/jamaica/culture-jamaica/">Culture</a><li id="menu-item-61427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61427"><a href="https://jamaicans.com/travel-jamaica/">Travel</a><li id="menu-item-83497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83497"><a href="https://jamaicans.com/recipes/">Food</a><li id="menu-item-77663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77663"><a href="https://jamaicans.com/speak-jamaican/">Speak JA</a><li id="menu-item-79829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79829 vce-cat-265"><a href="https://jamaicans.com/jamaica/jamaican-music/">Music</a><li id="menu-item-118281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118281"><a href="https://jamaicans.com/videos/%20">Videos</a><li id="menu-item-118279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118279"><a href="https://jamaicans.com/photogallery/">Photos</a><li id="menu-item-79826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79826 vce-cat-276"><a href="https://jamaicans.com/jamaica/jamaica-magazine/">JA Mag</a><li id="menu-item-79856" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-79856 vce-cat-267"><a href="https://jamaicans.com/jamaica/news-announcements/">News</a><li id="menu-item-61425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61425"><a href="https://jamaicans.com/jamaican-information/">Research JA</a></ul></nav> </div>
</div></header>
<div id="sticky_header" class="header-sticky">
<div class="container">
<div class="vce-res-nav">
<a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a>
</div>
<div class="site-branding">
<span class="site-title"><a href="https://jamaicans.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" srcset="https://jamaicans.com/wp-content/uploads/2015/08/final-logo-abbr.png"><source srcset="https://jamaicans.com/wp-content/uploads/2015/08/final-logo-abbr.png"><img src="https://jamaicans.com/wp-content/uploads/2015/08/final-logo-abbr.png" alt="Jamaicans.com"></picture></a></span></div> <nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="vce_main_navigation_menu" class="nav-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79827 vce-cat-40"><a href="https://jamaicans.com/jamaica/culture-jamaica/">Culture</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61427"><a href="https://jamaicans.com/travel-jamaica/">Travel</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83497"><a href="https://jamaicans.com/recipes/">Food</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77663"><a href="https://jamaicans.com/speak-jamaican/">Speak JA</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79829 vce-cat-265"><a href="https://jamaicans.com/jamaica/jamaican-music/">Music</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118281"><a href="https://jamaicans.com/videos/%20">Videos</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118279"><a href="https://jamaicans.com/photogallery/">Photos</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79826 vce-cat-276"><a href="https://jamaicans.com/jamaica/jamaica-magazine/">JA Mag</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-79856 vce-cat-267"><a href="https://jamaicans.com/jamaica/news-announcements/">News</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61425"><a href="https://jamaicans.com/jamaican-information/">Research JA</a></ul></nav> </div>
</div><div class='code-block code-block-6' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="8801353632" data-ad-format="link" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div id="main-wrapper">
<div class="vce-ad-below-header vce-ad-container">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2520621-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2520621-1');
</script>
</div>
<div id="content" class="container site-content vce-sid-right">
<div id="primary" class="vce-main-content">
<main id="main" class="main-box main-box-single">
<article id="post-146283" class="vce-single post-146283 post type-post status-publish format-standard has-post-thumbnail hentry category-news-announcements tag-caribbean-news tag-caribbean-weekly-news-summary tag-jamaican-news tag-jamaican-weekly-news-summary tag-news">
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/" class="category-267">Jamaican News &amp; Announcements</a></span>
<h1 class="entry-title">Top 7 Jamaican &#038; Caribbean News Stories You Missed The Week Ending January 22nd, 2021</h1>
<div class="entry-meta"><div class="meta-item date"><span class="updated">4 hours ago</span></div><div class="meta-item author"><span class="vcard author"><span class="fn">by <a href="https://jamaicans.com/author/developer/">Staff Writer</a></span></span></div></div>
</header>
<div class="meta-image">
<img width="810" height="432" src="https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3-810x432.png" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="weekly news stories you missed this week 3" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3-810x432.png 810w, https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3-300x160.png 300w, https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3-768x410.png 768w, https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3.png 900w" sizes="(max-width: 810px) 100vw, 810px" />
</div>
<div class="entry-content">
<div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="1532314968" data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="at-above-post addthis_tool" data-url="http://jamaicans.com/top-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021/"></div><h2><span style="font-weight: 400;">THIS WEEK’S TOP NEWS STORIES</span></h2>
<div id="attachment_114686" style="width: 518px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-114686" loading="lazy" class=" wp-image-114686" src="https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3-300x160.png" alt="weekly news stories you missed this week 3" width="508" height="271" srcset="https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3-300x160.png 300w, https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3-768x410.png 768w, https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3-810x432.png 810w, https://jamaicans.com/wp-content/uploads/weekly-news-stories-you-missed-this-week-3.png 900w" sizes="(max-width: 508px) 100vw, 508px" /><p id="caption-attachment-114686" class="wp-caption-text">Top 7 Jamaican &amp; Caribbean News Stories</p></div>
<p><span style="font-weight: 400;">JAMAICA’S MINISTER OF JUSTICE URGES SUPPORT FOR NATIONAL ID SYSTEM<br />
</span><span style="font-weight: 400;">Delroy Chuck, Jamaica’s Minister of Justice, is calling on Jamaicans to lend their support to the <a href="http://www.jamaicaobserver.com/latestnews/Justice_minister_calls_on_Jamaicans_to_support_NIDS?profile=1228">National Identification System (NIDS)</a>, which is designed to prevent identity theft over cyber channels. Chuck described the critical nature of support for the system at the third Joint Select Committee on National Identification &amp; Registration Act, 2020, Virtual Town Hall Meeting. He noted that one of the benefits of NIDS when it is implemented is avoidance of identity theft and said that many Jamaicans have experienced the negative consequences of identity theft and seen their bank accounts robbed by criminals who use their stolen personal information. </span></p>
<p><span style="font-weight: 400;">POLICE COMMISSIONER OF JAMAICA SAYS IT IS SAFE TO RETURN TO THE ISLAND<br />
</span><span style="font-weight: 400;">In response to concerns from Jamaicans around the world who have not wanted to return to Jamaica on a permanent basis because of its high crime levels, Police Commissioner Major General Antony Anderson is providing reassurance that the crime situation is not as bad as publicized. He said that the media portrays the problem in an exaggerated way. Specifically, Anderson said that what remains untold in many cases is who has committed the crimes and who are affected by them. For example, the media does not say when a crime is the result of a domestic problem as opposed to a stranger situation. The Jamaican government has implemented states of emergency in areas of St. James, Kingston, and St. Catherine, as well as zones of special operation (ZOSO), which have contributed to a decline in major crimes in recent years. </span></p>
<h2><span style="font-weight: 400;">THIS WEEK’S TOP CARIBBEAN NEWS</span></h2>
<div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-1901173274277249" data-ad-slot="1751381785"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><span style="font-weight: 400;">LEADERS OF CARIBBEAN NATIONS WELCOME BIDEN/HARRIS ADMINISTRATION<br />
</span><span style="font-weight: 400;">Caribbean leaders have welcomed the official start of the Joe <a href="https://jamaicans.com/chronixx-featured-on-biden-harris-inauguration-playlist/">Biden</a>/Kamala Harris presidential administration in the United States, with the Prime Minister of Dominica Roosevelt Skerrit saying he was looking forward to working with the new administration to enhance the prosperity of both nations. Mia Mottley, Prime Minister of Barbados also welcomed the change in the US top-level administration. The President of Guyana Irfaan Ali said his country is ready to stand with the new US president and vice-president in calls for unity and democracy. Vice-president Kamala Harris is the first Black and Caribbean <a href="https://jamaicans.com/jamaican-american-christina-cooper-featured-in-forbes-for-influence-on-2021-fashion-trends/">American</a> to serve in that role in US history, and she thanked Caribbean American voters for helping to ensure the victory of the Biden/Harris ticket.</span></p>
<h2><span style="font-weight: 400;">THIS WEEK’S TOP JAMAICAN DIASPORA NEWS</span></h2>
<p><span style="font-weight: 400;">JAMAICANS IN DIASPORA SEE NEW HOPE WITH BIDEN/HARRIS LEADING U.S.<br />
</span><span style="font-weight: 400;">Thousands of Jamaicans and other Caribbean nationals in the Diaspora are feeling hopeful about their status as immigrants in the United States with the coming to power of President Joe Biden and Vice-President Kamala Harris. Biden has already put forward a new immigration law providing a pathway to citizenship for the 11 million-plus people who currently live in the US illegally. The proposed legislation would allow undocumented individuals to apply for temporary legal status, and after five years, pending criminal and national-security background checks and proof of tax compliance, they would be able to apply for green cards. </span></p>
<h2><span style="font-weight: 400;">THIS WEEK’S TOP BUSINESS NEWS </span></h2>
<p><span style="font-weight: 400;">JAMPRO SIGNS MEMORANDUM OF UNDERSTANDING WITH CARIBBEAN CHAMBER OF COMMERCE IN EUROPE<br />
</span><span style="font-weight: 400;">The Jamaica Promotions Corporation (JAMPRO) has entered into an agreement via a Memorandum of Understanding (MOU) with the Caribbean Chamber of Commerce in Europe (CCCE) to increase trade and commerce between Jamaica and the United Kingdom and Europe. The MOU is also meant to increase European investment in Jamaica. It covers four critical areas of partnership: provision of market intelligence and market information, new matchmaking for business partners, technical assistance and support, and allowing the sourcing of investment partners and funding. The MOU is a one-year agreement that targets the Jamaica sectors of Agriculture and Agri-business, Creative industries, Energy, Global Digital and ICT and Knowledge Services, Logistics and Infrastructure, and Manufacturing.</span></p><div class='code-block code-block-5' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="7013629244"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<h2><span style="font-weight: 400;">THIS WEEK’S TOP ARTS &amp; ENTERTAINMENT NEWS</span></h2>
<p><span style="font-weight: 400;">REGGAE HISTORIAN CALLS FOR JAMAICAN REGGAE HALL OF FAME<br />
</span><span style="font-weight: 400;">Roger Steffens, a noted reggae historian, is calling for a Reggae Music Hall of Fame, criticizing local authorities for the lack of such an institution. He made his remarks following his efforts to have the late Toots Hibbert inducted into the Rock and Roll Hall of Fame. Bob Marley and Jimmy Cliff were inducted in 1994 and 2009, respectively. Steffens says other Jamaicans should be inducted, but says it would be better to have a Jamaican Reggae Hall of Fame to recognize artists like Peter Tosh,</span> <span style="font-weight: 400;">Joe Higgs, Coxsone Dodd, King Tubby, Roy Shirley, Alton Ellis, Slim Smith, Jimmy Riley, Justin Hinds, Dennis Brown, Jacob Miller, Prince Buster, Duke Reid, King Tubby, the Mighty Diamonds, and Culture. Steffens is said to have the largest collection of Jamaican music memorabilia in the world and believes it was “full time” that Toots Hibbert, credited with giving the reggae genre its name, be recognized at a high level.</span></p>
<h2><span style="font-weight: 400;">THIS WEEK’S TOP SPORTS NEWS</span></h2>
<p><span style="font-weight: 400;">NEW ATHLETICS CLUB FORMED TO RECOGNIZE NEW YOUNG TRACK-AND-FIELD TALENT<br />
</span><span style="font-weight: 400;">Omar Hawes, the head coach of the new Calabar-based Legacy Athletics club, believes that the organization has already gathered an impressive group of athletes to meet its goal of positioning itself as one of the major track-and-field clubs in the world. Legacy Athletics was created in 2020 at Calabar High School and included Olympians Deuce Carter and Jura Levy, Tyreke Wilson, Michael Bentley, Anthony Carpenter, Dejour Russell, Crystal Morrison, and Malik James King among those training with the club. Hawes is along-time coach at Calabar and said the club was formed to enhance the energy surrounding Jamaica’s track-and-field athletes and to develop top-class senior athletes at the global level. He wants to duplicate the energy spurred by Olympian Usain Bolt in past years. </span></p>
<div style="display: none;" class="kk-star-ratings kksr-valign-bottom kksr-align-center " data-id="146283" data-slug="">
<div class="kksr-stars">
<div class="kksr-stars-inactive">
<div class="kksr-star" data-star="1">
<div class="kksr-icon" style="width: 24px; height: 24px;"></div>
</div>
<div class="kksr-star" data-star="2">
<div class="kksr-icon" style="width: 24px; height: 24px;"></div>
</div>
<div class="kksr-star" data-star="3">
<div class="kksr-icon" style="width: 24px; height: 24px;"></div>
</div>
<div class="kksr-star" data-star="4">
<div class="kksr-icon" style="width: 24px; height: 24px;"></div>
</div>
<div class="kksr-star" data-star="5">
<div class="kksr-icon" style="width: 24px; height: 24px;"></div>
</div>
</div>
<div class="kksr-stars-active" style="width: 0px;">
<div class="kksr-star">
<div class="kksr-icon" style="width: 24px; height: 24px;"></div>
</div>
<div class="kksr-star">
<div class="kksr-icon" style="width: 24px; height: 24px;"></div>
</div>
<div class="kksr-star">
<div class="kksr-icon" style="width: 24px; height: 24px;"></div>
</div>
<div class="kksr-star">
<div class="kksr-icon" style="width: 24px; height: 24px;"></div>
</div>
<div class="kksr-star">
<div class="kksr-icon" style="width: 24px; height: 24px;"></div>
</div>
</div>
</div>
<div class="kksr-legend">
<span class="kksr-muted">Rate this post</span>
</div>
</div>
<div class="at-below-post addthis_tool" data-url="http://jamaicans.com/top-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021/"></div><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>

<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="8801353632" data-ad-format="link" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

</div>
<footer class="entry-footer">
<div class="meta-tags">
<a href="https://jamaicans.com/tag/caribbean-news/" rel="tag">Caribbean News</a> <a href="https://jamaicans.com/tag/caribbean-weekly-news-summary/" rel="tag">Caribbean Weekly News Summary</a> <a href="https://jamaicans.com/tag/jamaican-news/" rel="tag">JAMAICAN NEWS</a> <a href="https://jamaicans.com/tag/jamaican-weekly-news-summary/" rel="tag">Jamaican Weekly News Summary</a> <a href="https://jamaicans.com/tag/news/" rel="tag">news</a> </div>
</footer>
<div class="vce-share-bar">
<ul class="vce-share-items">
<div class="meks_ess rectangle no-labels"><a href="javascript:void(0);" class="meks_ess-item socicon-facebook" data-url="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fjamaicans.com%2Ftop-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021%2F&amp;t=Top%207%20Jamaican%20%26%20Caribbean%20News%20Stories%20You%20Missed%20The%20Week%20Ending%20January%2022nd%2C%202021"><span>Facebook</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-twitter" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fjamaicans.com%2Ftop-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021%2F&amp;text=Top%207%20Jamaican%20%26%20Caribbean%20News%20Stories%20You%20Missed%20The%20Week%20Ending%20January%2022nd%2C%202021"><span>Twitter</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-reddit" data-url="http://www.reddit.com/submit?url=https%3A%2F%2Fjamaicans.com%2Ftop-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021%2F&amp;title=Top%207%20Jamaican%20%26%20Caribbean%20News%20Stories%20You%20Missed%20The%20Week%20Ending%20January%2022nd%2C%202021"><span>Reddit</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-pinterest" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fjamaicans.com%2Ftop-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021%2F&amp;media=https%3A%2F%2Fjamaicans.com%2Fwp-content%2Fuploads%2Fweekly-news-stories-you-missed-this-week-3.png&amp;description=Top%207%20Jamaican%20%26%20Caribbean%20News%20Stories%20You%20Missed%20The%20Week%20Ending%20January%2022nd%2C%202021"><span>Pinterest</span></a><a href="/cdn-cgi/l/email-protection#ebd4989e89818e889fd6bf849bced9dbdcced9dba18a868a82888a85ced9dbced9ddced9dba88a998289898e8a85ced9dba58e9c98ced9dbb89f8499828e98ced9dbb2849eced9dba68298988e8fced9dbbf838eced9dbbc8e8e80ced9dbae858f82858cced9dba18a859e8a9992ced9dbd9d9858fced9a8ced9dbd9dbd9dacd8a869bd089848f92d6839f9f9b98ced8aaced9adced9ad818a868a82888a8598c5888486ced9ad9f849bc6dcc6818a868a82888a85c6888a998289898e8a85c6858e9c98c6989f8499828e98c692849ec6868298988e8fc69f838ec69c8e8e80c68e858f82858cc6818a859e8a9992c6d9d9858fc6d9dbd9daced9ad" class="socicon-mail prevent-share-popup "><span>Email</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-linkedin" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fjamaicans.com%2Ftop-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021%2F&amp;title=Top%207%20Jamaican%20%26%20Caribbean%20News%20Stories%20You%20Missed%20The%20Week%20Ending%20January%2022nd%2C%202021"><span>LinkedIn</span></a><a href="https://api.whatsapp.com/send?text=Top%207%20Jamaican%20%26%20Caribbean%20News%20Stories%20You%20Missed%20The%20Week%20Ending%20January%2022nd%2C%202021 https%3A%2F%2Fjamaicans.com%2Ftop-7-jamaican-caribbean-news-stories-you-missed-the-week-ending-january-22nd-2021%2F" class="meks_ess-item socicon-whatsapp prevent-share-popup"><span>WhatsApp</span></a></div> </ul>
</div>
</article>
<center>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-1901173274277249" data-ad-slot="7034397275"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></center>

<section class="main-box mbt-border-top author-box">
<h3 class="main-box-title">About the author</h3>
<div class="main-box-inside">
<div class="data-image">
<img alt='' src='https://secure.gravatar.com/avatar/77ecea7155e538bda1bbad3b3a6941cc?s=112&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/77ecea7155e538bda1bbad3b3a6941cc?s=224&#038;d=mm&#038;r=g 2x' class='avatar avatar-112 photo' height='112' width='112' loading='lazy' /> </div>
<div class="data-content">
<h4 class="author-title">Staff Writer</h4>
<div class="data-entry-content">
</div>
</div>
</div>
<div class="vce-content-outside">
<div class="data-links">
<a href="https://jamaicans.com/author/developer/" class="vce-author-link vce-button">View all posts</a>
</div>
<div class="vce-author-links">
</div>
</div>
</section>
<div class="main-box vce-related-box">
<h3 class="main-box-title">You may also like</h3>
<div class="main-box-inside">
<article class="vce-post vce-lay-d post-130578 post type-post status-publish format-standard has-post-thumbnail hentry category-news-announcements tag-flourgon tag-miley-cyrus">
<div class="meta-image">
<a href="https://jamaicans.com/miley-cyrus-settles-300-million-lawsuit-with-jamaican-reggae-artist-flourgon/" title="Miley Cyrus Settles $300 Million Lawsuit With Jamaican Reggae Artist, Flourgon">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Flourgan-Reggae-Artist-e1578109294888-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Flourgan Reggae Artist" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Flourgan-Reggae-Artist-e1578109294888-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Flourgan-Reggae-Artist-e1578109294888-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/" class="category-267">Jamaican News &amp; Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/miley-cyrus-settles-300-million-lawsuit-with-jamaican-reggae-artist-flourgon/" title="Miley Cyrus Settles $300 Million Lawsuit With Jamaican Reggae Artist, Flourgon">Miley Cyrus Settles $300 Million Lawsuit With Jamaican...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-100262 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-barack-obama tag-bob-marley tag-president-barack-obama tag-rita-marley">
<div class="meta-image">
<a href="https://jamaicans.com/rita-marley-widow-of-bob-marley-hospitalized-in-miami/" title="Rita Marley, Widow of Bob Marley, Hospitalized in Miami">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/rita_marley~s800x800-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/rita_marley~s800x800-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/rita_marley~s800x800-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/rita-marley-widow-of-bob-marley-hospitalized-in-miami/" title="Rita Marley, Widow of Bob Marley, Hospitalized in Miami">Rita Marley, Widow of Bob Marley, Hospitalized in Miami</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-135785 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-jamaican-achievement tag-jamaican-flag">
<div class="meta-image">
<a href="https://jamaicans.com/jamaican-flag-wins-it-all-in-the-world-cup-of-flags-2020-competition/" title="Jamaican Flag Wins it all in the World Cup of Flags 2020 Competition">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Jamaican-Flag-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Flag of Jamaica" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Jamaican-Flag-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Jamaican-Flag-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/jamaican-flag-wins-it-all-in-the-world-cup-of-flags-2020-competition/" title="Jamaican Flag Wins it all in the World Cup of Flags 2020 Competition">Jamaican Flag Wins it all in the World Cup of Flags...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-128279 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-miss-jamaica-world tag-toni-ann-singh">
<div class="meta-image">
<a href="https://jamaicans.com/toni-ann-singh-crowned-miss-jamaica-world-2019/" title="Toni-Ann Singh Crowned Miss Jamaica World 2019">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Toni-Ann-Singh-Crowned-Miss-Jamaica-World-2019-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Toni-Ann Singh Crowned Miss Jamaica World 2019" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Toni-Ann-Singh-Crowned-Miss-Jamaica-World-2019-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Toni-Ann-Singh-Crowned-Miss-Jamaica-World-2019-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/toni-ann-singh-crowned-miss-jamaica-world-2019/" title="Toni-Ann Singh Crowned Miss Jamaica World 2019">Toni-Ann Singh Crowned Miss Jamaica World 2019</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-132902 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-green-card tag-united-states-permanent-residency">
<div class="meta-image">
<a href="https://jamaicans.com/us-issues-new-laws-for-green-card-holders-from-caribbean/" title="US Issues New Laws for Green Card Holders from Caribbean">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Green-Card-Permanent-Resident-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="American Green Card - United States Permanent Residency Card Closeup." loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Green-Card-Permanent-Resident-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Green-Card-Permanent-Resident-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/us-issues-new-laws-for-green-card-holders-from-caribbean/" title="US Issues New Laws for Green Card Holders from Caribbean">US Issues New Laws for Green Card Holders from...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-90387 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements">
<div class="meta-image">
<a href="https://jamaicans.com/dna-proves-that-fabian-marley-is-not-the-son-of-bob-marley/" title="DNA proves that Fabian  Marley  Is Not The Son of Bob Marley">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/01/fabina-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Fabian Marley" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2016/01/fabina-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/01/fabina-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/dna-proves-that-fabian-marley-is-not-the-son-of-bob-marley/" title="DNA proves that Fabian  Marley  Is Not The Son of Bob Marley">DNA proves that Fabian Marley Is Not The Son of Bob...</a></h2>
</header>
</article>
</div>
</div>
</div>
<aside id="sidebar" class="sidebar right">
<div id="search-2" class="widget widget_search"><form class="vce-search-form" action="https://jamaicans.com/" method="get">
<input name="s" class="vce-search-input" size="20" type="text" value="Type here to search..." onfocus="(this.value == 'Type here to search...') && (this.value = '')" onblur="(this.value == '') && (this.value = 'Type here to search...')" placeholder="Type here to search..." />
<button type="submit" class="vce-search-submit"><i class="fa fa-search"></i></button>
</form></div><div id="custom_html-5" class="widget_text vce-no-padding widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="3218061934"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="custom_html-21" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://www.westernunion.com/us/en/web/send-money/start?SrcCode=12345&ReceiveCountry=US&SendAmount=100&ISOCurrency=CNY&FundsOut=BA&FundsIn=CreditCard/">
<img src="https://news.jamaicans.com/wp-content/uploads/2020/10/western-union-jamaica-october-novermber-2020.jpg">
</a>
</div></div><div id="mailerlite_widget-2" class="widget widget_mailerlite_widget">
<div id="mailerlite-form_1" data-temp-id="600b228387261">
<div class="mailerlite-form">
 <form action="" method="post">
<div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div>
<div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p>
</div>
<div class="mailerlite-form-inputs">
<div class="mailerlite-form-field">
<label for="mailerlite-1-field-email">Email</label>
<input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" />
</div>
<div class="mailerlite-form-loader">Please wait...</div>
<div class="mailerlite-subscribe-button-container">
<input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" />
</div>
<input type="hidden" name="form_id" value="1" />
<input type="hidden" name="action" value="mailerlite_subscribe_form" />
<input type="hidden" name="ml_nonce" value="e29e437469" />
</div>
<div class="mailerlite-form-response">
<h4><p><span style="color: #339966;">Thank you for sign up!</span></p>
</h4>
</div>
</form>
</div>
</div>
<script type="text/javascript">
    window.addEventListener("load", function (event) {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=600b228387261] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                submitHandler: function (form) {

                    jQuery(this.submitButton).prop('disabled', true);

                    form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                        form_container.find('.mailerlite-form-loader').fadeIn()
                    });

                    var data = jQuery(form).serialize();

                    jQuery.post('https://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                        form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                            form_container.find('.mailerlite-form-response').fadeIn()
                        });
                    });
                }
            });
        });
    }, false);
</script>
</div><div id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "250";
   medianet_crid = "966658449";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div></div><div id="mks_social_widget-3" class="widget mks_social_widget"><h4 class="widget-title">Follow Us</h4>
<ul class="mks_social_widget_ul">
<li><a href="https://www.facebook.com/pages/Jamaicanscom/128078147433" title="Facebook" class="socicon-facebook soc_square" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>facebook</span></a></li>
<li><a href="https://twitter.com/jamaicansdotcom" title="Twitter" class="socicon-twitter soc_square" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>twitter</span></a></li>
<li><a href="https://instagram.com/jamaicans_com" title="Instagram" class="socicon-instagram soc_square" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>instagram</span></a></li>
<li><a href="https://www.youtube.com/user/outofmanyonline" title="YouTube" class="socicon-youtube soc_square" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>youtube</span></a></li>
<li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="socicon-pinterest soc_square" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>pinterest</span></a></li>
<li><a href="https://jamaicansdotcom.tumblr.com/" title="tumblr" class="socicon-tumblr soc_square" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>tumblr</span></a></li>
</ul>
</div><div id="rss-5" class="widget widget_rss"><h4 class="widget-title"><a class="rsswidget" href="https://jamaicans.com/videos/?feed=rss2"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://jamaicans.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://jamaicans.com/videos">Videos</a></h4><ul><li><a class='rsswidget' href='https://jamaicans.com/videos/watch-how-to-make-an-easy-fish-chips-for-easter-fish-recipe/'>WATCH: HOW TO MAKE AN EASY FISH &amp; CHIPS FOR EASTER | Fish Recipe</a></li><li><a class='rsswidget' href='https://jamaicans.com/videos/watch-hennessy-spiked-bacon-shrimp-rigatoni-baked-surf-turf/'>WATCH: Hennessy Spiked Bacon &amp; Shrimp Rigatoni Baked Surf &amp; Turf</a></li></ul></div><div id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="text/javascript" src="//ap.lijit.com/www/delivery/fp?z=406528"></script></div></div><div id="custom_html-7" class="widget_text vce-no-padding widget widget_custom_html"><div class="textwidget custom-html-widget">
<script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "600";
   medianet_crid = "526552473";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div><div id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<script id='x33x15351354282617836'>
var Tynt=Tynt||[];Tynt.push('abWrx44JCr4z2Wacwqm_6r');
Tynt.cmd=Tynt.cmd||[];Tynt.cmd.push(function(){
Tynt.ads.display('300x250','x33x15351354282617836','inpage');});
(function(){var h,s=document.createElement('script');
s.src=(window.location.protocol==='https:'?
'https':'http')+'://cdn.tynt.com/siab.js';
h=document.getElementsByTagName('script')[0];
h.parentNode.insertBefore(s,h);})();
</script>
</div></div><div class="vce-sticky"><div id="ai_widget-2" class="widget ai_widget ai-viewport-1"><div class='code-block code-block-7' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="7013629244"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div></div> </aside>
</div>
<footer id="footer" class="site-footer">
<div class="container">
<div class="container-fix">
<div class="bit-3">
<div id="mks_social_widget-2" class="widget mks_social_widget"><h4 class="widget-title">Socially Speaking</h4>
<ul class="mks_social_widget_ul">
<li><a href="https://www.facebook.com/onelovejamaica" title="Facebook" class="socicon-facebook soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>facebook</span></a></li>
<li><a href="https://instagram.com/jamaicans_com" title="Instagram" class="socicon-instagram soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>instagram</span></a></li>
<li><a href="https://twitter.com/jamaicansdotcom" title="Twitter" class="socicon-twitter soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>twitter</span></a></li>
<li><a href="https://www.youtube.com/user/outofmanyonline" title="YouTube" class="socicon-youtube soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>youtube</span></a></li>
<li><a href="https://jamaicans.com/?feed=rss" title="RSS" class="socicon-rss soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>rss</span></a></li>
<li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="socicon-pinterest soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>pinterest</span></a></li>
<li><a href="http://jamaicansdotcom.tumblr.com/" title="tumblr" class="socicon-tumblr soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>tumblr</span></a></li>
<li><a href="https://jm.linkedin.com/company/jamaicans-com" title="Linkedin" class="socicon-linkedin soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>linkedin</span></a></li>
</ul>
</div><div id="mailerlite_widget-3" class="widget widget_mailerlite_widget">
<div id="mailerlite-form_1" data-temp-id="600b2285258e5">
<div class="mailerlite-form">
<form action="" method="post">
<div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div>
<div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p>
</div>
<div class="mailerlite-form-inputs">
<div class="mailerlite-form-field">
<label for="mailerlite-1-field-email">Email</label>
<input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" />
</div>
<div class="mailerlite-form-loader">Please wait...</div>
<div class="mailerlite-subscribe-button-container">
<input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" />
</div>
<input type="hidden" name="form_id" value="1" />
<input type="hidden" name="action" value="mailerlite_subscribe_form" />
<input type="hidden" name="ml_nonce" value="e29e437469" />
</div>
<div class="mailerlite-form-response">
<h4><p><span style="color: #339966;">Thank you for sign up!</span></p>
</h4>
</div>
</form>
</div>
</div>
<script type="text/javascript">
    window.addEventListener("load", function (event) {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=600b2285258e5] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                submitHandler: function (form) {

                    jQuery(this.submitButton).prop('disabled', true);

                    form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                        form_container.find('.mailerlite-form-loader').fadeIn()
                    });

                    var data = jQuery(form).serialize();

                    jQuery.post('https://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                        form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                            form_container.find('.mailerlite-form-response').fadeIn()
                        });
                    });
                }
            });
        });
    }, false);
</script>
</div> </div>
<div class="bit-3">
<div id="vce_posts_widget-2" class="widget vce_posts_widget"><h4 class="widget-title">Random Jamaican Recipes</h4>
<ul class="vce-post-list" data-autoplay="">
<li>
<a href="https://jamaicans.com/non-pork-jamaican-stew-peas-recipe/" class="featured_image_sidebar" title="Miss G’s Simple Non-Pork Jamaican Stew Peas Recipe (Smoked Turkey)"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Miss-G-Simple-Non-Pork-Jamaican-Stew-Peas-Recipe-Smoked-Turkey-neck-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Miss G Simple Non-Pork Jamaican Stew Peas Recipe Smoked Turkey neck" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Miss-G-Simple-Non-Pork-Jamaican-Stew-Peas-Recipe-Smoked-Turkey-neck-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Miss-G-Simple-Non-Pork-Jamaican-Stew-Peas-Recipe-Smoked-Turkey-neck-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/non-pork-jamaican-stew-peas-recipe/" title="Miss G’s Simple Non-Pork Jamaican Stew Peas Recipe (Smoked Turkey)" class="vce-post-link">Miss G’s Simple Non-Pork Jamaican Stew Peas Recipe...</a>
</div>
</li>
<li>
<a href="https://jamaicans.com/jamaican-blue-mountain-coffee-ice-cream-recipe/" class="featured_image_sidebar" title="Jamaican Blue Mountain Coffee Ice Cream Recipe"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Jamaican-Blue-Mountain-Coffee-Ice-Cream-Recipe-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Jamaican Blue Mountain Coffee Ice Cream Recipe" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Jamaican-Blue-Mountain-Coffee-Ice-Cream-Recipe-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Jamaican-Blue-Mountain-Coffee-Ice-Cream-Recipe-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/jamaican-blue-mountain-coffee-ice-cream-recipe/" title="Jamaican Blue Mountain Coffee Ice Cream Recipe" class="vce-post-link">Jamaican Blue Mountain Coffee Ice Cream Recipe</a>
</div>
</li>
<li>
<a href="https://jamaicans.com/chef-sians-peanut-porridge-recipe/" class="featured_image_sidebar" title="Chef Sian&#8217;s Peanut Porridge Recipe"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/chef-sians-peanut-porridge-recipe/" title="Chef Sian&#8217;s Peanut Porridge Recipe" class="vce-post-link">Chef Sian&#8217;s Peanut Porridge Recipe</a>
<div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/chef-sians-peanut-porridge-recipe/#respond"><span class="dsq-postid" data-dsqidentifier="101450 https://jamaicans.com/?p=101450">Add Comment</span></a></div></div>
</div>
</li>
<li>
<a href="https://jamaicans.com/tips-on-cooking-with-scotch-bonnet-pepper/" class="featured_image_sidebar" title="Tips on Cooking with Scotch Bonnet Pepper"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Tips-on-Cooking-with-Scotch-Bonnet-Pepper-Photo-by-Xavier-Murphy-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Tips on Cooking with Scotch Bonnet Pepper - Photo by Xavier Murphy" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Tips-on-Cooking-with-Scotch-Bonnet-Pepper-Photo-by-Xavier-Murphy-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Tips-on-Cooking-with-Scotch-Bonnet-Pepper-Photo-by-Xavier-Murphy-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/tips-on-cooking-with-scotch-bonnet-pepper/" title="Tips on Cooking with Scotch Bonnet Pepper" class="vce-post-link">Tips on Cooking with Scotch Bonnet Pepper</a>
</div>
</li>
<li>
<a href="https://jamaicans.com/chefnels-caribbean-rum-wing-sauce/" class="featured_image_sidebar" title="ChefNel&#8217;s Caribbean Rum Wing Sauce"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="ChefNel&#039;s Caribbean Rum Sauce" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png 145w, https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-380x260.png 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/chefnels-caribbean-rum-wing-sauce/" title="ChefNel&#8217;s Caribbean Rum Wing Sauce" class="vce-post-link">ChefNel&#8217;s Caribbean Rum Wing Sauce</a>
</div>
</li>
</ul>
</div> </div>
<div class="bit-3">
</div>
</div>
</div>
<div class="container-full site-info">
<div class="container">
<div class="vce-wrap-left">
<p>Copyright © Simbis Inc. All rights reserved. <a href="https://jamaicans.com/privacy/">Privacy Policy &amp; Terms of use</a>. Stock Photos from Photos.com, iStockPhotos.com, 123rf.</p> </div>
<div class="vce-wrap-right">
<ul id="vce_footer_menu" class="bottom-nav-menu"><li id="menu-item-76837" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76837"><a href="https://www.jamaicans.com/forums/">Forums</a></li>
<li id="menu-item-145195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145195"><a href="https://jamaicans.com/free-email/">Free Email</a></li>
<li id="menu-item-76836" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76836"><a target="_blank" rel="noopener" href="https://amzn.to/2JueBog">Shopping</a></li>
<li id="menu-item-459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-459"><a href="https://jamaicans.com/our-contact/">Contact</a></li>
<li id="menu-item-526" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-526"><a href="https://jamaicans.com/about-us/">About Us</a></li>
<li id="menu-item-77011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77011"><a href="https://jamaicans.com/advertise-with-us/">Advertise</a></li>
</ul>
</div>
</div>
</div>
</footer>
</div>
</div>
<a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://jamaicans.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "ce6b208ddf", post_id : 146283 } ); } ); /* ]]> */</script>
<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":"300"}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":6,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"services":"facebook,twitter,email,pinterest_share,whatsapp,addthis","elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":6,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"services":"facebook,twitter,email,pinterest_share,whatsapp,addthis","elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-bf34677b4718a8fdb8e7d271cfbb868e","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=wp-bf34677b4718a8fdb8e7d271cfbb868e" async="async"></script><script type='text/javascript' id='google_cse_v2-js-extra'>
/* <![CDATA[ */
var scriptParams = {"google_search_engine_id":"partner-pub-1901173274277249:8952111638"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/wp-google-search/assets/js/google_cse_v2.js?ver=1' id='google_cse_v2-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/jamaicans.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3.2' id='contact-form-7-js'></script>
<script type='text/javascript' id='kk-star-ratings-js-extra'>
/* <![CDATA[ */
var kk_star_ratings = {"action":"kk-star-ratings","endpoint":"https:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","nonce":"f10831a95c"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/kk-star-ratings/public/js/kk-star-ratings.js?ver=4.1.7' id='kk-star-ratings-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/meks-flexible-shortcodes/js/main.js?ver=1' id='mks_shortcodes_js-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' id='vce-main-js-extra'>
/* <![CDATA[ */
var vce_js_settings = {"sticky_header":"1","sticky_header_offset":"200","sticky_header_logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/08\/final-logo-abbr.png","logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/01\/jamaicans_logo.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"https:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","ajax_wpml_current_lang":null,"ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"1","full_slider_autoplay":"","grid_slider_autoplay":"","grid_big_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"0","top_bar_mobile_group":"1","top_bar_more_link":"More"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/themes/voice/assets/js/min.js?ver=2.9' id='vce-main-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/meks-easy-social-share/assets/js/main.js?ver=1.2.1' id='meks_ess-main-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/js/jquery.validate.min.js?ver=f98d59096dde3e8de0aae3f396c74601' id='jquery-validation-plugin-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/wp-review/public/js/js.cookie.min.js?ver=2.1.4' id='js-cookie-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' id='wp-util-js-extra'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/wp-util.min.js?ver=f98d59096dde3e8de0aae3f396c74601' id='wp-util-js'></script>
<script type='text/javascript' id='wp_review-js-js-extra'>
/* <![CDATA[ */
var wpreview = {"ajaxurl":"https:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","loginRequiredMessage":"You must log in to add your review"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/wp-review/public/js/main.js?ver=5.3.4' id='wp_review-js-js'></script>
<script type='text/javascript' id='fca_pc_client_js-js-extra'>
/* <![CDATA[ */
var fcaPcEvents = [];
var fcaPcDebug = {"debug":""};
var fcaPcPost = {"title":"Top 7 Jamaican & Caribbean News Stories You Missed The Week Ending January 22nd, 2021","type":"post","id":"146283","categories":["Jamaican News &amp; Announcements"],"utm_support":"","user_parameters":"","edd_delay":"0","woo_delay":"0","edd_enabled":"","woo_enabled":"","video_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/facebook-conversion-pixel/pixel-cat.min.js?ver=2.5.5' id='fca_pc_client_js-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/facebook-conversion-pixel/video.compiled.js?ver=f98d59096dde3e8de0aae3f396c74601' id='fca_pc_video_js-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/wp-embed.min.js?ver=f98d59096dde3e8de0aae3f396c74601' id='wp-embed-js'></script>
</body>
</html>
