<!DOCTYPE html><!--[if IE 8]><html class="ie8"><![endif]--> <!--[if IE 9]><html class="ie9"><![endif]--> <!--[if gt IE 8]><!--><html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" prefix="og: http://ogp.me/ns#"> <!--<![endif]--><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1"><title>Jamaican Actor Jason R. Moore Lands Leading Role on Netflix’s “The Punisher” - Interview - Jamaicans.com</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%7CRoboto%20Slab%3A400%7COswald%3A400&subset=" as="style" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" href="https://jamaicans.com/wp-content/cache/min/1/b9f078262ec545e71abf1dc80710e80f.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><!--[if lt IE 9]> <script src="https://jamaicans.com/wp-content/themes/voice/js/html5.js"></script> <![endif]--> <script type="text/javascript">if(document.location.protocol=='http:'){
 var Tynt=Tynt||[];Tynt.push('abWrx44JCr4z2Wacwqm_6r');
 (function(){var s=document.createElement('script');s.async="async";s.type="text/javascript";s.src='https://tcr.tynt.com/ti.js';var h=document.getElementsByTagName('script')[0];h.parentNode.insertBefore(s,h);})();
}</script> <title>Jamaican Actor Jason R. Moore Lands Leading Role on Netflix’s “The Punisher” - Interview - Jamaicans.com</title><link rel="preload" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%7CRoboto%20Slab%3A400%7COswald%3A400&subset=" as="style" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" href="https://jamaicans.com/wp-content/cache/min/1/b9f078262ec545e71abf1dc80710e80f.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /> <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
			n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
			document,'script','https://connect.facebook.net/en_US/fbevents.js');
			fbq('init', '1055480241142713' );			fbq('track', 'PageView');</script> <noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1055480241142713&ev=PageView&noscript=1"
/></noscript><meta name="description" content="Jamaican-born actor, Jason R. Moore stars in the Netflix remake of Marvel&#039;s &quot;The Punisher.&quot; We discuss life, Jamaica,music, and food with him." /><link rel="canonical" href="https://jamaicans.com/jamaican-actor-jason-r-moore-lands-leading-role-on-netflixs-the-punisher-interview/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Jamaican Actor Jason R. Moore Lands Leading Role on Netflix’s “The Punisher” - Interview - Jamaicans.com" /><meta property="og:description" content="Jamaican-born actor, Jason R. Moore stars in the Netflix remake of Marvel&#039;s &quot;The Punisher.&quot; We discuss life, Jamaica,music, and food with him." /><meta property="og:url" content="http://jamaicans.com/jamaican-actor-jason-r-moore-lands-leading-role-on-netflixs-the-punisher-interview/" /><meta property="og:site_name" content="Jamaicans.com" /><meta property="article:tag" content="Curtis Hoyle" /><meta property="article:tag" content="Interview" /><meta property="article:tag" content="Jamaica" /><meta property="article:tag" content="Jason Moore" /><meta property="article:tag" content="Netflix The Punisher" /><meta property="article:section" content="Interviews" /><meta property="article:published_time" content="2019-02-16T21:00:59+00:00" /><meta property="article:modified_time" content="2019-02-16T04:49:06+00:00" /><meta property="og:updated_time" content="2019-02-16T04:49:06+00:00" /><meta property="og:image" content="https://jamaicans.com/wp-content/uploads/Jamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher.jpg" /><meta property="og:image:secure_url" content="https://jamaicans.com/wp-content/uploads/Jamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher.jpg" /><meta property="og:image:width" content="747" /><meta property="og:image:height" content="491" /><meta property="og:image:alt" content="Jamaican Actor Jason R. Moore Lands Leading Role on Netflixs The Punisher" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Jamaican-born actor, Jason R. Moore stars in the Netflix remake of Marvel&#039;s &quot;The Punisher.&quot; We discuss life, Jamaica,music, and food with him." /><meta name="twitter:title" content="Jamaican Actor Jason R. Moore Lands Leading Role on Netflix’s “The Punisher” - Interview - Jamaicans.com" /><meta name="twitter:image" content="https://jamaicans.com/wp-content/uploads/Jamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher.jpg" /><meta name="twitter:creator" content="@drmrsmom" /><link rel='dns-prefetch' href='//static.mailerlite.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Feed" href="https://jamaicans.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Comments Feed" href="https://jamaicans.com/comments/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><style id='vce_style-inline-css' type='text/css'>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</style><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;background:#000;margin:5px}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://jamaicans.com/wp-content/plugins/wp-rocket/inc/front/img/youtube.png) no-repeat;cursor:pointer}</style> <script type='text/javascript' src='https://jamaicans.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4.js'></script> <script type='text/javascript' src='https://jamaicans.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-migrate.min-1.4.1.js' defer></script> <script type='text/javascript' src='https://static.mailerlite.com/js/jquery.validate.min.js?ver=cb79fc6e523936fdf7fa41e31b484781' defer></script> <link rel='https://api.w.org/' href='https://jamaicans.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jamaicans.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jamaicans.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://jamaicans.com/?p=122668' /><meta name="thumbnail" content="https://jamaicans.com/wp-content/uploads/Jamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher-150x150.jpg" /> <script>(function(m,a,i,l,e,r){ m['MailerLiteObject']=e;function f(){
var c={ a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?v'+(~~(new Date().getTime()/1000000));
_.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');</script> <script>(function (m, a, i, l, e, r) {
            m['MailerLiteObject'] = e;

            function f() {
                var c = {a: arguments, q: []};
                var r = this.push(c);
                return "number" != typeof r ? r : f.bind(c.q);
            }

            f.q = f.q || [];
            m[e] = m[e] || f.bind(f.q);
            m[e].q = m[e].q || f.q;
            r = a.createElement(i);
            var _ = a.getElementsByTagName(i)[0];
            r.async = 1;
            r.src = l + '?' + (~~(new Date().getTime() / 10000000));
            _.parentNode.insertBefore(r, _);
        })(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

        var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');</script> <script type="text/javascript">var rsssl_share_url = window.location.href.replace('https://', 'http://');
                var addthis_share = {url: '' + rsssl_share_url + ''};</script> <link rel="shortcut icon" href="https://jamaicans.com/wp-content/uploads/2015/08/JA-favicon.png" type="image/x-icon" /><style type="text/css">div.sumome-share-client-wrapper.sumome-share-client-wrapper-left-page.sumome-share-client-counts.sumome-share-client-light.sumome-share-client-medium{top:45%}.page-id-207 #breadcrumbs{display:none}.nav-menu .vce-mega-menu .sub-menu .sub-menu li,.nav-menu .vce-mega-menu .sub-menu a{line-height:1.2em!important}.main-navigation a{font-size:19px;padding:15px 21px 15px}.vce-slider-pagination .owl-controls{background:#ffde00}.vce-post{box-shadow:0 1px 3px 0 rgba(0,0,0,0)}.main-navigation a{line-height:39px;font-size:18px;padding:15px 10px 15px}.main-box-title{border-top-width:8px!important}.dp_pec_monthly.light,.dp_pec_weekly.light,.dp_pec_daily.light{margin:0 auto}.vce-wrap-left{width:65%}.vce-wrap-right{width:35%}.header-sticky{height:74px}.header-sticky .site-title img{max-height:69px}li.feed-item{list-style:none;font-size:.9em}li.feed-item a{font-size:1.1em;font-weight:700}#rss-3 li a{font-size:1.1em;color:#55ad4c}#breadcrumbs{margin:10px 0;padding:10px 20px;color:#393939;opacity:.8;background:#fff;border-left:#393939 solid 5px}#breadcrumbs span{padding:0 5px}#breadcrumbs a{font-size:.8em;color:#393939}.breadcrumb_last{font-size:.9em;color:#55ad4c}#mailerlite_widget-2{background:rgba(243,212,91,.48)}.main-box-title.cat-348{border-top:8px solid #f34d28!important}.meta-category a{font-weight:700}</style>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2520621-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2520621-1');</script> <script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script> <div class="wrapper-outer"><div style="display:none;height:0;width:0;"> <script type="text/javascript" src="https://widgets.amung.us/small.js" defer></script> <script type="text/javascript">WAU_small('jamaicans')</script> </div></head><body data-rssslsocial=1 data-rsssl=1 data-rssslsocial=1 data-rssslsocial=1 data-rssslsocial=1 data-rsssl=1 class="post-template-default single single-post postid-122668 single-format-standard chrome vce-sid-right voice-v_2_8_3"><div id="vce-main"><header id="header" class="main-header"><div class="container header-2-wrapper header-main-area"><div class="vce-res-nav"> <a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a></div><div class="site-branding"> <span class="site-title"><a href="https://jamaicans.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><source srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><img src="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png" alt="Jamaicans.com"></picture></a></span></div><div class="vce-header-ads"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="5539842733" data-ad-format="link"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div class="header-bottom-wrapper header-left-nav"><div class="container"><nav id="site-navigation" class="main-navigation" role="navigation"><ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-79827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79827 vce-cat-40"><a href="https://jamaicans.com/jamaica/culture-jamaica/">Culture</a><li id="menu-item-61427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61427"><a href="https://jamaicans.com/travel-jamaica/">Travel</a><li id="menu-item-83497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83497"><a href="https://jamaicans.com/recipes/">Food</a><li id="menu-item-77663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77663"><a href="https://jamaicans.com/speak-jamaican/">Speak JA</a><li id="menu-item-79829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79829 vce-cat-265"><a href="https://jamaicans.com/jamaica/jamaican-music/">Music</a><li id="menu-item-118280" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-118280"><a href="#">Photos + Videos</a><ul class="sub-menu"><li id="menu-item-118279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118279"><a href="https://jamaicans.com/photogallery/">Photos</a><li id="menu-item-118281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118281"><a href="https://jamaicans.com/videos/%20">Videos</a></ul><li id="menu-item-79826" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-79826 vce-cat-276"><a href="https://jamaicans.com/jamaica/jamaica-magazine/">JA Mag</a><li id="menu-item-79856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79856 vce-cat-267"><a href="https://jamaicans.com/jamaica/news-announcements/">News</a><li id="menu-item-61425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61425"><a href="https://jamaicans.com/jamaican-information/">Research JA</a><li class="search-header-wrap"><a class="search_header" href="javascript:void(0)"><i class="fa fa-search"></i></a><ul class="search-header-form-ul"><li><form action="https://jamaicans.com/search-results/" class="search-form" method="get" role="search"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" title="Search for:" name="q" value="" placeholder="Search ..." class="search-field" /> </label> <input type="submit" value="Search" class="search-submit" /></form></li></ul></li></ul></nav></div></div></header><div id="main-wrapper"><div id="content" class="container site-content"><div id=“breadcrumbs”></div><div id="primary" class="vce-main-content"><main id="main" class="main-box main-box-single"><article id="post-122668" class="vce-single post-122668 post type-post status-publish format-standard has-post-thumbnail hentry category-jamaica-magazine-interviews tag-curtis-hoyle tag-interview tag-jamaica tag-jason-moore tag-netflix-the-punisher"><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-interviews/" class="category-339">Interviews</a></span><h1 class="entry-title">Jamaican Actor Jason R. Moore Lands Leading Role on Netflix’s “The Punisher” &#8211; Interview</h1><div class="entry-meta"><div class="meta-item date"><span class="updated">1 hour ago</span></div><div class="meta-item author"><span class="vcard author"><span class="fn">by <a href="https://jamaicans.com/author/kerriann/">Kerri-Ann M. Smith</a></span></span></div></div></header><div class="meta-image"> <img width="747" height="491" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/Jamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher.jpg" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="Jamaican Actor Jason R. Moore Lands Leading Role on Netflixs The Punisher" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/Jamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher.jpg 747w, https://jamaicans.com/wp-content/uploads/Jamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher-300x197.jpg 300w" data-lazy-sizes="(max-width: 747px) 100vw, 747px" /><noscript><img width="747" height="491" src="https://jamaicans.com/wp-content/uploads/Jamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher.jpg" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="Jamaican Actor Jason R. Moore Lands Leading Role on Netflixs The Punisher" srcset="https://jamaicans.com/wp-content/uploads/Jamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher.jpg 747w, https://jamaicans.com/wp-content/uploads/Jamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher-300x197.jpg 300w" sizes="(max-width: 747px) 100vw, 747px" /></noscript></div><div class="entry-content"><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="1532314968" data-ad-format="link"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><div class="at-above-post addthis_tool" data-url="http://jamaicans.com/jamaican-actor-jason-r-moore-lands-leading-role-on-netflixs-the-punisher-interview/"></div><p><em><strong>Jamaican-born Jason R. Moore plays the role of the conscientious Curtis Hoyle in the Netflix remake of the Marvel comic, “The Punisher.” Curtis Hoyle first appears in Marvel comic The Punisher #1 (Vol. 2) where Hoyle and Frank Castle (portrayed by Jon Bernthal) served together. Hoyle is a former U.S. Navy Special Amphibious Reconnaissance Corpsman who became the leader of a therapy group after losing the lower part of his left leg in combat. Moore’s background in theater and digital media are all noteworthy, as he shares a deliberate consciousness about issues facing the diaspora. Moore’s leading role in The Punisher exemplifies Netflix’s commitment to putting more diverse talent in the forefront, thus allowing them to play more nuanced, complex leading roles.</strong></em></p><p><strong>1. </strong><strong>Where are you from?<br /> </strong>I was born in Red Hills, St. Andrew, but I came to the U.S. as a baby. I’ve been fortunate to spend a lot of time there because I always go back and see my family. I came to the United States and moved to Albany, New York. Most people ask how we got there, but that’s where my aunt was, so we ended up there. My parents are still there. I left Albany to go to college (SUNY Morrisville and then Purchase College).</p><p><strong>2. Did you have formal training in theater and acting?<br /> </strong>I studied theater at Purchase College. While there, I got a chance to do many different roles. I did a Lynn Nottage—Black playwright—play, Crumbs for the Table of Joy. I also did many plays by Chekov, Shakespeare, and did one experimental piece called The Green Bird. The theater program at Purchase is a 4-year conservatory program and so it was very intense. I would say that the school prepared me for some areas of the industry that were important because while in the program, we aren’t allowed to work. We have to focus on getting through the very structured program, so we couldn’t say, take jobs or anything like that, which is similar to when you’re under contract when you’re in the acting world.</p><div class='code-block code-block-4' style='margin: 8px 0; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-1901173274277249" data-ad-slot="1751381785"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p><strong>3. What are some of the principles you learned from being of Jamaican heritage that you apply to your work today?<br /> </strong>Marcus Garvey is one of my greatest influences. Listen, the confidence of Jamaican people is amazing, and Marcus Garvey spoke about that in his work. My understanding of power comes from Garvey. One of the things Garvey said is that if the Chinese man, White man, or Indian man can do “it,” then we can do it too. What I learned from reading his work is that we are capable of doing anything. Understanding and believing that is powerful! Once I implemented that in my own life, it paid off. Creating Atlanta Black Star was difficult especially because I didn’t go to school for journalism, but I was capable. I firmly believe that anyone is capable of doing anything if they put their mind to it.</p><p><strong>4. Oftentimes, people take issue with the “you can do anything” trope because it sort of feeds into respectability politics. Can you clarify what you’re saying there, so people understand?</strong><strong><br /> </strong>I’m not saying, “pull yourself up by the bootstraps,” because you have to have boots to do that! There’s a society that is invested in ensuring that we don’t have boots. People who say “pull yourself up by the bootstraps” are totally disregarding the experience of Black people in this country. That’s not what I’m saying. What I’m saying is, develop yourself as a human being. The world is so much bigger than just where you are, so prepare for the global stage. That takes initiative. Nobody else will give us the power that they have so we have to take initiative to get some power for ourselves. Though we are a people who suffered, they couldn’t kill us! We are still here and we have to understand our history, but we also have to take what’s ours as a people. We have to make our mark. My brothers and I wanted to do that, so we started this digital platform called <a href="https://atlantablackstar.com"><strong>Atlanta Black Star</strong></a>—to shift the way we were consuming news about ourselves and to reshape the way the news about us was being shared.</p><div id="attachment_122712" style="width: 310px" class="wp-caption alignright"><a href="https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R.jpeg"><img class="size-medium wp-image-122712" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-300x200.jpeg" alt="" width="300" height="200" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-300x200.jpeg 300w, https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-768x512.jpeg 768w, https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-1024x682.jpeg 1024w, https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-810x540.jpeg 810w, https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-1140x760.jpeg 1140w, https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R.jpeg 1280w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /><noscript><img class="size-medium wp-image-122712" src="https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-300x200.jpeg" alt="" width="300" height="200" srcset="https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-300x200.jpeg 300w, https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-768x512.jpeg 768w, https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-1024x682.jpeg 1024w, https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-810x540.jpeg 810w, https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R-1140x760.jpeg 1140w, https://jamaicans.com/wp-content/uploads/145_CRIME_205_Unit_00618R.jpeg 1280w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a><p class="wp-caption-text">Marvel&#8217;s The Punisher</p><div class='code-block code-block-5' style='margin: 8px 0; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:468px;height:15px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="7634263850"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><p><strong>5. When did you develop a love/passion for acting? Did you do act as a child?<br /> </strong>I never did theater as a kid. While I had an interest, I never acted on it. I was an athlete first and I knew I couldn’t do that forever because athletes get injured, etc. As a Jamaican, running (track and field) came naturally, but I knew I had to get out before the injuries came. So, when I got to college and I had to figure out the rest of my life, I sat back in my dorm, thinking about it and I asked myself what my interests were. I decided to be an actor. I had no training, no experience, but I decided that I was gonna approach it as if I were becoming a brain surgeon. I decided not to quit until I had done it.</p><p>Purchase College’s program is very competitive. I applied twice. By the time I got in, I was almost done with school, so I had to practically redo college because it’s a four-year program. But I didn’t give up. As I learned more and more about acting, I got bitten by the bug and I started to gain a greater appreciation for what I was doing.</p><p><strong>6. How did your Jamaican family respond when you decided to be an actor?<br /> </strong>Ha! They sucked their teeth, then laughed, and said I can’t be serious. One of my brothers is an engineer, the other is a mathematician, and my sister practiced law and then went to the military. I am the outlier&#8211;I was always the outlier.</p><p><strong>7. What advice did they give you?<br /> </strong>My brothers, who are all good in math, said it didn’t add up. There was too much risk. Based on numbers, it just didn’t make sense. Despite their laughing, though, were still supportive. You know, they were just worried that I wouldn’t be able to sustain myself. My dad would say, “get a real job, man,” but he was just worried that I’d be broke. I finished college well into my twenties, so time was against me. They’re immigrants, so all they know is their idea of working hard. Even after I finished school, they saw me struggling and they kept saying “get a normal job.” Yes, I got some small acting jobs here and there, but none of it could sustain my livelihood. I was never gonna do that. I wasn’t cut out for that lifestyle.</p><div id="attachment_122709" style="width: 310px" class="wp-caption alignleft"><a href="https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R.jpeg"><img class="size-medium wp-image-122709" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-300x169.jpeg" alt="" width="300" height="169" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-300x169.jpeg 300w, https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-768x432.jpeg 768w, https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-1024x576.jpeg 1024w, https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-810x456.jpeg 810w, https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-1140x641.jpeg 1140w, https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R.jpeg 1280w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /><noscript><img class="size-medium wp-image-122709" src="https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-300x169.jpeg" alt="" width="300" height="169" srcset="https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-300x169.jpeg 300w, https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-768x432.jpeg 768w, https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-1024x576.jpeg 1024w, https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-810x456.jpeg 810w, https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R-1140x641.jpeg 1140w, https://jamaicans.com/wp-content/uploads/031_CRIME_207_Unit_01241R.jpeg 1280w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a><p class="wp-caption-text">Marvel&#8217;s The Punisher</p></div><p><strong>8. Was there ever a time when you agreed with them?<br /> </strong>Yes, absolutely, yes. After a while, I said I better secure myself, so I started a business with my brothers and some partners. It was a digital media company and from there, we started the Atlanta Black Star. We all are heavily influenced by Garvey and that was the manifesto behind Atlanta Black Star. In the philosophy of Garvey, we went to Jamaica, hired students, paid them in U.S. dollars, and mentored them to show them how to get real-world experience in journalism and to empower them to start learning and mastering digital platforms. It was really great, rewarding work. However, I did that strategically to supplement my acting, so I was itching to get back to acting. Developing that website was demanding and it sort of took over, so I left and went back to acting. Shortly after that, I booked The Punisher.</p><p><strong>9. How are they responding, now that you’re landing big roles?<br /> </strong>My family members are the proudest people on the planet about my tv show, now. Listen, my mother tells everybody who will listen that her son is on The Punisher. My dad is really proud, and they should be, because they provided the means for me to be who I am. They didn’t understand the whole acting thing, but they supported it, and that is all I needed. I was determined, and they were supportive.</p><p><strong>10. How did you end up with this particular role on The Punisher?<br /> </strong>My manager sent me a part of the script and I recorded a tape and sent it in. They loved the tape, and I had to meet the showrunner, head of Marvel, and the director. I repeated the stuff I did on the tape in front of them, and they loved what I did, so they offered the role to me.</p><div class="mceTemp"></div><p><strong>11. Did you have any hang-ups about the role?<br /> </strong>Not really, but I do play a character who is a white man in the original comic book. I don’t think anyone cared about that character enough to realize that I was a Black man playing the role of a white character. The character wasn’t that significant in the comics, so he could have been anything, so I haven’t gotten much backlash about that. His role in the TV show is a bit different.</p><p><strong>12. Tell us about Curtis Hoyle. He seems quite conscientious and reasonable. Is he?<br /> </strong>He’s the moral compass of the show. In a world where everyone is running around shooting guns in Manhattan, he’s saying “you can’t do that!” In Curtis’ world, people don’t want to be themselves any more; they take on these “images” or characters, like The Punisher. Curtis wants people to be themselves and be functional members of society. He’s suffering from his own issues, and they haven’t gotten into much of it yet, but he says it that by helping others he’s helping himself and this is how he copes.</p><div class="mceTemp"></div><div class="mceTemp"></div><p><strong>13. What are some other roles you’d love to play?<br /> </strong>I would love to play a historical figure. That’s real work. To create an individual, it takes a level of reverence and deference. You have to put yourself in a headspace that’s not easy to get in and out of. Doing The Punisher is easy, but to create a real-life character is challenging work that I’d love to do. I want to tell important stories that affect our people.</p><div id="attachment_122711" style="width: 310px" class="wp-caption alignright"><a href="https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R.jpeg"><img class="size-medium wp-image-122711" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-300x200.jpeg" alt="" width="300" height="200" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-300x200.jpeg 300w, https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-768x512.jpeg 768w, https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-1024x682.jpeg 1024w, https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-810x540.jpeg 810w, https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-1140x760.jpeg 1140w, https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R.jpeg 1280w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /><noscript><img class="size-medium wp-image-122711" src="https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-300x200.jpeg" alt="" width="300" height="200" srcset="https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-300x200.jpeg 300w, https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-768x512.jpeg 768w, https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-1024x682.jpeg 1024w, https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-810x540.jpeg 810w, https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R-1140x760.jpeg 1140w, https://jamaicans.com/wp-content/uploads/041C_CRIME_207_Unit_00801R.jpeg 1280w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a><p class="wp-caption-text">Marvel&#8217;s The Punisher</p></div><p><strong>14. What does it mean to be walking in the footsteps of people like Harry Belafonte and Delroy Lindo?<br /> </strong>It’s a big deal! They have set a standard/high bar in front of the camera and in their natural lives that you have to give respect where it’s due. They laid the blocks for me. I’m proud of them as Jamaican actors but the real big deal for me is that they’re Black men, not just Jamaican. We are out of many, one. To see them on the big screen was empowering to me. The fact that they’re Jamaican just reassured me that Jamaicans have the potential to be so great coming from such a small place.</p><p><strong>15. Let’s talk about some Jamaican things. What’s your favorite spot in Jamaica?<br /> </strong>Right on the verandah in front of the house that I remember going to as a kid in Red Hills. I am not a resort guy because it’s not authentic for me. I also love being on the beach and watching the water crash on the shores. The Blue Mountains are cool too.</p><p><strong>16. Ok, so you’re given a plate on which you should put your favorite foods. What’s on it?<br /> </strong>Curry chicken is my classic favorite. I can eat that at any time of the day. But ok, I’m going to eat breakfast and that would be saltfish and callaloo, one boiled dumplin’, one banana, one piece of yam, and one festival. And then I’m going to drink ginger beer or a Red Stripe (Don’t judge me, I can drink beer for breakfast.) or a really good, spicy sorrel. I try to eat healthy, though, so while we have some of the best food in the world, it’s not always easy to find healthy options when it comes to our favorites. For example, I haven’t eaten oxtail in years, although I know it tastes good.</p><p><strong>17. Whose music do you enjoy the most? Who’s your artiste?<br /> </strong>Oh man, I love all the culture people. Capleton, Sizzla, Morgan Heritage, Garnett Silk, Barrington Levy. I was just listening to some recent dancehall in the car before our conversation, but I’m not a fan of that. I like the more conscious stuff.</p><p><strong>18. Now, I know everybody is wondering. Is Jason R. Moore married?<br /> </strong>I don’t have a family yet, so I have to secure myself to ensure that. I’m a single guy and I have no children, so I have to work on that.</p><p><strong>19. Are you working on anything else outside of acting?<br /> </strong>Outside of acting, I invested in this lighting company called AnthemBox. Our light is lighter, brighter, quieter, cheaper, and it reflects all skin tones better than the others. Our product highlights the glow that we’ve been missing in all the TV shows and films out there. You might not notice, but the existing lights were calibrated to white skin, so there was always a dull look to darker skin tones. Our light fixes that problem. We are trying to get it in the hands of all Black cinematographers and directors.</p><p>We do demonstrations to show how it works and the benefits. It’s a startup company, so we’re working with a modest budget while trying to get the word out. We are getting ourselves out there to showcase our product next to all the big companies, so I feel pretty good about that. You can visit <a href="http://www.anthemone.com/">www.AnthemOne.com</a> to learn more. Next week, we will be in New Mexico to shoot a film.</p><p><strong>20. Have you done anything with a Jamaican focus yet?<br /> </strong>I was the lead actor in one of Tami Chin’s videos “Tell Me Seh.” That’s back when I had locks, too. You should check it out.</p><p><em><strong>You can binge watch The Punisher on Netflix.</strong></em></p><div id="attachment_122710" style="width: 310px" class="wp-caption aligncenter"><a href="https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R.jpeg"><img class="size-medium wp-image-122710" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-300x200.jpeg" alt="" width="300" height="200" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-300x200.jpeg 300w, https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-768x512.jpeg 768w, https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-1024x682.jpeg 1024w, https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-810x540.jpeg 810w, https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-1140x760.jpeg 1140w, https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R.jpeg 1280w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /><noscript><img class="size-medium wp-image-122710" src="https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-300x200.jpeg" alt="" width="300" height="200" srcset="https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-300x200.jpeg 300w, https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-768x512.jpeg 768w, https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-1024x682.jpeg 1024w, https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-810x540.jpeg 810w, https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R-1140x760.jpeg 1140w, https://jamaicans.com/wp-content/uploads/038_CRIME_207_Unit_00369R.jpeg 1280w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a><p class="wp-caption-text">Marvel&#8217;s The Punisher</p></div><p>Moore’s Bio: Jason R. Moore is a Jamaican-born, American actor from Albany, New York. After graduating college, he moved to New York City where he quickly garnered television roles on series such as Law &amp; Order: SVU, Kings, and The Unusuals. He was later cast in the Disney Feature Film The Sorcerer’s Apprentice and received critical praise for his work in the award-winning Independent drama A Lonely Place for Dying. Jason then relocated his talents to Los Angeles, where he landed the role of Curtis Hoyle in the highly anticipated Marvel series The Punisher, which premiered in 2017. The much anticipated second season returned on January 19, 2019 with more intrigue on action than ever. The second season reveals less of a benevolent relationship between Hoyle (Moore) and The Punisher (Bernthal).</p><p>Source: Sharp &amp; Associates PR</p><p>&nbsp;</p><div class="at-below-post addthis_tool" data-url="http://jamaicans.com/jamaican-actor-jason-r-moore-lands-leading-role-on-netflixs-the-punisher-interview/"></div><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'> <script id="mNCC" language="javascript">medianet_width = "336";
   medianet_height = "280";
   medianet_crid = "849612493";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();</script></div></div><footer class="entry-footer"><div class="meta-tags"> <a href="https://jamaicans.com/tag/curtis-hoyle/" rel="tag">Curtis Hoyle</a> <a href="https://jamaicans.com/tag/interview/" rel="tag">Interview</a> <a href="https://jamaicans.com/tag/jamaica/" rel="tag">Jamaica</a> <a href="https://jamaicans.com/tag/jason-moore/" rel="tag">Jason Moore</a> <a href="https://jamaicans.com/tag/netflix-the-punisher/" rel="tag">Netflix The Punisher</a></div></footer><div class="vce-share-bar"><ul class="vce-share-items"><li><a class="fa fa-facebook" href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fjamaicans.com%2Fjamaican-actor-jason-r-moore-lands-leading-role-on-netflixs-the-punisher-interview%2F&amp;t=Jamaican%20Actor%20Jason%20R.%20Moore%20Lands%20Leading%20Role%20on%20Netflix%E2%80%99s%20%E2%80%9CThe%20Punisher%E2%80%9D%20%E2%80%93%20Interview"></a></li><li><a class="fa fa-twitter" href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fjamaicans.com%2Fjamaican-actor-jason-r-moore-lands-leading-role-on-netflixs-the-punisher-interview%2F&amp;text=Jamaican%20Actor%20Jason%20R.%20Moore%20Lands%20Leading%20Role%20on%20Netflix%E2%80%99s%20%E2%80%9CThe%20Punisher%E2%80%9D%20%E2%80%93%20Interview"></a></li><li><a class="fa fa-google-plus" href="javascript:void(0);" data-url="https://plus.google.com/share?url=https%3A%2F%2Fjamaicans.com%2Fjamaican-actor-jason-r-moore-lands-leading-role-on-netflixs-the-punisher-interview%2F"></a></li><li><a class="fa fa-pinterest" href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fjamaicans.com%2Fjamaican-actor-jason-r-moore-lands-leading-role-on-netflixs-the-punisher-interview%2F&amp;media=https%3A%2F%2Fjamaicans.com%2Fwp-content%2Fuploads%2FJamaican-Actor-Jason-R.-Moore-Lands-Leading-Role-on-Netflixs-The-Punisher.jpg&amp;description=Jamaican%20Actor%20Jason%20R.%20Moore%20Lands%20Leading%20Role%20on%20Netflix%E2%80%99s%20%E2%80%9CThe%20Punisher%E2%80%9D%20%E2%80%93%20Interview"></a></li><li><a class="fa fa-linkedin" href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fjamaicans.com%2Fjamaican-actor-jason-r-moore-lands-leading-role-on-netflixs-the-punisher-interview%2F&amp;title=Jamaican%20Actor%20Jason%20R.%20Moore%20Lands%20Leading%20Role%20on%20Netflix%E2%80%99s%20%E2%80%9CThe%20Punisher%E2%80%9D%20%E2%80%93%20Interview"></a></li></ul></div></article><nav class="prev-next-nav"><div class="vce-next-link"> <a href="https://jamaicans.com/our-stories-im-very-strange-and-i-like-it-dahniel-jae-harvey/" rel="prev"><span class="img-wrp"><img width="375" height="195" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/rsz_dahniel_jae-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="" /><noscript><img width="375" height="195" src="https://jamaicans.com/wp-content/uploads/rsz_dahniel_jae-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="" /></noscript><span class="vce-pn-ico"><i class="fa fa fa-chevron-right"></i></span></span><span class="vce-prev-next-link">Our Stories: I&#8217;m Very Strange and I like it DahNiel-Jae Harvey</span></a></div></nav></main><section class="main-box mbt-border-top author-box"><h3 class="main-box-title">About the author</h3><div class="main-box-inside"><div class="data-image"> <img alt='' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://secure.gravatar.com/avatar/6913d1e0d307b686a11989c8b2d7b5e3?s=112&#038;d=mm&#038;r=g' data-lazy-srcset='https://secure.gravatar.com/avatar/6913d1e0d307b686a11989c8b2d7b5e3?s=224&#038;d=mm&#038;r=g 2x' class='avatar avatar-112 photo' height='112' width='112' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/6913d1e0d307b686a11989c8b2d7b5e3?s=112&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/6913d1e0d307b686a11989c8b2d7b5e3?s=224&#038;d=mm&#038;r=g 2x' class='avatar avatar-112 photo' height='112' width='112' /></noscript></div><div class="data-content"><h4 class="author-title">Kerri-Ann M. Smith</h4><div class="data-entry-content"><p>Dr. Kerri-Ann M. Smith is an author and educator. She is an Assistant Professor of English at Queensborough Community College, CUNY. She is a patois translator, a wife, and the mother of two beautiful little girls. She is a senior writer for jamaicans.com.</p></div></div></div><div class="vce-content-outside"><div class="data-links"> <a href="https://jamaicans.com/author/kerriann/" class="vce-author-link vce-button">View all posts</a></div><div class="vce-author-links"> <a href="http://@drmrsmom" target="_blank" class="fa fa-twitter"></a></div></div></section><div class="main-box vce-related-box"><h3 class="main-box-title">You may also like</h3><div class="main-box-inside"><article class="vce-post vce-lay-d post-87823 post type-post status-publish format-standard has-post-thumbnail hentry category-culture-jamaica tag-jamaica tag-jamaican-coworker tag-patois tag-rastafarian"><div class="meta-image"> <a href="https://jamaicans.com/10-things-not-to-do-when-you-discover-your-coworker-is-jamaican/" title="10 Things Not To Do When you Discover your Coworker is Jamaican"> <img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/2015/11/jamaican-co-worker-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2015/11/jamaican-co-worker-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/11/jamaican-co-worker-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2015/11/jamaican-co-worker-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://jamaicans.com/wp-content/uploads/2015/11/jamaican-co-worker-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/11/jamaican-co-worker-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/culture-jamaica/" class="category-40">Culture</a></span><h2 class="entry-title"><a href="https://jamaicans.com/10-things-not-to-do-when-you-discover-your-coworker-is-jamaican/" title="10 Things Not To Do When you Discover your Coworker is Jamaican">10 Things Not To Do When you Discover your Coworker is...</a></h2></header></article><article class="vce-post vce-lay-d post-94605 post type-post status-publish format-standard has-post-thumbnail hentry category-recipes tag-jamaica tag-jamaican-street-food tag-street-food"><div class="meta-image"> <a href="https://jamaicans.com/7-amazing-jamaican-street-foods-you-must-try/" title="7 Amazing Jamaican Street Foods You Must Try"> <img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-145x100.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Peppered Shrimps by kwesianthony" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-145x100.png 145w, https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-380x260.png 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-145x100.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Peppered Shrimps by kwesianthony" srcset="https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-145x100.png 145w, https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-380x260.png 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/recipes/" class="category-277">Jamaican Recipes</a></span><h2 class="entry-title"><a href="https://jamaicans.com/7-amazing-jamaican-street-foods-you-must-try/" title="7 Amazing Jamaican Street Foods You Must Try">7 Amazing Jamaican Street Foods You Must Try</a></h2></header></article><article class="vce-post vce-lay-d post-80629 post type-post status-publish format-standard has-post-thumbnail hentry category-jamaica-magazine-interviews tag-boombastic tag-dancehall tag-deejay tag-reggae tag-shaggy"><div class="meta-image"> <a href="https://jamaicans.com/10-things-you-did-not-know-about-shaggy/" title="10 Things You Did Not Know About Shaggy"> <img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/2015/05/shaggy-reggae-featured-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2015/05/shaggy-reggae-featured-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/05/shaggy-reggae-featured-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2015/05/shaggy-reggae-featured-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://jamaicans.com/wp-content/uploads/2015/05/shaggy-reggae-featured-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/05/shaggy-reggae-featured-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-interviews/" class="category-339">Interviews</a></span><h2 class="entry-title"><a href="https://jamaicans.com/10-things-you-did-not-know-about-shaggy/" title="10 Things You Did Not Know About Shaggy">10 Things You Did Not Know About Shaggy</a></h2></header></article><article class="vce-post vce-lay-d post-95318 post type-post status-publish format-standard has-post-thumbnail hentry category-jamaica-magazine-interviews tag-interview tag-kingston tag-music-2 tag-reggae tag-romain-virgo tag-st-ann tag-stepney"><div class="meta-image"> <a href="https://jamaicans.com/12-things-you-did-not-know-about-romain-virgo/" title="12 Things You Did Not Know About Romain Virgo"> <img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/2016/06/Romain-Virgo-12-Things-You-Did-Not-Know-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Romain Virgo" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2016/06/Romain-Virgo-12-Things-You-Did-Not-Know-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/06/Romain-Virgo-12-Things-You-Did-Not-Know-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/06/Romain-Virgo-12-Things-You-Did-Not-Know-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Romain Virgo" srcset="https://jamaicans.com/wp-content/uploads/2016/06/Romain-Virgo-12-Things-You-Did-Not-Know-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/06/Romain-Virgo-12-Things-You-Did-Not-Know-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-interviews/" class="category-339">Interviews</a></span><h2 class="entry-title"><a href="https://jamaicans.com/12-things-you-did-not-know-about-romain-virgo/" title="12 Things You Did Not Know About Romain Virgo">12 Things You Did Not Know About Romain Virgo</a></h2></header></article><article class="vce-post vce-lay-d post-77079 post type-post status-publish format-standard has-post-thumbnail hentry category-jamaica-magazine-interviews tag-blondie-ras-productions tag-calibe-thompson tag-lukkee-chong tag-pbs tag-taste-the-islands"><div class="meta-image"> <a href="https://jamaicans.com/5-questions-with-calibe-thompson-the-first-jamaican-producer-to-get-a-national-series-on-pbs-taste-the-islands/" title="5 Questions with Calibe Thompson, the first Jamaican producer to get a national series on PBS &#8211; Taste the Islands"> <img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/2015/04/calibe-thompson-feature-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2015/04/calibe-thompson-feature-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/04/calibe-thompson-feature-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2015/04/calibe-thompson-feature-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://jamaicans.com/wp-content/uploads/2015/04/calibe-thompson-feature-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/04/calibe-thompson-feature-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-interviews/" class="category-339">Interviews</a></span><h2 class="entry-title"><a href="https://jamaicans.com/5-questions-with-calibe-thompson-the-first-jamaican-producer-to-get-a-national-series-on-pbs-taste-the-islands/" title="5 Questions with Calibe Thompson, the first Jamaican producer to get a national series on PBS &#8211; Taste the Islands">5 Questions with Calibe Thompson, the first Jamaican...</a></h2></header></article><article class="vce-post vce-lay-d post-105878 post type-post status-publish format-standard has-post-thumbnail hentry category-culture-jamaica tag-jamaica"><div class="meta-image"> <a href="https://jamaicans.com/memba-the-good-ole-jamaica-days/" title="Memba the Good Ole Day in Jamaica?"> <img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/2017/03/Ole-Days-in-Jamaica-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Ole Days in Jamaica" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2017/03/Ole-Days-in-Jamaica-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2017/03/Ole-Days-in-Jamaica-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2017/03/Ole-Days-in-Jamaica-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Ole Days in Jamaica" srcset="https://jamaicans.com/wp-content/uploads/2017/03/Ole-Days-in-Jamaica-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2017/03/Ole-Days-in-Jamaica-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/culture-jamaica/" class="category-40">Culture</a></span><h2 class="entry-title"><a href="https://jamaicans.com/memba-the-good-ole-jamaica-days/" title="Memba the Good Ole Day in Jamaica?">Memba the Good Ole Day in Jamaica?</a></h2></header></article></div></div></div><aside id="sidebar" class="sidebar right"><div id="search-4" class="widget widget_search"><form action="https://jamaicans.com/search-results/" class="search-form" method="get" role="search"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" title="Search for:" name="q" value="" placeholder="Search ..." class="search-field" /> </label> <input type="submit" value="Search" class="search-submit" /></form></div><div id="mks_social_widget-3" class="widget mks_social_widget"><h4 class="widget-title">Follow Us</h4><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/pages/Jamaicanscom/128078147433" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>facebook</span></a></li><li><a href="https://twitter.com/jamaicansdotcom" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>twitter</span></a></li><li><a href="https://google.com/+Jamaicans" title="Google Plus" class="google-plus_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>google-plus</span></a></li><li><a href="https://instagram.com/jamaicans_com" title="Instagram" class="instagram_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>instagram</span></a></li><li><a href="https://www.youtube.com/user/outofmanyonline" title="Youtube" class="youtube_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>youtube</span></a></li><li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="pinterest_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>pinterest</span></a></li><li><a href="https://jamaicansdotcom.tumblr.com/" title="Tumblr" class="tumblr_ico soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>tumblr</span></a></li></ul></div><div id="mailerlite_widget-2" class="widget widget_mailerlite_widget"><div id="mailerlite-form_1" data-temp-id="5c688ef153cf9"><div class="mailerlite-form"><form action="" method="post"><div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div><div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p></div><div class="mailerlite-form-inputs"><div class="mailerlite-form-field"> <label for="mailerlite-1-field-email">Email</label> <input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" /></div><div class="mailerlite-form-loader">Please wait...</div><div class="mailerlite-subscribe-button-container"> <input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" /></div> <input type="hidden" name="form_id" value="1" /> <input type="hidden" name="action" value="mailerlite_subscribe_form" /></div><div class="mailerlite-form-response"><h4><p><span style="color: #339966;">Thank you for sign up!</span></p></h4></div></form></div></div> <script type="text/javascript">(function () {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=5c688ef153cf9] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                submitHandler: function (form) {

                    jQuery(this.submitButton).prop('disabled', true);

                    form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                        form_container.find('.mailerlite-form-loader').fadeIn()
                    });

                    var data = jQuery(form).serialize();

                    jQuery.post('https://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                        form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                            form_container.find('.mailerlite-form-response').fadeIn()
                        });
                    });
                }
            });
        });
    })();</script> </div><div id="vce_adsense_widget-8" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"> <a href='http://www.simbis.com/tools/phpAdsNew/adclick.php?n=a8466447' target='_blank'><img src='https://www.simbis.com/tools/phpAdsNew/adview.php?what=zone:5&amp;n=a8466447' border='0' alt=''></a></div></div><div id="vce_adsense_widget-15" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"> <script id="mNCC" language="javascript">medianet_width = "300";
   medianet_height = "250";
   medianet_crid = "966658449";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();</script> </div></div><div id="vce_adsense_widget-2" class="widget vce_adsense_widget vce_adsense_expand"><div class="vce_adsense_wrapper"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="3218061934"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="vce_adsense_widget-13" class="widget vce_adsense_widget vce_adsense_expand"><div class="vce_adsense_wrapper"> <a href="https://blog.amerijet.com/amerijet-easy-fast-reliable/?lrx=ibmwxo1476296317"><img src="https://www.jamaicans.com/images/ads/AmeriJet-Logo-3002.jpg" /></a> <div class="rll-youtube-player" data-id="2XFghsPeJ9Q" data-query=""></div><noscript><iframe width="300" height="102" src="https://www.youtube.com/embed/2XFghsPeJ9Q" frameborder="0" allowfullscreen></iframe></noscript></div></div><div id="rss-5" class="widget widget_rss"><h4 class="widget-title"><a class="rsswidget" href="https://jamaicans.com/videos/?feed=rss2"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://jamaicans.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://jamaicans.com/videos">Videos</a></h4><ul><li><a class='rsswidget' href='https://jamaicans.com/videos/rum-cream-fruit-smoothie-recipe/'>Rum Cream Fruit Smoothie Recipe</a></li><li><a class='rsswidget' href='https://jamaicans.com/videos/black-britain-on-film-british-jamaican-nottingham-pioneers/'>Black Britain on Film – British Jamaican – Nottingham Pioneers</a></li></ul></div><div id="vce_adsense_widget-14" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"> <a href="https://blog.amerijet.com/amerijet-easy-fast-reliable/?lrx=ibmwxo1476296317"><img src="https://news.jamaicans.com/wp-content/uploads/2018/03/amerijet-160x600.jpg" /></a> <br><br> <script id="mNCC" language="javascript">medianet_width = "250";
    medianet_height = "250";
    medianet_crid = "715859434";
    medianet_versionId = "3111299";</script> <script src="//contextual.media.net/nmedianet.js?cid=8CUN66J27" defer></script> </div></div><div id="vce_adsense_widget-16" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"> <script type="text/javascript" src="//ap.lijit.com/www/delivery/fp?z=406528"></script> </div></div><div id="vce_adsense_widget-7" class="widget vce_adsense_widget vce_adsense_expand"><div class="vce_adsense_wrapper"> <script id="mNCC" language="javascript">medianet_width = "300";
   medianet_height = "600";
   medianet_crid = "526552473";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();</script> </div></div><div id="vce_adsense_widget-4" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"><div id="amzn-assoc-ad-b16961e9-7a01-4871-a07e-eaeca02e8430"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=b16961e9-7a01-4871-a07e-eaeca02e8430"></script> </div></div><div id="vce_adsense_widget-10" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"> <script id='x33x15351354282617836'>var Tynt=Tynt||[];Tynt.push('abWrx44JCr4z2Wacwqm_6r');
Tynt.cmd=Tynt.cmd||[];Tynt.cmd.push(function(){
Tynt.ads.display('300x250','x33x15351354282617836','inpage');});
(function(){var h,s=document.createElement('script');
s.src=(window.location.protocol==='https:'?
'https':'http')+'://cdn.tynt.com/siab.js';
h=document.getElementsByTagName('script')[0];
h.parentNode.insertBefore(s,h);})();</script> </div></div></aside></div><footer id="footer" class="site-footer"><div class="container"><div class="container-fix"><div class="bit-3"><div id="mks_social_widget-2" class="widget mks_social_widget"><h4 class="widget-title">Socially Speaking</h4><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/onelovejamaica" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>facebook</span></a></li><li><a href="https://plus.google.com/+Jamaicans/" title="" class="googleplus_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>googleplus</span></a></li><li><a href="https://instagram.com/jamaicans_com" title="Instagram" class="instagram_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>instagram</span></a></li><li><a href="https://twitter.com/jamaicansdotcom" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>twitter</span></a></li><li><a href="https://www.youtube.com/user/outofmanyonline" title="Youtube" class="youtube_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>youtube</span></a></li><li><a href="https://jamaicans.com/?feed=rss" title="RSS" class="rss_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>rss</span></a></li><li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="pinterest_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>pinterest</span></a></li><li><a href="http://jamaicansdotcom.tumblr.com/" title="Tumblr" class="tumblr_ico soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>tumblr</span></a></li></ul></div><div id="mailerlite_widget-3" class="widget widget_mailerlite_widget"><div id="mailerlite-form_1" data-temp-id="5c688ef34a8a9"><div class="mailerlite-form"><form action="" method="post"><div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div><div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p></div><div class="mailerlite-form-inputs"><div class="mailerlite-form-field"> <label for="mailerlite-1-field-email">Email</label> <input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" /></div><div class="mailerlite-form-loader">Please wait...</div><div class="mailerlite-subscribe-button-container"> <input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" /></div> <input type="hidden" name="form_id" value="1" /> <input type="hidden" name="action" value="mailerlite_subscribe_form" /></div><div class="mailerlite-form-response"><h4><p><span style="color: #339966;">Thank you for sign up!</span></p></h4></div></form></div></div> <script type="text/javascript">(function () {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=5c688ef34a8a9] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                submitHandler: function (form) {

                    jQuery(this.submitButton).prop('disabled', true);

                    form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                        form_container.find('.mailerlite-form-loader').fadeIn()
                    });

                    var data = jQuery(form).serialize();

                    jQuery.post('https://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                        form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                            form_container.find('.mailerlite-form-response').fadeIn()
                        });
                    });
                }
            });
        });
    })();</script> </div></div><div class="bit-3"><div id="vce_posts_widget-2" class="widget vce_posts_widget"><h4 class="widget-title">Random Jamaican Recipes</h4><ul class="vce-post-list" data-autoplay=""><li> <a href="https://jamaicans.com/9-recipes-will-make-jamaican-man-forgive/" class="featured_image_sidebar" title="9 Recipes that Will Make A Jamaican Husband/Man Forgive Anything"><span class="vce-post-img"><img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Ackee and Saltfish" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Ackee and Saltfish" srcset="https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript></span></a><div class="vce-posts-wrap"> <a href="https://jamaicans.com/9-recipes-will-make-jamaican-man-forgive/" title="9 Recipes that Will Make A Jamaican Husband/Man Forgive Anything" class="vce-post-link">9 Recipes that Will Make A Jamaican Husband/Man...</a><div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/9-recipes-will-make-jamaican-man-forgive/#respond"><span class="dsq-postid" data-dsqidentifier="100257 https://jamaicans.com/?p=100257">Add Comment</span></a></div></div></div></li><li> <a href="https://jamaicans.com/chefnels-caribbean-rum-wing-sauce/" class="featured_image_sidebar" title="ChefNel&#8217;s Caribbean Rum Wing Sauce"><span class="vce-post-img"><img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="ChefNel&#039;s Caribbean Rum Sauce" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png 145w, https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-380x260.png 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="ChefNel&#039;s Caribbean Rum Sauce" srcset="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png 145w, https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-380x260.png 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript></span></a><div class="vce-posts-wrap"> <a href="https://jamaicans.com/chefnels-caribbean-rum-wing-sauce/" title="ChefNel&#8217;s Caribbean Rum Wing Sauce" class="vce-post-link">ChefNel&#8217;s Caribbean Rum Wing Sauce</a></div></li><li> <a href="https://jamaicans.com/chef-cunnys-jack-daniels-bbq-wings/" class="featured_image_sidebar" title="Chef Noel Cunningham BBQ Wings"><span class="vce-post-img"><img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript></span></a><div class="vce-posts-wrap"> <a href="https://jamaicans.com/chef-cunnys-jack-daniels-bbq-wings/" title="Chef Noel Cunningham BBQ Wings" class="vce-post-link">Chef Noel Cunningham BBQ Wings</a><div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/chef-cunnys-jack-daniels-bbq-wings/#respond"><span class="dsq-postid" data-dsqidentifier="97656 https://jamaicans.com/?p=97656">Add Comment</span></a></div></div></div></li><li> <a href="https://jamaicans.com/chef-sians-peanut-porridge-recipe/" class="featured_image_sidebar" title="Chef Sian&#8217;s Peanut Porridge Recipe"><span class="vce-post-img"><img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/10/peanut-porridge-2-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript></span></a><div class="vce-posts-wrap"> <a href="https://jamaicans.com/chef-sians-peanut-porridge-recipe/" title="Chef Sian&#8217;s Peanut Porridge Recipe" class="vce-post-link">Chef Sian&#8217;s Peanut Porridge Recipe</a><div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/chef-sians-peanut-porridge-recipe/#respond"><span class="dsq-postid" data-dsqidentifier="101450 https://jamaicans.com/?p=101450">Add Comment</span></a></div></div></div></li><li> <a href="https://jamaicans.com/chef-noel-eggnog-french-toast/" class="featured_image_sidebar" title="Chef Noel Eggnog French Toast"><span class="vce-post-img"><img width="145" height="100" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://jamaicans.com/wp-content/uploads/Chef-Noel-Eggnog-French-Toast-2-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Chef Noel Eggnog French Toast" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/Chef-Noel-Eggnog-French-Toast-2-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Chef-Noel-Eggnog-French-Toast-2-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Chef-Noel-Eggnog-French-Toast-2-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Chef Noel Eggnog French Toast" srcset="https://jamaicans.com/wp-content/uploads/Chef-Noel-Eggnog-French-Toast-2-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Chef-Noel-Eggnog-French-Toast-2-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript></span></a><div class="vce-posts-wrap"> <a href="https://jamaicans.com/chef-noel-eggnog-french-toast/" title="Chef Noel Eggnog French Toast" class="vce-post-link">Chef Noel Eggnog French Toast</a></div></li></ul></div></div><div class="bit-3"><div id="vce_adsense_widget-9" class="widget vce_adsense_widget vce_adsense_expand"><div class="vce_adsense_wrapper"><div id="amzn-assoc-ad-e4689c20-dff8-4cad-9aa6-9cbb20113f59"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=e4689c20-dff8-4cad-9aa6-9cbb20113f59"></script> </div></div></div></div></div><div class="container-full site-info"><div align="center" style="padding-bottom: 20px;"> <script type="text/javascript">google_ad_client = "pub-1901173274277249";

google_alternate_ad_url = "https://www.jamaicans.com/images/ads/google_728X90.htm";

google_ad_width = 728;

google_ad_height = 90;

google_ad_format = "728x90_as";

google_ad_type = "text_image";

google_ad_channel = "";

google_color_border = "798DC2";

google_color_bg = "FFFFFF";

google_color_link = "5870AE";

google_color_text = "676768";

google_color_url = "2C2F4B";</script> <script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js" defer></script> </div><div class="container"><div class="vce-wrap-left"><p>Copyright © Simbis Inc. All rights reserved. <a href="https://jamaicans.com/privacy/">Privacy Policy &amp; Terms of use</a>.</p></div><div class="vce-wrap-right"><ul id="vce_footer_menu" class="bottom-nav-menu"><li id="menu-item-76837" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76837"><a href="https://www.jamaicans.com/forums/">Forums</a></li><li id="menu-item-77461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77461"><a href="https://jamaicans.com/mobile-apps/">Mobile apps</a></li><li id="menu-item-76836" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76836"><a target="_blank" href="http://www.jamaicanstore.com">Shopping</a></li><li id="menu-item-459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-459"><a href="https://jamaicans.com/our-contact/">Contact</a></li><li id="menu-item-526" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-526"><a href="https://jamaicans.com/about-us/">About Us</a></li><li id="menu-item-77011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77011"><a href="https://jamaicans.com/advertise-with-us/">Advertise</a></li></ul></div></div></div></footer></div></div><a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a> <script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='433af38b6e2402a24dab9aa3d747b3033cf5bc5d8ebe9c002919c18dd0789a50';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script> <script type="application/javascript">var ajaxurl = "https://jamaicans.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }</script> <script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://jamaicans.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "38742bc03e", post_id : 122668 } ); } ); /* ]]> */</script> <script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.1.8"; } if (window.wp_blog_version === undefined) { window.wp_blog_version = "5.0.3"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":"300"}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.1.8","plugin_mode":"WordPress","anonymous_profile_id":"wp-bf34677b4718a8fdb8e7d271cfbb868e","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());</script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=wp-bf34677b4718a8fdb8e7d271cfbb868e" async="async"></script><script type='text/javascript'>/* <![CDATA[ */ var wpcf7 = {"apiSettings":{"root":"https:\/\/jamaicans.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://jamaicans.com/wp-content/cache/min/1/wp-content/plugins/contact-form-7/includes/js/scripts-cde51a1dd4552c458c87aefb7087b47e.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var countVars = {"disqusShortname":"jamaicanscom"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://jamaicans.com/wp-content/cache/min/1/wp-content/plugins/disqus-comment-system/public/js/comment_count-486a5004e6daa5a400249fe2df998e76.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var vce_js_settings = {"sticky_header":"1","sticky_header_offset":"200","sticky_header_logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/08\/final-logo-abbr.png","logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/01\/jamaicans_logo.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"https:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","ajax_wpml_current_lang":null,"ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"1","full_slider_autoplay":"","grid_slider_autoplay":"","grid_big_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"0","top_bar_mobile_group":"1","top_bar_more_link":null}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://jamaicans.com/wp-content/cache/min/1/wp-content/themes/voice/js/min-a2af706d713015299c7ba13112815ebd.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var fcaPcEvents = [];
var fcaPcDebug = {"debug":""};
var fcaPcPost = {"title":"Jamaican Actor Jason R. Moore Lands Leading Role on Netflix\u2019s \u201cThe Punisher\u201d - Interview","type":"post","id":"122668","categories":["Interviews"],"utm_support":"","user_parameters":"","edd_delay":"0","woo_delay":"0","edd_enabled":"","woo_enabled":""}; /* ]]> */</script> <script type='text/javascript' src='https://jamaicans.com/wp-content/cache/busting/1/wp-content/plugins/facebook-conversion-pixel/pixel-cat.min-2.4.0.js' defer></script> <script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	s.src = !("IntersectionObserver" in w) ? "https://jamaicans.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-8.15.2.min.js" : "https://jamaicans.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-10.17.min.js";
	w.lazyLoadOptions = {
		elements_selector: "img,iframe",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		data_sizes: "lazy-sizes",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );

	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };

	observer.observe(b, config);
}, false);</script> <script>function lazyLoadThumb(e){var t='<img src="https://i.ytimg.com/vi/ID/hqdefault.jpg">',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="https://www.youtube.com/embed/ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.id)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script> <noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%7CRoboto%20Slab%3A400%7COswald%3A400&subset=" /></noscript><noscript><link rel="stylesheet" href="https://jamaicans.com/wp-content/cache/min/1/b9f078262ec545e71abf1dc80710e80f.css" data-minify="1" /></noscript><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%7CRoboto%20Slab%3A400%7COswald%3A400&subset=" /></noscript><noscript><link rel="stylesheet" href="https://jamaicans.com/wp-content/cache/min/1/b9f078262ec545e71abf1dc80710e80f.css" data-minify="1" /></noscript></body></html>
