<!DOCTYPE html><!--[if IE 8]><html class="ie8"><![endif]--> <!--[if IE 9]><html class="ie9"><![endif]--> <!--[if gt IE 8]><!--><html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" prefix="og: http://ogp.me/ns#"> <!--<![endif]--><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1"><title>Pimenta Jamaican Restaurant Brings Island Spice to Fredericksburg, Virginia - Jamaicans.com</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%7CRoboto%20Slab%3A400%7COswald%3A400&subset=" as="style" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" href="https://jamaicans.com/wp-content/cache/min/1/b9f078262ec545e71abf1dc80710e80f.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><!--[if lt IE 9]> <script src="https://jamaicans.com/wp-content/themes/voice/js/html5.js"></script> <![endif]--> <script type="text/javascript">if(document.location.protocol=='http:'){
 var Tynt=Tynt||[];Tynt.push('abWrx44JCr4z2Wacwqm_6r');
 (function(){var s=document.createElement('script');s.async="async";s.type="text/javascript";s.src='https://tcr.tynt.com/ti.js';var h=document.getElementsByTagName('script')[0];h.parentNode.insertBefore(s,h);})();
}</script> <title>Pimenta Jamaican Restaurant Brings Island Spice to Fredericksburg, Virginia - Jamaicans.com</title><link rel="preload" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%7CRoboto%20Slab%3A400%7COswald%3A400&subset=" as="style" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" href="https://jamaicans.com/wp-content/cache/min/1/b9f078262ec545e71abf1dc80710e80f.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /> <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
			n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
			document,'script','https://connect.facebook.net/en_US/fbevents.js');
			fbq('init', '1055480241142713' );			fbq('track', 'PageView');</script> <noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1055480241142713&ev=PageView&noscript=1"
/></noscript><link rel="canonical" href="https://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Pimenta Jamaican Restaurant Brings Island Spice to Fredericksburg, Virginia - Jamaicans.com" /><meta property="og:description" content="Roy Simmonds, the owner of the Jamaican Pimenta restaurant in downtown Fredericksburg, grew up in Jamaica and learned how to cook from his mother. As he became more experienced, he added some American-style preparations to her Jamaican specialties along with his own unique influence to create the cuisine that is on offer at his Pimenta &hellip;" /><meta property="og:url" content="http://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/" /><meta property="og:site_name" content="Jamaicans.com" /><meta property="article:author" content="http://www.facebook.com/onelovejamaica" /><meta property="article:tag" content="Jamaican Restaurant" /><meta property="article:tag" content="Virginia" /><meta property="article:section" content="Announcements" /><meta property="article:published_time" content="2019-05-05T20:00:25+00:00" /><meta property="article:modified_time" content="2019-05-03T23:03:39+00:00" /><meta property="og:updated_time" content="2019-05-03T23:03:39+00:00" /><meta property="og:image" content="https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia.jpg" /><meta property="og:image:secure_url" content="https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia.jpg" /><meta property="og:image:width" content="1000" /><meta property="og:image:height" content="691" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Roy Simmonds, the owner of the Jamaican Pimenta restaurant in downtown Fredericksburg, grew up in Jamaica and learned how to cook from his mother. As he became more experienced, he added some American-style preparations to her Jamaican specialties along with his own unique influence to create the cuisine that is on offer at his Pimenta [&hellip;]" /><meta name="twitter:title" content="Pimenta Jamaican Restaurant Brings Island Spice to Fredericksburg, Virginia - Jamaicans.com" /><meta name="twitter:image" content="https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia.jpg" /><meta name="twitter:creator" content="@jamaicansdotcom" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://jamaicans.com/#organization","name":"","url":"https://jamaicans.com/","sameAs":[]},{"@type":"WebSite","@id":"https://jamaicans.com/#website","url":"https://jamaicans.com/","name":"Jamaicans.com","publisher":{"@id":"https://jamaicans.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://jamaicans.com/search-results/?q={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/#webpage","url":"https://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/","inLanguage":"en-US","name":"Pimenta Jamaican Restaurant Brings Island Spice to Fredericksburg, Virginia - Jamaicans.com","isPartOf":{"@id":"https://jamaicans.com/#website"},"image":{"@type":"ImageObject","@id":"https://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/#primaryimage","url":"https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia.jpg","width":1000,"height":691,"caption":"Pimenta Jamaican Restaurant Oxtails Fredericksburg Virginia"},"primaryImageOfPage":{"@id":"https://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/#primaryimage"},"datePublished":"2019-05-05T20:00:25+00:00","dateModified":"2019-05-03T23:03:39+00:00"},{"@type":"Article","@id":"https://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/#article","isPartOf":{"@id":"https://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/#webpage"},"author":{"@id":"https://jamaicans.com/author/staffwriter/#author","name":"Staff Writer"},"publisher":{"@id":"https://jamaicans.com/#organization"},"headline":"Pimenta Jamaican Restaurant Brings Island Spice to Fredericksburg, Virginia","datePublished":"2019-05-05T20:00:25+00:00","dateModified":"2019-05-03T23:03:39+00:00","commentCount":0,"mainEntityOfPage":"https://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/#webpage","image":{"@id":"https://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/#primaryimage"},"keywords":"Jamaican Restaurant,Virginia","articleSection":"Announcements"},{"@type":"Person","@id":"https://jamaicans.com/author/staffwriter/#author","name":"Staff Writer","image":{"@type":"ImageObject","@id":"https://jamaicans.com/#personlogo","url":"https://secure.gravatar.com/avatar/e2da7c869d4a6c93cae5e8d151fc0f2d?s=96&d=mm&r=g","caption":"Staff Writer"},"sameAs":["http://www.facebook.com/onelovejamaica","http://instagram.com/jamaicans_com","https://twitter.com/http://twitter.com/jamaicansdotcom"]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Feed" href="https://jamaicans.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Comments Feed" href="https://jamaicans.com/comments/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><style id='vce_style-inline-css' type='text/css'>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</style><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://jamaicans.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style> <script type='text/javascript' src='https://jamaicans.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4.js'></script> <script type='text/javascript' src='https://jamaicans.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-migrate.min-1.4.1.js' defer></script> <link rel='https://api.w.org/' href='https://jamaicans.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jamaicans.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jamaicans.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://jamaicans.com/?p=123949' /><meta name="thumbnail" content="https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-150x150.jpg" /> <script>(function(m,a,i,l,e,r){ m['MailerLiteObject']=e;function f(){
var c={ a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?v'+(~~(new Date().getTime()/1000000));
_.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');</script> <script>(function (m, a, i, l, e, r) {
            m['MailerLiteObject'] = e;

            function f() {
                var c = {a: arguments, q: []};
                var r = this.push(c);
                return "number" != typeof r ? r : f.bind(c.q);
            }

            f.q = f.q || [];
            m[e] = m[e] || f.bind(f.q);
            m[e].q = m[e].q || f.q;
            r = a.createElement(i);
            var _ = a.getElementsByTagName(i)[0];
            r.async = 1;
            r.src = l + '?' + (~~(new Date().getTime() / 10000000));
            _.parentNode.insertBefore(r, _);
        })(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

        var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');</script> <script type="text/javascript">var rsssl_share_url = window.location.href.replace('https://', 'http://');
                var addthis_share = {url: '' + rsssl_share_url + ''};</script> <link rel="shortcut icon" href="https://jamaicans.com/wp-content/uploads/2015/08/JA-favicon.png" type="image/x-icon" /><style type="text/css">div.sumome-share-client-wrapper.sumome-share-client-wrapper-left-page.sumome-share-client-counts.sumome-share-client-light.sumome-share-client-medium{top:45%}.page-id-207 #breadcrumbs{display:none}.nav-menu .vce-mega-menu .sub-menu .sub-menu li,.nav-menu .vce-mega-menu .sub-menu a{line-height:1.2em!important}.main-navigation a{font-size:19px;padding:15px 21px 15px}.vce-slider-pagination .owl-controls{background:#ffde00}.vce-post{box-shadow:0 1px 3px 0 rgba(0,0,0,0)}.main-navigation a{line-height:39px;font-size:18px;padding:15px 10px 15px}.main-box-title{border-top-width:8px!important}.dp_pec_monthly.light,.dp_pec_weekly.light,.dp_pec_daily.light{margin:0 auto}.vce-wrap-left{width:65%}.vce-wrap-right{width:35%}.header-sticky{height:74px}.header-sticky .site-title img{max-height:69px}li.feed-item{list-style:none;font-size:.9em}li.feed-item a{font-size:1.1em;font-weight:700}#rss-3 li a{font-size:1.1em;color:#55ad4c}#breadcrumbs{margin:10px 0;padding:10px 20px;color:#393939;opacity:.8;background:#fff;border-left:#393939 solid 5px}#breadcrumbs span{padding:0 5px}#breadcrumbs a{font-size:.8em;color:#393939}.breadcrumb_last{font-size:.9em;color:#55ad4c}#mailerlite_widget-2{background:rgba(243,212,91,.48)}.main-box-title.cat-348{border-top:8px solid #f34d28!important}.meta-category a{font-weight:700}</style>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2520621-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2520621-1');</script> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script> <div class="wrapper-outer"><div style="display:none;height:0;width:0;"> <script type="text/javascript" src="https://widgets.amung.us/small.js" defer></script> <script type="text/javascript">WAU_small('jamaicans')</script> </div></head><body data-rssslsocial=1 data-rssslsocial=1 data-rsssl=1 class="post-template-default single single-post postid-123949 single-format-standard gecko vce-sid-right voice-v_2_8_4"><div id="vce-main"><header id="header" class="main-header"><div class="container header-2-wrapper header-main-area"><div class="vce-res-nav"> <a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a></div><div class="site-branding"> <span class="site-title"><a href="https://jamaicans.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><source data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" alt="Jamaicans.com" data-lazy-src="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><noscript><img class="rocket-lazyload" src="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png" alt="Jamaicans.com"></noscript></picture></a></span></div><div class="vce-header-ads"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="5539842733" data-ad-format="link"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div class="header-bottom-wrapper header-left-nav"><div class="container"><nav id="site-navigation" class="main-navigation" role="navigation"><ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-79827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79827 vce-cat-40"><a href="https://jamaicans.com/jamaica/culture-jamaica/">Culture</a><li id="menu-item-61427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61427"><a href="https://jamaicans.com/travel-jamaica/">Travel</a><li id="menu-item-83497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83497"><a href="https://jamaicans.com/recipes/">Food</a><li id="menu-item-77663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77663"><a href="https://jamaicans.com/speak-jamaican/">Speak JA</a><li id="menu-item-79829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79829 vce-cat-265"><a href="https://jamaicans.com/jamaica/jamaican-music/">Music</a><li id="menu-item-118280" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-118280"><a href="#">Photos + Videos</a><ul class="sub-menu"><li id="menu-item-118279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118279"><a href="https://jamaicans.com/photogallery/">Photos</a><li id="menu-item-118281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118281"><a href="https://jamaicans.com/videos/%20">Videos</a></ul><li id="menu-item-79826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79826 vce-cat-276"><a href="https://jamaicans.com/jamaica/jamaica-magazine/">JA Mag</a><li id="menu-item-79856" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-79856 vce-cat-267"><a href="https://jamaicans.com/jamaica/news-announcements/">News</a><li id="menu-item-61425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61425"><a href="https://jamaicans.com/jamaican-information/">Research JA</a><li class="search-header-wrap"><a class="search_header" href="javascript:void(0)"><i class="fa fa-search"></i></a><ul class="search-header-form-ul"><li><form action="https://jamaicans.com/search-results/" class="search-form" method="get" role="search"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" title="Search for:" name="q" value="" placeholder="Search ..." class="search-field" /> </label> <input type="submit" value="Search" class="search-submit" /></form></li></ul></li></ul></nav></div></div></header><div id="main-wrapper"><div id="content" class="container site-content"><div id=“breadcrumbs”></div><div id="primary" class="vce-main-content"><main id="main" class="main-box main-box-single"><article id="post-123949" class="vce-single post-123949 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-jamaican-restaurant tag-virginia"><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span><h1 class="entry-title">Pimenta Jamaican Restaurant Brings Island Spice to Fredericksburg, Virginia</h1><div class="entry-meta"><div class="meta-item date"><span class="updated">2 hours ago</span></div><div class="meta-item author"><span class="vcard author"><span class="fn">by <a href="https://jamaicans.com/author/staffwriter/">Staff Writer</a></span></span></div></div></header><div class="meta-image"> <img width="810" height="560" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20810%20560'%3E%3C/svg%3E" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="Pimenta Jamaican Restaurant Oxtails Fredericksburg Virginia" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-810x560.jpg 810w, https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-300x207.jpg 300w, https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-768x531.jpg 768w, https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia.jpg 1000w" data-lazy-sizes="(max-width: 810px) 100vw, 810px" data-lazy-src="https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-810x560.jpg" /><noscript><img width="810" height="560" src="https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-810x560.jpg" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="Pimenta Jamaican Restaurant Oxtails Fredericksburg Virginia" srcset="https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-810x560.jpg 810w, https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-300x207.jpg 300w, https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-768x531.jpg 768w, https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Pimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia.jpg 1000w" sizes="(max-width: 810px) 100vw, 810px" /></noscript></div><div class="entry-content"><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="1532314968" data-ad-format="link"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><div class="at-above-post addthis_tool" data-url="http://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/"></div><p>Roy Simmonds, the owner of the Jamaican Pimenta <a href="https://pimentaeats.com/">restaurant</a> in downtown Fredericksburg, grew up in Jamaica and learned how to cook from his mother. As he became more experienced, he added some American-style preparations to her Jamaican specialties along with his own unique influence to create the cuisine that is on offer at his Pimenta eatery. The restaurant takes its name from “pimenta dioica,” which is also known as allspice and is a premier ingredient in authentic and spicy Jamaican jerk. Allspice brings hints of cinnamon, nutmeg, black pepper, and cloves and offers an intriguing mix of flavors that have been described as “wild and racy yet pure and delicate.” And the restaurant Pimenta is just like its namesake.</p><p>The venue has the vibe of a waterside sunset with its pink and blue walls, and with Bob Marley tunes and photographs of iconic Jamaican locations like White River and Treasure Beach, it is easy for diners to lose themselves in a Caribbean dream. The menu features fanciful headings like “Pon di River” for seafood and “Di Main Tings” for regular entrées, which add to its overall ambiance.</p><p>In addition to jerk, Pimenta offers <a href="https://jamaicans.com/simple-jamaican-beef-patty-recipe/">Jamaican patties</a>, which are dough pockets filled with spicy mixes of beef, chicken or vegetables; the Kingston Egg Rolls that are stuffed with cabbage, carrots, and green and red peppers; and The Sailing Buffalo Wings, a hearty and traditional wing dish with a Caribbean kick. The jerk dishes include Momma’s Jerk Chicken and Jerk Shrimp, while other island favorites like <a href="https://jamaicans.com/simple-jamaican-oxtail-stew-recipe/">Oxtail</a> cooked with garlic and scotch bonnet peppers provide authentic Jamaican heat. Pimenta’s Escovitch features not only fish but a whole crab in a red and green pepper blanket. They also serve <a href="https://jamaicans.com/simple-jamaican-curry-goat-recipe/">Curry Goat</a> spiced with cumin and turmeric. Desserts include Jamaican Rum Cake, cheesecake with tropical fruit topping, and coconut pie with Myers rum.</p><div class="at-below-post addthis_tool" data-url="http://jamaicans.com/pimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia/"></div><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'> <script id="mNCC" language="javascript">medianet_width = "336";
   medianet_height = "280";
   medianet_crid = "849612493";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();</script></div></div><footer class="entry-footer"><div class="meta-tags"> <a href="https://jamaicans.com/tag/jamaican-restaurant/" rel="tag">Jamaican Restaurant</a> <a href="https://jamaicans.com/tag/virginia/" rel="tag">Virginia</a></div></footer><div class="vce-share-bar"><ul class="vce-share-items"><li><a class="fa fa-facebook" href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fjamaicans.com%2Fpimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia%2F&amp;t=Pimenta%20Jamaican%20Restaurant%20Brings%20Island%20Spice%20to%20Fredericksburg%2C%20Virginia"></a></li><li><a class="fa fa-twitter" href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fjamaicans.com%2Fpimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia%2F&amp;text=Pimenta%20Jamaican%20Restaurant%20Brings%20Island%20Spice%20to%20Fredericksburg%2C%20Virginia"></a></li><li><a class="fa fa-google-plus" href="javascript:void(0);" data-url="https://plus.google.com/share?url=https%3A%2F%2Fjamaicans.com%2Fpimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia%2F"></a></li><li><a class="fa fa-pinterest" href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fjamaicans.com%2Fpimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia%2F&amp;media=https%3A%2F%2Fjamaicans.com%2Fwp-content%2Fuploads%2FPimenta-Jamaican-Restaurant-Oxtails-Fredericksburg-Virginia.jpg&amp;description=Pimenta%20Jamaican%20Restaurant%20Brings%20Island%20Spice%20to%20Fredericksburg%2C%20Virginia"></a></li><li><a class="fa fa-linkedin" href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fjamaicans.com%2Fpimenta-jamaican-restaurant-brings-island-spice-to-fredericksburg-virginia%2F&amp;title=Pimenta%20Jamaican%20Restaurant%20Brings%20Island%20Spice%20to%20Fredericksburg%2C%20Virginia"></a></li></ul></div></article><nav class="prev-next-nav"><div class="vce-next-link"> <a href="https://jamaicans.com/jamaican-in-new-york-is-small-business-award-honoree/" rel="prev"><span class="img-wrp"><img width="375" height="195" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20375%20195'%3E%3C/svg%3E" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="Jamaican in New York Is Small Business Award Honoree 3" data-lazy-src="https://jamaicans.com/wp-content/uploads/Jamaican-in-New-York-Is-Small-Business-Award-Honoree-3-e1556925475298-375x195.jpg" /><noscript><img width="375" height="195" src="https://jamaicans.com/wp-content/uploads/Jamaican-in-New-York-Is-Small-Business-Award-Honoree-3-e1556925475298-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="Jamaican in New York Is Small Business Award Honoree 3" /></noscript><span class="vce-pn-ico"><i class="fa fa fa-chevron-right"></i></span></span><span class="vce-prev-next-link">Jamaican in New York Is Small Business Award Honoree</span></a></div></nav></main><section class="main-box mbt-border-top author-box"><h3 class="main-box-title">About the author</h3><div class="main-box-inside"><div class="data-image"> <img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20112%20112'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/e2da7c869d4a6c93cae5e8d151fc0f2d?s=224&#038;d=mm&#038;r=g 2x' class='avatar avatar-112 photo' height='112' width='112' data-lazy-src="https://secure.gravatar.com/avatar/e2da7c869d4a6c93cae5e8d151fc0f2d?s=112&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/e2da7c869d4a6c93cae5e8d151fc0f2d?s=112&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e2da7c869d4a6c93cae5e8d151fc0f2d?s=224&#038;d=mm&#038;r=g 2x' class='avatar avatar-112 photo' height='112' width='112' /></noscript></div><div class="data-content"><h4 class="author-title">Staff Writer</h4><div class="data-entry-content"></div></div></div><div class="vce-content-outside"><div class="data-links"> <a href="https://jamaicans.com/author/staffwriter/" class="vce-author-link vce-button">View all posts</a></div><div class="vce-author-links"> <a href="https://www.jamaicans.com" target="_blank" class="fa fa-link vce-author-website"></a> <a href="https://www.facebook.com/onelovejamaica" target="_blank" class="fa fa-facebook"></a> <a href="https://google.com/+Jamaicans" target="_blank" class="fa fa-google"></a> <a href="https://instagram.com/jamaicans_com" target="_blank" class="fa fa-instagram"></a> <a href="https://twitter.com/jamaicansdotcom" target="_blank" class="fa fa-twitter"></a></div></div></section><div class="main-box vce-related-box"><h3 class="main-box-title">You may also like</h3><div class="main-box-inside"><article class="vce-post vce-lay-d post-115575 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-jamaican tag-marjory-stoneman-douglas-high-school tag-parkland tag-stoneman-douglas"><div class="meta-image"> <a href="https://jamaicans.com/jamaican-17-teens-died-florida-school-shooting/" title="Jamaican Among 17 Teens Who Died in Florida School Shooting"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Jamaican Helena Ramsey Parkland Shooting victim" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/Jamaican-helena-ramsey-parkland-shooting-victim-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Jamaican-helena-ramsey-parkland-shooting-victim-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/Jamaican-helena-ramsey-parkland-shooting-victim-145x100.jpg" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Jamaican-helena-ramsey-parkland-shooting-victim-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Jamaican Helena Ramsey Parkland Shooting victim" srcset="https://jamaicans.com/wp-content/uploads/Jamaican-helena-ramsey-parkland-shooting-victim-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Jamaican-helena-ramsey-parkland-shooting-victim-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span><h2 class="entry-title"><a href="https://jamaicans.com/jamaican-17-teens-died-florida-school-shooting/" title="Jamaican Among 17 Teens Who Died in Florida School Shooting">Jamaican Among 17 Teens Who Died in Florida School...</a></h2></header></article><article class="vce-post vce-lay-d post-102100 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-dudus tag-portia-simpson-miller"><div class="meta-image"> <a href="https://jamaicans.com/dudus-coke-and-portia-simpson-miller-are-not-dead/" title="Dudus Coke and Portia Simpson Miller Are Not Dead"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Portia Miller-Simpson and Dudus Coke Not Dead" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2016/11/Portia-Miller-Simpson-and-Dudus-Coke-Not-Dead-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/11/Portia-Miller-Simpson-and-Dudus-Coke-Not-Dead-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/2016/11/Portia-Miller-Simpson-and-Dudus-Coke-Not-Dead-145x100.jpg" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/11/Portia-Miller-Simpson-and-Dudus-Coke-Not-Dead-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Portia Miller-Simpson and Dudus Coke Not Dead" srcset="https://jamaicans.com/wp-content/uploads/2016/11/Portia-Miller-Simpson-and-Dudus-Coke-Not-Dead-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/11/Portia-Miller-Simpson-and-Dudus-Coke-Not-Dead-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span><h2 class="entry-title"><a href="https://jamaicans.com/dudus-coke-and-portia-simpson-miller-are-not-dead/" title="Dudus Coke and Portia Simpson Miller Are Not Dead">Dudus Coke and Portia Simpson Miller Are Not Dead</a></h2></header></article><article class="vce-post vce-lay-d post-124059 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-bunny-wailer tag-ganja tag-junior-gong-marley"><div class="meta-image"> <a href="https://jamaicans.com/netflix-releases-film-on-ganja-featuring-bunny-wailer-and-junior-gong-marley/" title="Netflix Releases Film on Ganja featuring Bunny Wailer and Junior Gong Marley"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Netflix Releases Film on Ganja featuring Bunny Wailer and Junior Gong Marley" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/Netflix-Releases-Film-on-Ganja-featuring-Bunny-Wailer-and-Junior-Gong-Marley-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Netflix-Releases-Film-on-Ganja-featuring-Bunny-Wailer-and-Junior-Gong-Marley-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/Netflix-Releases-Film-on-Ganja-featuring-Bunny-Wailer-and-Junior-Gong-Marley-145x100.jpg" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Netflix-Releases-Film-on-Ganja-featuring-Bunny-Wailer-and-Junior-Gong-Marley-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Netflix Releases Film on Ganja featuring Bunny Wailer and Junior Gong Marley" srcset="https://jamaicans.com/wp-content/uploads/Netflix-Releases-Film-on-Ganja-featuring-Bunny-Wailer-and-Junior-Gong-Marley-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Netflix-Releases-Film-on-Ganja-featuring-Bunny-Wailer-and-Junior-Gong-Marley-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span><h2 class="entry-title"><a href="https://jamaicans.com/netflix-releases-film-on-ganja-featuring-bunny-wailer-and-junior-gong-marley/" title="Netflix Releases Film on Ganja featuring Bunny Wailer and Junior Gong Marley">Netflix Releases Film on Ganja featuring Bunny Wailer...</a></h2></header></article><article class="vce-post vce-lay-d post-122511 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-chinese-jamaican tag-jamaican-chinese tag-new-england-patriots tag-patrick-chung tag-super-bowl"><div class="meta-image"> <a href="https://jamaicans.com/jamaican-patrick-chung-wins-3rd-super-bowl/" title="Jamaican Patrick Chung Wins 3rd Super Bowl Ring"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Patrick Chung" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/Patrick-Chung-e1549288131873-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Patrick-Chung-e1549288131873-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/Patrick-Chung-e1549288131873-145x100.jpg" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Patrick-Chung-e1549288131873-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Patrick Chung" srcset="https://jamaicans.com/wp-content/uploads/Patrick-Chung-e1549288131873-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Patrick-Chung-e1549288131873-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span><h2 class="entry-title"><a href="https://jamaicans.com/jamaican-patrick-chung-wins-3rd-super-bowl/" title="Jamaican Patrick Chung Wins 3rd Super Bowl Ring">Jamaican Patrick Chung Wins 3rd Super Bowl Ring</a></h2></header></article><article class="vce-post vce-lay-d post-121616 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-buju-banton"><div class="meta-image"> <a href="https://jamaicans.com/buju-banton-first-show-on-the-long-walk-to-freedom-tour-announced/" title="Buju Banton First Show on The Long Walk To Freedom Tour Announced &#8211; March 16th 2019  at Jamaican the National Stadium"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Buju Banton" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/Buju-Banton-Reggae-Artist-e1545262578661-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Buju-Banton-Reggae-Artist-e1545262578661-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/Buju-Banton-Reggae-Artist-e1545262578661-145x100.jpg" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Buju-Banton-Reggae-Artist-e1545262578661-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Buju Banton" srcset="https://jamaicans.com/wp-content/uploads/Buju-Banton-Reggae-Artist-e1545262578661-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Buju-Banton-Reggae-Artist-e1545262578661-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span><h2 class="entry-title"><a href="https://jamaicans.com/buju-banton-first-show-on-the-long-walk-to-freedom-tour-announced/" title="Buju Banton First Show on The Long Walk To Freedom Tour Announced &#8211; March 16th 2019  at Jamaican the National Stadium">Buju Banton First Show on The Long Walk To Freedom...</a></h2></header></article><article class="vce-post vce-lay-d post-114104 post type-post status-publish format-standard has-post-thumbnail hentry category-announcements tag-aidonia tag-barrington-levy tag-bunji-garlin tag-bustamante-hospital-for-children tag-capleton tag-chaka-demus-and-pliers tag-christopher-martin tag-dexta-daps tag-fay-ann-lyons tag-fetty-wap tag-junior-reid tag-professor-nuts tag-shaggy tag-shenseea tag-sting tag-third-world tag-wayne-wonder tag-wyclef-jean"><div class="meta-image"> <a href="https://jamaicans.com/shaggy-friends-announce-2018-concert-date-line/" title="Shaggy &#038; Friends Announce 2018 Concert Date And Line-Up"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Shaggy &amp; Friends Announce 2018 Concert Date And Line-Up Jamaica" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/Shaggy-Friends-Announce-2018-Concert-Date-And-Line-Up-Jamaica-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Shaggy-Friends-Announce-2018-Concert-Date-And-Line-Up-Jamaica-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/Shaggy-Friends-Announce-2018-Concert-Date-And-Line-Up-Jamaica-145x100.jpg" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Shaggy-Friends-Announce-2018-Concert-Date-And-Line-Up-Jamaica-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Shaggy &amp; Friends Announce 2018 Concert Date And Line-Up Jamaica" srcset="https://jamaicans.com/wp-content/uploads/Shaggy-Friends-Announce-2018-Concert-Date-And-Line-Up-Jamaica-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Shaggy-Friends-Announce-2018-Concert-Date-And-Line-Up-Jamaica-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/" class="category-382">Announcements</a></span><h2 class="entry-title"><a href="https://jamaicans.com/shaggy-friends-announce-2018-concert-date-line/" title="Shaggy &#038; Friends Announce 2018 Concert Date And Line-Up">Shaggy &#038; Friends Announce 2018 Concert Date And...</a></h2></header></article></div></div></div><aside id="sidebar" class="sidebar right"><div id="search-4" class="widget widget_search"><form action="https://jamaicans.com/search-results/" class="search-form" method="get" role="search"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" title="Search for:" name="q" value="" placeholder="Search ..." class="search-field" /> </label> <input type="submit" value="Search" class="search-submit" /></form></div><div id="mks_social_widget-3" class="widget mks_social_widget"><h4 class="widget-title">Follow Us</h4><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/pages/Jamaicanscom/128078147433" title="Facebook" class="socicon-facebook soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>facebook</span></a></li><li><a href="https://twitter.com/jamaicansdotcom" title="Twitter" class="socicon-twitter soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>twitter</span></a></li><li><a href="https://google.com/+Jamaicans" title="" class="socicon-google-plus soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>google-plus</span></a></li><li><a href="https://instagram.com/jamaicans_com" title="Instagram" class="socicon-instagram soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>instagram</span></a></li><li><a href="https://www.youtube.com/user/outofmanyonline" title="YouTube" class="socicon-youtube soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>youtube</span></a></li><li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="socicon-pinterest soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>pinterest</span></a></li><li><a href="https://jamaicansdotcom.tumblr.com/" title="tumblr" class="socicon-tumblr soc_circle" target="_blank" style="width: 48px; height: 48px; font-size: 16px;line-height:53px;"><span>tumblr</span></a></li></ul></div><div id="mailerlite_widget-2" class="widget widget_mailerlite_widget"><div id="mailerlite-form_1" data-temp-id="5ccf63c010c94"><div class="mailerlite-form"><form action="" method="post"><div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div><div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p></div><div class="mailerlite-form-inputs"><div class="mailerlite-form-field"> <label for="mailerlite-1-field-email">Email</label> <input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" /></div><div class="mailerlite-form-loader">Please wait...</div><div class="mailerlite-subscribe-button-container"> <input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" /></div> <input type="hidden" name="form_id" value="1" /> <input type="hidden" name="action" value="mailerlite_subscribe_form" /></div><div class="mailerlite-form-response"><h4><p><span style="color: #339966;">Thank you for sign up!</span></p></h4></div></form></div></div> <script type="text/javascript">window.addEventListener("load", function (event) {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=5ccf63c010c94] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                submitHandler: function (form) {

                    jQuery(this.submitButton).prop('disabled', true);

                    form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                        form_container.find('.mailerlite-form-loader').fadeIn()
                    });

                    var data = jQuery(form).serialize();

                    jQuery.post('https://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                        form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                            form_container.find('.mailerlite-form-response').fadeIn()
                        });
                    });
                }
            });
        });
    }, false);</script> </div><div id="vce_adsense_widget-17" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"> <a href="https://www.iriecampjamaica.com/diaspora.html"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20600'%3E%3C/svg%3E" width="300" height="600" data-lazy-src="https://news.jamaicans.com/wp-content/uploads/2019/04/Irie-Camp-Banner-Final.png" /><noscript><img src="https://news.jamaicans.com/wp-content/uploads/2019/04/Irie-Camp-Banner-Final.png" width="300" height="600" /></noscript></a></div></div><div id="vce_adsense_widget-8" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"> <a href='http://www.simbis.com/tools/phpAdsNew/adclick.php?n=a8466447' target='_blank'><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" border='0' alt='' data-lazy-src="https://www.simbis.com/tools/phpAdsNew/adview.php?what=zone:5&amp;n=a8466447"><noscript><img src='https://www.simbis.com/tools/phpAdsNew/adview.php?what=zone:5&amp;n=a8466447' border='0' alt=''></noscript></a></div></div><div id="vce_adsense_widget-15" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"> <script id="mNCC" language="javascript">medianet_width = "300";
   medianet_height = "250";
   medianet_crid = "966658449";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();</script> </div></div><div id="vce_adsense_widget-2" class="widget vce_adsense_widget vce_adsense_expand"><div class="vce_adsense_wrapper"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="3218061934"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div id="rss-5" class="widget widget_rss"><h4 class="widget-title"><a class="rsswidget" href="https://jamaicans.com/videos/?feed=rss2"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2014%2014'%3E%3C/svg%3E" alt="RSS" data-lazy-src="https://jamaicans.com/wp-includes/images/rss.png" /><noscript><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://jamaicans.com/wp-includes/images/rss.png" alt="RSS" /></noscript></a> <a class="rsswidget" href="https://jamaicans.com/videos">Videos</a></h4><ul><li><a class='rsswidget' href='https://jamaicans.com/videos/jamaican-homemade-iced-coffee-recipe/'>Jamaican Homemade Iced Coffee Recipe</a></li><li><a class='rsswidget' href='https://jamaicans.com/videos/protoje-live-performance-on-the-tonight-show-featuring-jimmy-fallon-may-2nd-2019/'>Watch Protoje live performance on The Tonight Show featuring Jimmy Fallon – May 2nd 2019</a></li></ul></div><div id="vce_adsense_widget-16" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"> <script type="text/javascript" src="//ap.lijit.com/www/delivery/fp?z=406528"></script> </div></div><div id="vce_adsense_widget-7" class="widget vce_adsense_widget vce_adsense_expand"><div class="vce_adsense_wrapper"> <script id="mNCC" language="javascript">medianet_width = "300";
   medianet_height = "600";
   medianet_crid = "526552473";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();</script> </div></div><div id="vce_adsense_widget-4" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"><div id="amzn-assoc-ad-b16961e9-7a01-4871-a07e-eaeca02e8430"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=b16961e9-7a01-4871-a07e-eaeca02e8430"></script> </div></div><div id="vce_adsense_widget-10" class="widget vce_adsense_widget"><div class="vce_adsense_wrapper"> <script id='x33x15351354282617836'>var Tynt=Tynt||[];Tynt.push('abWrx44JCr4z2Wacwqm_6r');
Tynt.cmd=Tynt.cmd||[];Tynt.cmd.push(function(){
Tynt.ads.display('300x250','x33x15351354282617836','inpage');});
(function(){var h,s=document.createElement('script');
s.src=(window.location.protocol==='https:'?
'https':'http')+'://cdn.tynt.com/siab.js';
h=document.getElementsByTagName('script')[0];
h.parentNode.insertBefore(s,h);})();</script> </div></div></aside></div><footer id="footer" class="site-footer"><div class="container"><div class="container-fix"><div class="bit-3"><div id="mks_social_widget-2" class="widget mks_social_widget"><h4 class="widget-title">Socially Speaking</h4><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/onelovejamaica" title="Facebook" class="socicon-facebook soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>facebook</span></a></li><li><a href="https://plus.google.com/+Jamaicans/" title="Google+" class="socicon-googleplus soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>googleplus</span></a></li><li><a href="https://instagram.com/jamaicans_com" title="Instagram" class="socicon-instagram soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>instagram</span></a></li><li><a href="https://twitter.com/jamaicansdotcom" title="Twitter" class="socicon-twitter soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>twitter</span></a></li><li><a href="https://www.youtube.com/user/outofmanyonline" title="YouTube" class="socicon-youtube soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>youtube</span></a></li><li><a href="https://jamaicans.com/?feed=rss" title="RSS" class="socicon-rss soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>rss</span></a></li><li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="socicon-pinterest soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>pinterest</span></a></li><li><a href="http://jamaicansdotcom.tumblr.com/" title="tumblr" class="socicon-tumblr soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>tumblr</span></a></li></ul></div><div id="mailerlite_widget-3" class="widget widget_mailerlite_widget"><div id="mailerlite-form_1" data-temp-id="5ccf63c01553e"><div class="mailerlite-form"><form action="" method="post"><div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div><div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p></div><div class="mailerlite-form-inputs"><div class="mailerlite-form-field"> <label for="mailerlite-1-field-email">Email</label> <input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" /></div><div class="mailerlite-form-loader">Please wait...</div><div class="mailerlite-subscribe-button-container"> <input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" /></div> <input type="hidden" name="form_id" value="1" /> <input type="hidden" name="action" value="mailerlite_subscribe_form" /></div><div class="mailerlite-form-response"><h4><p><span style="color: #339966;">Thank you for sign up!</span></p></h4></div></form></div></div> <script type="text/javascript">window.addEventListener("load", function (event) {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=5ccf63c01553e] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                submitHandler: function (form) {

                    jQuery(this.submitButton).prop('disabled', true);

                    form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                        form_container.find('.mailerlite-form-loader').fadeIn()
                    });

                    var data = jQuery(form).serialize();

                    jQuery.post('https://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                        form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                            form_container.find('.mailerlite-form-response').fadeIn()
                        });
                    });
                }
            });
        });
    }, false);</script> </div></div><div class="bit-3"><div id="vce_posts_widget-2" class="widget vce_posts_widget"><h4 class="widget-title">Random Jamaican Recipes</h4><ul class="vce-post-list" data-autoplay=""><li> <a href="https://jamaicans.com/7-amazing-jamaican-street-foods-you-must-try/" class="featured_image_sidebar" title="7 Amazing Jamaican Street Foods You Must Try"><span class="vce-post-img"><img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Peppered Shrimps by kwesianthony" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-145x100.png 145w, https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-380x260.png 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-145x100.png" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-145x100.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Peppered Shrimps by kwesianthony" srcset="https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-145x100.png 145w, https://jamaicans.com/wp-content/uploads/2016/05/Peppered-Shrimps-by-kwesianthony-380x260.png 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript></span></a><div class="vce-posts-wrap"> <a href="https://jamaicans.com/7-amazing-jamaican-street-foods-you-must-try/" title="7 Amazing Jamaican Street Foods You Must Try" class="vce-post-link">7 Amazing Jamaican Street Foods You Must Try</a><div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/7-amazing-jamaican-street-foods-you-must-try/#respond"><span class="dsq-postid" data-dsqidentifier="94605 https://jamaicans.com/?p=94605">Add Comment</span></a></div></div></div></li><li> <a href="https://jamaicans.com/chefnels-caribbean-rum-wing-sauce/" class="featured_image_sidebar" title="ChefNel&#8217;s Caribbean Rum Wing Sauce"><span class="vce-post-img"><img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="ChefNel&#039;s Caribbean Rum Sauce" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png 145w, https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-380x260.png 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="ChefNel&#039;s Caribbean Rum Sauce" srcset="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png 145w, https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-380x260.png 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript></span></a><div class="vce-posts-wrap"> <a href="https://jamaicans.com/chefnels-caribbean-rum-wing-sauce/" title="ChefNel&#8217;s Caribbean Rum Wing Sauce" class="vce-post-link">ChefNel&#8217;s Caribbean Rum Wing Sauce</a></div></li><li> <a href="https://jamaicans.com/jamaican-foods-listed-essential-caribbean/" class="featured_image_sidebar" title="Four Jamaican Foods Listed in Saveur Magazine’s List of 17 Essential Caribbean Dishes"><span class="vce-post-img"><img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Saltfish Fritters Essential Caribbean Dishes" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/Saltfish-Fritters-Essential-Caribbean-Dishes-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Saltfish-Fritters-Essential-Caribbean-Dishes-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/Saltfish-Fritters-Essential-Caribbean-Dishes-145x100.jpg" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Saltfish-Fritters-Essential-Caribbean-Dishes-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Saltfish Fritters Essential Caribbean Dishes" srcset="https://jamaicans.com/wp-content/uploads/Saltfish-Fritters-Essential-Caribbean-Dishes-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Saltfish-Fritters-Essential-Caribbean-Dishes-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript></span></a><div class="vce-posts-wrap"> <a href="https://jamaicans.com/jamaican-foods-listed-essential-caribbean/" title="Four Jamaican Foods Listed in Saveur Magazine’s List of 17 Essential Caribbean Dishes" class="vce-post-link">Four Jamaican Foods Listed in Saveur Magazine’s List...</a><div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/jamaican-foods-listed-essential-caribbean/#respond"><span class="dsq-postid" data-dsqidentifier="112453 https://jamaicans.com/?p=112453">Add Comment</span></a></div></div></div></li><li> <a href="https://jamaicans.com/chef-cunnys-jack-daniels-bbq-wings/" class="featured_image_sidebar" title="Chef Noel Cunningham BBQ Wings"><span class="vce-post-img"><img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-145x100.jpg" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/08/IMG_3661-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript></span></a><div class="vce-posts-wrap"> <a href="https://jamaicans.com/chef-cunnys-jack-daniels-bbq-wings/" title="Chef Noel Cunningham BBQ Wings" class="vce-post-link">Chef Noel Cunningham BBQ Wings</a><div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/chef-cunnys-jack-daniels-bbq-wings/#respond"><span class="dsq-postid" data-dsqidentifier="97656 https://jamaicans.com/?p=97656">Add Comment</span></a></div></div></div></li><li> <a href="https://jamaicans.com/9-recipes-will-make-jamaican-man-forgive/" class="featured_image_sidebar" title="9 Recipes that Will Make A Jamaican Husband/Man Forgive Anything"><span class="vce-post-img"><img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Ackee and Saltfish" data-lazy-srcset="https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-380x260.jpg 380w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-145x100.jpg" /><noscript><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Ackee and Saltfish" srcset="https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></noscript></span></a><div class="vce-posts-wrap"> <a href="https://jamaicans.com/9-recipes-will-make-jamaican-man-forgive/" title="9 Recipes that Will Make A Jamaican Husband/Man Forgive Anything" class="vce-post-link">9 Recipes that Will Make A Jamaican Husband/Man...</a><div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/9-recipes-will-make-jamaican-man-forgive/#respond"><span class="dsq-postid" data-dsqidentifier="100257 https://jamaicans.com/?p=100257">Add Comment</span></a></div></div></div></li></ul></div></div><div class="bit-3"><div id="vce_adsense_widget-9" class="widget vce_adsense_widget vce_adsense_expand"><div class="vce_adsense_wrapper"><div id="amzn-assoc-ad-e4689c20-dff8-4cad-9aa6-9cbb20113f59"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=e4689c20-dff8-4cad-9aa6-9cbb20113f59"></script> </div></div></div></div></div><div class="container-full site-info"><div align="center" style="padding-bottom: 20px;"> <script type="text/javascript">google_ad_client = "pub-1901173274277249";

google_alternate_ad_url = "https://www.jamaicans.com/images/ads/google_728X90.htm";

google_ad_width = 728;

google_ad_height = 90;

google_ad_format = "728x90_as";

google_ad_type = "text_image";

google_ad_channel = "";

google_color_border = "798DC2";

google_color_bg = "FFFFFF";

google_color_link = "5870AE";

google_color_text = "676768";

google_color_url = "2C2F4B";</script> <script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js" defer></script> </div><div class="container"><div class="vce-wrap-left"><p>Copyright © Simbis Inc. All rights reserved. <a href="https://jamaicans.com/privacy/">Privacy Policy &amp; Terms of use</a>.</p></div><div class="vce-wrap-right"><ul id="vce_footer_menu" class="bottom-nav-menu"><li id="menu-item-76837" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76837"><a href="https://www.jamaicans.com/forums/">Forums</a></li><li id="menu-item-77461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77461"><a href="https://jamaicans.com/mobile-apps/">Mobile apps</a></li><li id="menu-item-76836" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76836"><a target="_blank" href="http://www.jamaicanstore.com">Shopping</a></li><li id="menu-item-459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-459"><a href="https://jamaicans.com/our-contact/">Contact</a></li><li id="menu-item-526" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-526"><a href="https://jamaicans.com/about-us/">About Us</a></li><li id="menu-item-77011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77011"><a href="https://jamaicans.com/advertise-with-us/">Advertise</a></li></ul></div></div></div></footer></div></div><a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a> <script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='433af38b6e2402a24dab9aa3d747b3033cf5bc5d8ebe9c002919c18dd0789a50';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script> <script type="application/javascript">var ajaxurl = "https://jamaicans.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }</script> <script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://jamaicans.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "e208615a67", post_id : 123949 } ); } ); /* ]]> */</script> <script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.3"; } if (window.wp_blog_version === undefined) { window.wp_blog_version = "5.1.1"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":"300"}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.3","plugin_mode":"WordPress","anonymous_profile_id":"wp-bf34677b4718a8fdb8e7d271cfbb868e","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());</script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=wp-bf34677b4718a8fdb8e7d271cfbb868e" async="async"></script><script type='text/javascript'>/* <![CDATA[ */ var wpcf7 = {"apiSettings":{"root":"https:\/\/jamaicans.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://jamaicans.com/wp-content/cache/min/1/wp-content/plugins/contact-form-7/includes/js/scripts-bc9debcecac91b86c25a648b32e61c12.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var countVars = {"disqusShortname":"jamaicanscom"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://jamaicans.com/wp-content/cache/min/1/wp-content/plugins/disqus-comment-system/public/js/comment_count-ee46bee2ce68148bd4c00d5b1989d47a.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var vce_js_settings = {"sticky_header":"1","sticky_header_offset":"200","sticky_header_logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/08\/final-logo-abbr.png","logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/01\/jamaicans_logo.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"https:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","ajax_wpml_current_lang":null,"ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"1","full_slider_autoplay":"","grid_slider_autoplay":"","grid_big_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"0","top_bar_mobile_group":"1","top_bar_more_link":null}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://jamaicans.com/wp-content/cache/min/1/wp-content/themes/voice/js/min-42d1e37e19edcd2419e54f314dc841f5.js' defer></script> <script type='text/javascript' src='https://jamaicans.com/wp-content/cache/busting/1/wp-content/plugins/official-mailerlite-sign-up-forms/assets/js/jquery.validate.min-7d3f4c0bd9b30e2438076ca4b2029dd9.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var fcaPcEvents = [];
var fcaPcDebug = {"debug":""};
var fcaPcPost = {"title":"Pimenta Jamaican Restaurant Brings Island Spice to Fredericksburg, Virginia","type":"post","id":"123949","categories":["Announcements"],"utm_support":"","user_parameters":"","edd_delay":"0","woo_delay":"0","edd_enabled":"","woo_enabled":""}; /* ]]> */</script> <script type='text/javascript' src='https://jamaicans.com/wp-content/cache/busting/1/wp-content/plugins/facebook-conversion-pixel/pixel-cat.min-2.4.2.js' defer></script> <script>window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                skip_invisible: false,
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_load: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;
        
            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            imgs = mutation.addedNodes[i].getElementsByTagName('img');
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            if ( 0 === imgs.length && 0 === iframes.length && 0 === rocket_lazy.length ) {
                                return;
                            }

                            lazyLoadInstance.update();
                        }
                    } );
                } );
                
                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };
                
                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="https://jamaicans.com/wp-content/plugins/wp-rocket/assets/js/lazyload/11.0.6/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="https://www.youtube.com/embed/ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.id)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script> <noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%7CRoboto%20Slab%3A400%7COswald%3A400&subset=" /></noscript><noscript><link rel="stylesheet" href="https://jamaicans.com/wp-content/cache/min/1/b9f078262ec545e71abf1dc80710e80f.css" data-minify="1" /></noscript><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%7CRoboto%20Slab%3A400%7COswald%3A400&subset=" /></noscript><noscript><link rel="stylesheet" href="https://jamaicans.com/wp-content/cache/min/1/b9f078262ec545e71abf1dc80710e80f.css" data-minify="1" /></noscript></body></html>
