<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" class="no-js no-svg">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1, minimum-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<script>
			!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
			n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
			document,'script','https://connect.facebook.net/en_US/fbevents.js');
			fbq('init', '1055480241142713' );			fbq('track', 'PageView');

			</script>
<noscript><img height="1" width="1" style="display:none"
			src="https://www.facebook.com/tr?id=1055480241142713&ev=PageView&noscript=1"
			/></noscript>



<title>WEEKLY DEVOTIONAL - Let God be God - Jamaicans.com</title>
<meta name="description" content="Often times we miss out on God&#039;s exceedingly, abundantly above all we could ask or think (Ephesians 3:20) because, in our mind&#039;s eye, it just doesn&#039;t add up." />
<link rel="canonical" href="https://jamaicans.com/weekly-devotional-let-god-be-god/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="WEEKLY DEVOTIONAL - Let God be God - Jamaicans.com" />
<meta property="og:description" content="Often times we miss out on God&#039;s exceedingly, abundantly above all we could ask or think (Ephesians 3:20) because, in our mind&#039;s eye, it just doesn&#039;t add up." />
<meta property="og:url" content="http://jamaicans.com/weekly-devotional-let-god-be-god/" />
<meta property="og:site_name" content="Jamaicans.com" />
<meta property="article:published_time" content="2021-08-13T09:30:20+00:00" />
<meta property="og:image" content="https://jamaicans.com/wp-content/uploads/letgodbegod.jpg" />
<meta property="og:image:width" content="505" />
<meta property="og:image:height" content="308" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Colin Wilson" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="4 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://jamaicans.com/#website","url":"https://jamaicans.com/","name":"Jamaicans.com","description":"Out of Many, One People Online","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://jamaicans.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://jamaicans.com/weekly-devotional-let-god-be-god/#primaryimage","inLanguage":"en-US","url":"https://jamaicans.com/wp-content/uploads/letgodbegod.jpg","contentUrl":"https://jamaicans.com/wp-content/uploads/letgodbegod.jpg","width":505,"height":308,"caption":"Let God be God"},{"@type":"WebPage","@id":"https://jamaicans.com/weekly-devotional-let-god-be-god/#webpage","url":"https://jamaicans.com/weekly-devotional-let-god-be-god/","name":"WEEKLY DEVOTIONAL - Let God be God - Jamaicans.com","isPartOf":{"@id":"https://jamaicans.com/#website"},"primaryImageOfPage":{"@id":"https://jamaicans.com/weekly-devotional-let-god-be-god/#primaryimage"},"datePublished":"2021-08-13T09:30:20+00:00","dateModified":"2021-08-13T09:30:20+00:00","author":{"@id":"https://jamaicans.com/#/schema/person/e5b7219b64aa66241ef044712562cf22"},"description":"Often times we miss out on God's exceedingly, abundantly above all we could ask or think (Ephesians 3:20) because, in our mind's eye, it just doesn't add up.","breadcrumb":{"@id":"https://jamaicans.com/weekly-devotional-let-god-be-god/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://jamaicans.com/weekly-devotional-let-god-be-god/"]}]},{"@type":"BreadcrumbList","@id":"https://jamaicans.com/weekly-devotional-let-god-be-god/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://jamaicans.com/"},{"@type":"ListItem","position":2,"name":"WEEKLY DEVOTIONAL &#8211; Let God be God"}]},{"@type":"Person","@id":"https://jamaicans.com/#/schema/person/e5b7219b64aa66241ef044712562cf22","name":"Colin Wilson","image":{"@type":"ImageObject","@id":"https://jamaicans.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/23f05fd9d6f1216560d30b8800b4c038?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/23f05fd9d6f1216560d30b8800b4c038?s=96&d=mm&r=g","caption":"Colin Wilson"},"description":"Easy going, dislike negativity, and an optimist. I believe that amidst the hustle and bustle of everyday living, each day is a gift from God and if we stop and think about it, there is at least one thing for which we ought to be thankful. In addition, I believe that every day is a great day to be alive. No matter how bad we think we have it, there are any number of people who are on the \"other side\" who, if they could, would gladly trade places with us. Email me at churchdude@outlook.com","url":"https://jamaicans.com/author/colinwilson/"}]}</script>

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Feed" href="https://jamaicans.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Comments Feed" href="https://jamaicans.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jamaicans.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=3500f9c9638f8da19fe3de33a1de82fa"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wgs2-css' href='https://jamaicans.com/wp-content/plugins/wp-google-search/wgs2.css?ver=3500f9c9638f8da19fe3de33a1de82fa' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://jamaicans.com/wp-includes/css/dist/block-library/style.min.css?ver=3500f9c9638f8da19fe3de33a1de82fa' type='text/css' media='all' />
<link rel='stylesheet' id='mks_shortcodes_simple_line_icons-css' href='https://jamaicans.com/wp-content/plugins/meks-flexible-shortcodes/css/simple-line/simple-line-icons.css?ver=1.3.3' type='text/css' media='screen' />
<link rel='stylesheet' id='mks_shortcodes_css-css' href='https://jamaicans.com/wp-content/plugins/meks-flexible-shortcodes/css/style.css?ver=1.3.3' type='text/css' media='screen' />
<link rel='stylesheet' id='mailerlite_forms.css-css' href='https://jamaicans.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/css/mailerlite_forms.css?ver=1.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='wpProQuiz_front_style-css' href='https://jamaicans.com/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all' />
<link rel='stylesheet' id='vce-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%7CRoboto+Slab%3A400%7COswald%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='vce-style-css' href='https://jamaicans.com/wp-content/themes/voice/assets/css/min.css?ver=2.9.9' type='text/css' media='all' />
<style id='vce-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='meks-ads-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-easy-ads-widget/css/style.css?ver=2.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='meks_instagram-widget-styles-css' href='https://jamaicans.com/wp-content/plugins/meks-easy-instagram-widget/css/widget.css?ver=3500f9c9638f8da19fe3de33a1de82fa' type='text/css' media='all' />
<link rel='stylesheet' id='meks-flickr-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-simple-flickr-widget/css/style.css?ver=1.2' type='text/css' media='all' />
<link rel='stylesheet' id='meks-author-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-smart-author-widget/css/style.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='meks-social-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-smart-social-widget/css/style.css?ver=1.5' type='text/css' media='all' />
<link rel='stylesheet' id='meks-themeforest-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-themeforest-smart-widget/css/style.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='meks_ess-main-css' href='https://jamaicans.com/wp-content/plugins/meks-easy-social-share/assets/css/main.css?ver=1.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp_review-style-css' href='https://jamaicans.com/wp-content/plugins/wp-review/public/css/wp-review.css?ver=5.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css' href='https://jamaicans.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=3500f9c9638f8da19fe3de33a1de82fa' type='text/css' media='all' />
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-2520621-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["jamaicans.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-2520621-1", {"anonymize_ip":true});
</script>
<link rel="https://api.w.org/" href="https://jamaicans.com/wp-json/" /><link rel="alternate" type="application/json" href="https://jamaicans.com/wp-json/wp/v2/posts/151237" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jamaicans.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jamaicans.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://jamaicans.com/?p=151237' />
<link rel="alternate" type="application/json+oembed" href="https://jamaicans.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-let-god-be-god%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://jamaicans.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-let-god-be-god%2F&#038;format=xml" />
<meta name="framework" content="Redux 4.2.14" /><meta name="generator" content="Site Kit by Google 1.38.1" />
<script>
(function(m,a,i,l,e,r){ m['MailerLiteObject']=e;function f(){
var c={ a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?v'+(~~(new Date().getTime()/1000000));
_.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');
</script>
 
<script>
        (function (m, a, i, l, e, r) {
            m['MailerLiteObject'] = e;

            function f() {
                var c = {a: arguments, q: []};
                var r = this.push(c);
                return "number" != typeof r ? r : f.bind(c.q);
            }

            f.q = f.q || [];
            m[e] = m[e] || f.bind(f.q);
            m[e].q = m[e].q || f.q;
            r = a.createElement(i);
            var _ = a.getElementsByTagName(i)[0];
            r.async = 1;
            r.src = l + '?' + (~~(new Date().getTime() / 10000000));
            _.parentNode.insertBefore(r, _);
        })(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

        var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');
    </script>

<script type="text/javascript">
                var rsssl_share_url = window.location.href.replace('https://', 'http://');
                var addthis_share = {url: '' + rsssl_share_url + ''};
            </script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-1901173274277249","enable_page_level_ads":true,"tag_partner":"site_kit"});</script> <style type="text/css" id="wp-custom-css">
			.main-box-head {display:none;}		</style>
<style>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
</head>
<body data-rssslsocial=1 class="post-template-default single single-post postid-151237 single-format-standard wp-embed-responsive vce-sid-right voice-v_2_9_9">
<div id="vce-main">
<header id="header" class="main-header">
<div class="container header-2-wrapper header-main-area">
<div class="vce-res-nav">
<a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a>
</div>
<div class="site-branding">
<span class="site-title"><a href="https://jamaicans.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><source srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><img src="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png" alt="Jamaicans.com"></picture></a></span></div>
<div class="vce-header-ads">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="9929021134"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</div>
<div class="header-bottom-wrapper header-left-nav">
<div class="container">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-83497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-83497"><a href="https://jamaicans.com/recipes/">Recipes</a>
<ul class="sub-menu">
<li id="menu-item-150405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150405 vce-cat-422"><a href="https://jamaicans.com/jamaica/recipes/recipes-meat/">Meat Recipes</a> <li id="menu-item-150406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150406 vce-cat-406"><a href="https://jamaicans.com/jamaica/recipes/recipes-jamaican-food-photos/">Photo Gallery of Jamaican Foods</a> <li id="menu-item-150407" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150407 vce-cat-322"><a href="https://jamaicans.com/jamaica/recipes/recipes-pork/">Pork Recipes</a> <li id="menu-item-150408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150408 vce-cat-402"><a href="https://jamaicans.com/jamaica/recipes/recipes-sauces/">Sauce Recipes</a> <li id="menu-item-150409" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150409 vce-cat-396"><a href="https://jamaicans.com/jamaica/recipes/recipes-fish/">Seafood Recipes</a> <li id="menu-item-150410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150410 vce-cat-338"><a href="https://jamaicans.com/jamaica/recipes/recipes-seasonal/">Seasonal Recipes</a> <li id="menu-item-150411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150411 vce-cat-317"><a href="https://jamaicans.com/jamaica/recipes/recipes-soup/">Soup Recipes</a> <li id="menu-item-150414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150414 vce-cat-377"><a href="https://jamaicans.com/jamaica/recipes/recipes-traditional/">Traditional Recipes</a> <li id="menu-item-150415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150415 vce-cat-358"><a href="https://jamaicans.com/jamaica/recipes/recipes-vegetarian/">Vegetarian Recipes</a></ul>
<li id="menu-item-77663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77663"><a href="https://jamaicans.com/speak-jamaican/">Speak JA</a><li id="menu-item-79826" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-79826 vce-cat-276"><a href="https://jamaicans.com/jamaica/jamaica-magazine/">Features</a>
<ul class="sub-menu">
<li id="menu-item-150388" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150388 vce-cat-341"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-articles/">Main Feature</a> <li id="menu-item-150389" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150389 vce-cat-339"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-interviews/">Interviews</a> <li id="menu-item-150387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150387 vce-cat-348"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-advice/">Advice &amp; Help</a> <li id="menu-item-150390" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150390 vce-cat-325"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-comments/">Commentary</a> <li id="menu-item-150396" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150396 vce-cat-312"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-blogs/">Blogs</a></ul>
<li id="menu-item-146369" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146369 vce-cat-284"><a href="https://jamaicans.com/jamaica/bestofja/">Best Of Jamaica</a><li id="menu-item-79827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79827 vce-cat-40"><a href="https://jamaicans.com/jamaica/culture-jamaica/">Culture</a><li id="menu-item-79829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79829 vce-cat-265"><a href="https://jamaicans.com/jamaica/jamaican-music/">Music</a><li id="menu-item-61427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61427"><a href="https://jamaicans.com/travel-jamaica/">Travel</a><li id="menu-item-118281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118281"><a href="https://jamaicans.com/videos/%20">Videos</a><li id="menu-item-118279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118279"><a href="https://jamaicans.com/photogallery/">Photos</a><li id="menu-item-79856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-79856 vce-cat-267"><a href="https://jamaicans.com/jamaica/news-announcements/">News &#038; Media</a>
<ul class="sub-menu">
<li id="menu-item-150416" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-150416 vce-cat-856"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/">Weekly Devotional</a> <li id="menu-item-150418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150418 vce-cat-382"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/">Announcements</a> <li id="menu-item-150417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-150417"><a href="https://irietimes.jamaicans.com/">Irie Times Radio</a> <li id="menu-item-150419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150419 vce-cat-432"><a href="https://jamaicans.com/jamaica/news-announcements/events/">Events</a></ul>
<li id="menu-item-61425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61425"><a href="https://jamaicans.com/jamaican-information/">Research JA</a></ul></nav> </div>
</div></header>
<div id="sticky_header" class="header-sticky">
<div class="container">
<div class="vce-res-nav">
<a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a>
</div>
<div class="site-branding">
<span class="site-title"><a href="https://jamaicans.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" srcset="https://jamaicans.com/wp-content/uploads/2015/08/final-logo-abbr.png"><source srcset="https://jamaicans.com/wp-content/uploads/2015/08/final-logo-abbr.png"><img src="https://jamaicans.com/wp-content/uploads/2015/08/final-logo-abbr.png" alt="Jamaicans.com"></picture></a></span></div> <nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="vce_main_navigation_menu" class="nav-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-83497"><a href="https://jamaicans.com/recipes/">Recipes</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150405 vce-cat-422"><a href="https://jamaicans.com/jamaica/recipes/recipes-meat/">Meat Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150406 vce-cat-406"><a href="https://jamaicans.com/jamaica/recipes/recipes-jamaican-food-photos/">Photo Gallery of Jamaican Foods</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150407 vce-cat-322"><a href="https://jamaicans.com/jamaica/recipes/recipes-pork/">Pork Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150408 vce-cat-402"><a href="https://jamaicans.com/jamaica/recipes/recipes-sauces/">Sauce Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150409 vce-cat-396"><a href="https://jamaicans.com/jamaica/recipes/recipes-fish/">Seafood Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150410 vce-cat-338"><a href="https://jamaicans.com/jamaica/recipes/recipes-seasonal/">Seasonal Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150411 vce-cat-317"><a href="https://jamaicans.com/jamaica/recipes/recipes-soup/">Soup Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150414 vce-cat-377"><a href="https://jamaicans.com/jamaica/recipes/recipes-traditional/">Traditional Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150415 vce-cat-358"><a href="https://jamaicans.com/jamaica/recipes/recipes-vegetarian/">Vegetarian Recipes</a></ul>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77663"><a href="https://jamaicans.com/speak-jamaican/">Speak JA</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-79826 vce-cat-276"><a href="https://jamaicans.com/jamaica/jamaica-magazine/">Features</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150388 vce-cat-341"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-articles/">Main Feature</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150389 vce-cat-339"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-interviews/">Interviews</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150387 vce-cat-348"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-advice/">Advice &amp; Help</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150390 vce-cat-325"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-comments/">Commentary</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150396 vce-cat-312"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-blogs/">Blogs</a></ul>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146369 vce-cat-284"><a href="https://jamaicans.com/jamaica/bestofja/">Best Of Jamaica</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79827 vce-cat-40"><a href="https://jamaicans.com/jamaica/culture-jamaica/">Culture</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79829 vce-cat-265"><a href="https://jamaicans.com/jamaica/jamaican-music/">Music</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61427"><a href="https://jamaicans.com/travel-jamaica/">Travel</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118281"><a href="https://jamaicans.com/videos/%20">Videos</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118279"><a href="https://jamaicans.com/photogallery/">Photos</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-79856 vce-cat-267"><a href="https://jamaicans.com/jamaica/news-announcements/">News &#038; Media</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-150416 vce-cat-856"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/">Weekly Devotional</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150418 vce-cat-382"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/">Announcements</a> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-150417"><a href="https://irietimes.jamaicans.com/">Irie Times Radio</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150419 vce-cat-432"><a href="https://jamaicans.com/jamaica/news-announcements/events/">Events</a></ul>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61425"><a href="https://jamaicans.com/jamaican-information/">Research JA</a></ul></nav> </div>
</div>
<div id="main-wrapper">
<div class="vce-ad-below-header vce-ad-container">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2520621-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2520621-1');
</script>
</div>
<div id="content" class="container site-content vce-sid-right">
<div id="primary" class="vce-main-content">
<main id="main" class="main-box main-box-single">
<article id="post-151237" class="vce-single post-151237 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional tag-faith-and-doubt tag-in-the-valley-of-dry-bones tag-let-god-be-god-exceedingly-abundantly-above-all tag-trusting-god">
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h1 class="entry-title">WEEKLY DEVOTIONAL &#8211; Let God be God</h1>
<div class="entry-meta"><div class="meta-item date"><span class="updated">6 hours ago</span></div><div class="meta-item author"><span class="vcard author"><span class="fn">by <a href="https://jamaicans.com/author/colinwilson/">Colin Wilson</a></span></span></div></div>
</header>
<div class="meta-image">
<img width="505" height="308" src="https://jamaicans.com/wp-content/uploads/letgodbegod.jpg" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/letgodbegod.jpg 505w, https://jamaicans.com/wp-content/uploads/letgodbegod-300x183.jpg 300w" sizes="(max-width: 505px) 100vw, 505px" />
</div>
<div class="entry-content">
<div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="1532314968" data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="at-above-post addthis_tool" data-url="http://jamaicans.com/weekly-devotional-let-god-be-god/"></div><p>What would you do if God told you to prophesy over a pile of dried-out bones? Or, to speak to a dried-up dream?  Some of us would like to believe that we would do that just.  Well, God bless you.  For others, not so fast.  Our logical minds would instantly react: &#8220;How does that make any sense?&#8221; &#8220;What is that going to do?&#8221; &#8220;I don&#8217;t want to look like an idiot!&#8221; or some variation of those statements.  Yet, isn&#8217;t it just like God to sometimes ask us to do the illogical in order for us to see the supernatural?  Often times we miss out on God&#8217;s exceedingly, abundantly above all we could ask or think (Ephesians 3:20) because, in our mind&#8217;s eye, it just doesn&#8217;t add up.  Hence, we do nothing or we do something that seems logical to us but very different than what God asked us to do.</p>
<p>However, God did not give us the task of trying to figure Him out, but rather that we trust Hm.  Even when His instructions do not make sense to our natural minds.  Through the prophet Isaiah, He declares, “For My thoughts are not your thoughts, nor are your ways My ways . . . For as the heavens are higher than the earth, so are My ways higher than your ways and My thoughts higher than your thoughts&#8221; (<a href="https://www.biblegateway.com/passage/?search=Isaiah+55%3A8-9&amp;version=AMP" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Isaiah+55%3A8-9&amp;version=AMP">Isaiah 55:8-9, AMP</a>). While some believe this portion of Scripture relates to God&#8217;s pardon (see<a href="https://www.biblegateway.com/passage/?search=Isaiah+55%3A1-7&amp;version=AMP" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Isaiah+55%3A1-7&amp;version=AMP"> vv. 1-7</a>), it could apply to any and everything because we, with our finite minds, can and could never understand the infinite mind of God.  Paul puts it this way: &#8220;Oh, the depth of the riches and wisdom and knowledge of God! How unsearchable are His judgments and decisions and how unfathomable and untraceable are His ways!  For who has known the mind of the Lord, or who has been His counselor?&#8221; <a href="https://www.biblegateway.com/passage/?search=Romans+11%3A33-34&amp;version=AMP" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Romans+11%3A33-34&amp;version=AMP">Romans 11:33-34.</a></p>
<p>Standing in his vision in the valley of dry bones which represented the dried-up dream of the exiled ancient Israelites, God gave Ezekiel three sets of instructions that made no sense: &#8220;Prophesy upon these bones, and say unto them, &#8216;O ye dry bones, hear the word of the LORD&#8217; (see <a href="https://www.biblegateway.com/passage/?search=Ezekiel+37%3A4-6&amp;version=KJV" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Ezekiel+37%3A4-6&amp;version=KJV">Ezekiel 37:4-6</a>); &#8220;Prophesy unto the wind, prophesy, son of man, and say to the wind, &#8216;Thus saith the Lord GOD; Come from the four winds, O breath, and breathe upon these slain, that they may live'&#8221; (see<a href="https://www.biblegateway.com/passage/?search=Ezekiel+37%3A9&amp;version=KJV" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Ezekiel+37%3A9&amp;version=KJV"> v. 9</a>); &#8220;Prophesy and say unto [these bones], &#8216;Thus saith the Lord GOD; Behold, O my people, I will open your graves, and cause you to come up out of your graves, and bring you into the land of Israel'&#8221; (see <a href="https://www.biblegateway.com/passage/?search=Ezekiel+37%3A11-14&amp;version=KJV" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Ezekiel+37%3A11-14&amp;version=KJV">vv, 11-14</a>).  With every obeyed instruction, things happened (vv.<a href="https://www.biblegateway.com/passage/?search=Ezekiel+37%3A7-8&amp;version=KJV" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Ezekiel+37%3A7-8&amp;version=KJV"> 7-8</a>; <a href="https://www.biblegateway.com/passage/?search=Ezekiel+37%3A10&amp;version=KJV" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Ezekiel+37%3A10&amp;version=KJV">10</a>) with the fulfillment of the third prophesy coming later on.  Couldn&#8217;t God have done all of this without human intervention? Of course, He could have, but then the prophet would not have learned the importance of the results that came from acting on God&#8217;s word or be reminded that God is God over everything, including helpless-looking situations.</p>
<div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-1901173274277249" data-ad-slot="1751381785"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>God is as trustworthy today as He was then.  It is no wonder Mary, the mother of Jesus, said to the servants at the wedding where the wine ran out, &#8220;Whatever He says to you, do it” (<a href="https://www.biblegateway.com/passage/?search=John+2%3A5&amp;version=AMP" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=John+2%3A5&amp;version=AMP">John 2:5</a>).  Implied in the statement is that regardless of whatever it was, no matter how crazy it sounded, don&#8217;t try to figure it out, just do it!  In other words, let God be God! Often times when we ask Him for help or directions, He will give us instructions. We are meant to be active participants in God&#8217;s plan for our lives and this requires us to act on what He has spoken into our hearts. It doesn&#8217;t have to make sense to us or anyone around us; He knows what He is doing. In the Proverbs, we read, &#8220;Trust in and rely confidently on the Lord with all your heart and do not rely on your own insight or understanding.  In all your ways know and acknowledge and recognize Him, and He will make your paths straight and smooth [removing obstacles that block your way]&#8221; (<a href="https://www.biblegateway.com/passage/?search=Proverbs+3%3A5-6&amp;version=AMP" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Proverbs+3%3A5-6&amp;version=AMP">3:5-6</a>).  Notice the promise comes with conditions that have to be met first.  God will always do His part.  It is up to you and me to do ours, and let God be God.</p>
<div class="at-below-post addthis_tool" data-url="http://jamaicans.com/weekly-devotional-let-god-be-god/"></div><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>

<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="8801353632" data-ad-format="link" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

</div>
<footer class="entry-footer">
<div class="meta-tags">
<a href="https://jamaicans.com/tag/faith-and-doubt/" rel="tag">faith and doubt</a> <a href="https://jamaicans.com/tag/in-the-valley-of-dry-bones/" rel="tag">in the valley of dry bones</a> <a href="https://jamaicans.com/tag/let-god-be-god-exceedingly-abundantly-above-all/" rel="tag">let God be God; exceedingly abundantly above all</a> <a href="https://jamaicans.com/tag/trusting-god/" rel="tag">trusting God</a> </div>
</footer>
<div class="vce-share-bar">
<ul class="vce-share-items">
<div class="meks_ess rounded no-labels solid "><a href="#" onclick="return false;" class="meks_ess-item socicon-facebook" data-url="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fjamaicans.com%2Fweekly-devotional-let-god-be-god%2F&amp;t=WEEKLY%20DEVOTIONAL%20%E2%80%93%20Let%20God%20be%20God"><span>Facebook</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-twitter" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-let-god-be-god%2F&amp;text=WEEKLY%20DEVOTIONAL%20%E2%80%93%20Let%20God%20be%20God"><span>Twitter</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-reddit" data-url="http://www.reddit.com/submit?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-let-god-be-god%2F&amp;title=WEEKLY%20DEVOTIONAL%20%E2%80%93%20Let%20God%20be%20God"><span>Reddit</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-pinterest" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-let-god-be-god%2F&amp;media=https%3A%2F%2Fjamaicans.com%2Fwp-content%2Fuploads%2Fletgodbegod.jpg&amp;description=WEEKLY%20DEVOTIONAL%20%E2%80%93%20Let%20God%20be%20God"><span>Pinterest</span></a><a href="/cdn-cgi/l/email-protection#ccf3bfb9aea6a9afb8f19b8989878095e9fefc88899a83988583828d80e9fefce989fee9f4fce9f5ffe9fefc80a9b8e9fefc8ba3a8e9fefcaea9e9fefc8ba3a8eaada1bcf7aea3a8b5f1a4b8b8bcbfe9ff8de9fe8ae9fe8aa6ada1ada5afada2bfe2afa3a1e9fe8abba9a9a7a0b5e1a8a9baa3b8a5a3a2ada0e1a0a9b8e1aba3a8e1aea9e1aba3a8e9fe8a" class="meks_ess-item  socicon-mail prevent-share-popup "><span>Email</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-linkedin" data-url="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-let-god-be-god%2F"><span>LinkedIn</span></a><a href="https://api.whatsapp.com/send?text=WEEKLY%20DEVOTIONAL%20%E2%80%93%20Let%20God%20be%20God https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-let-god-be-god%2F" class="meks_ess-item socicon-whatsapp prevent-share-popup"><span>WhatsApp</span></a></div> </ul>
</div>
</article>
<nav class="prev-next-nav">
<div class="vce-next-link">
<a href="https://jamaicans.com/weekly-devotional-keep-the-dream-alive/" rel="prev"><span class="img-wrp"><img width="375" height="195" src="https://jamaicans.com/wp-content/uploads/keepthedreamalive-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="" loading="lazy" /><span class="vce-pn-ico"><i class="fa fa fa-chevron-right"></i></span></span><span class="vce-prev-next-link">WEEKLY DEVOTIONAL &#8211; Keep the Dream Alive</span></a> </div>
</nav>
</main>
<section class="main-box mbt-border-top author-box">
<h3 class="main-box-title">About the author</h3>
<div class="main-box-inside">
<div class="data-image">
<img alt='' src='https://secure.gravatar.com/avatar/23f05fd9d6f1216560d30b8800b4c038?s=112&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/23f05fd9d6f1216560d30b8800b4c038?s=224&#038;d=mm&#038;r=g 2x' class='avatar avatar-112 photo' height='112' width='112' loading='lazy' /> </div>
<div class="data-content">
<h4 class="author-title">Colin Wilson</h4>
<div class="data-entry-content">
<p>Easy going, dislike negativity, and an optimist. I believe that amidst the hustle and bustle of everyday living, each day is a gift from God and if we stop and think about it, there is at least one thing for which we ought to be thankful. In addition, I believe that every day is a great day to be alive. No matter how bad we think we have it, there are any number of people who are on the "other side" who, if they could, would gladly trade places with us. Email me at <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="44272c3136272c20312021042b3130282b2b2f6a272b29">[email&#160;protected]</a></p>
</div>
</div>
</div>
<div class="vce-content-outside">
<div class="data-links">
<a href="https://jamaicans.com/author/colinwilson/" class="vce-author-link vce-button">View all posts</a>
</div>
<div class="vce-author-links">
</div>
</div>
</section>
<div class="main-box vce-related-box">
<h3 class="main-box-title">You may also like</h3>
<div class="main-box-inside">
<article class="vce-post vce-lay-d post-113534 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional tag-not-my-will tag-submission tag-surrender">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-not-my-will/" title="WEEKLY DEVOTIONAL &#8211; &#8220;Not My Will, But Thine, Be Done&#8221;">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/notmywill-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/notmywill-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/notmywill-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-not-my-will/" title="WEEKLY DEVOTIONAL &#8211; &#8220;Not My Will, But Thine, Be Done&#8221;">WEEKLY DEVOTIONAL &#8211; &#8220;Not My Will, But...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-83662 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional tag-devotional tag-god tag-psalm">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-god-is-no-mans-debtor/" title="WEEKLY DEVOTIONAL – God is No Man&#8217;s Debtor">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2015/03/devotion-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2015/03/devotion-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/03/devotion-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-god-is-no-mans-debtor/" title="WEEKLY DEVOTIONAL – God is No Man&#8217;s Debtor">WEEKLY DEVOTIONAL – God is No Man&#8217;s Debtor</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-107481 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional tag-determination tag-esther tag-if-i-perish">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-perish-perish/" title="WEEKLY DEVOTIONAL &#8211; &#8220;If I Perish, I Perish&#8221;">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2017/04/ruthperish-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2017/04/ruthperish-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2017/04/ruthperish-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-perish-perish/" title="WEEKLY DEVOTIONAL &#8211; &#8220;If I Perish, I Perish&#8221;">WEEKLY DEVOTIONAL &#8211; &#8220;If I Perish, I...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-122723 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional tag-adversities tag-challenges tag-christian-faith tag-fear">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-does-jesus-care/" title="WEEKLY DEVOTIONAL &#8211; Does Jesus Care?">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/doesjesuscare-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="does Jesus care" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/doesjesuscare-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/doesjesuscare-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-does-jesus-care/" title="WEEKLY DEVOTIONAL &#8211; Does Jesus Care?">WEEKLY DEVOTIONAL &#8211; Does Jesus Care?</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-62150 post type-post status-publish format-standard has-post-thumbnail hentry category-jamaica-magazine category-weekly-devotional tag-devotional tag-god tag-psalm">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-baring-the-soul/" title="WEEKLY DEVOTIONAL &#8211; Baring the Soul">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2015/03/devotion-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2015/03/devotion-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/03/devotion-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/" class="category-276">Jamaica Magazine</a> <span>&bull;</span> <a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-baring-the-soul/" title="WEEKLY DEVOTIONAL &#8211; Baring the Soul">WEEKLY DEVOTIONAL &#8211; Baring the Soul</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-111085 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-refiners-fire/" title="WEEKLY DEVOTIONAL &#8211; The Refiner&#8217;s Fire">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/refinersfire-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/refinersfire-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/refinersfire-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-refiners-fire/" title="WEEKLY DEVOTIONAL &#8211; The Refiner&#8217;s Fire">WEEKLY DEVOTIONAL &#8211; The Refiner&#8217;s Fire</a></h2>
</header>
</article>
</div>
</div>
</div>
<aside id="sidebar" class="sidebar right">
<div id="search-2" class="widget widget_search"><form class="vce-search-form" action="https://jamaicans.com/" method="get">
<input name="s" class="vce-search-input" size="20" type="text" value="Type here to search..." onfocus="(this.value == 'Type here to search...') && (this.value = '')" onblur="(this.value == '') && (this.value = 'Type here to search...')" placeholder="Type here to search..." />
<button type="submit" class="vce-search-submit"><i class="fa fa-search"></i></button>
</form></div><div id="custom_html-5" class="widget_text vce-no-padding widget widget_custom_html"><div class="textwidget custom-html-widget"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="3218061934"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "250";
   medianet_crid = "966658449";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div></div><div id="rss-5" class="widget widget_rss"><h4 class="widget-title"><a class="rsswidget" href="https://jamaicans.com/videos/?feed=rss2"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://jamaicans.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://jamaicans.com/videos">Videos</a></h4><ul><li><a class='rsswidget' href='https://jamaicans.com/videos/watch-how-to-make-tun-turn-cornmeal-deddys-kitchen/'>WATCH: How to make Tun “Turn” Cornmeal! | Deddy’s Kitchen</a></li><li><a class='rsswidget' href='https://jamaicans.com/videos/watch-the-ultimate-smoothie-bowl-quick-easy-healthy-delicious/'>WATCH: The Ultimate Smoothie Bowl | QUICK, EASY, HEALTHY &amp; DELICIOUS</a></li></ul></div><div id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="text/javascript" src="//ap.lijit.com/www/delivery/fp?z=406528"></script></div></div><div id="custom_html-7" class="widget_text vce-no-padding widget widget_custom_html"><div class="textwidget custom-html-widget">
<script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "600";
   medianet_crid = "526552473";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div><div id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<script id='x33x15351354282617836'>
var Tynt=Tynt||[];Tynt.push('abWrx44JCr4z2Wacwqm_6r');
Tynt.cmd=Tynt.cmd||[];Tynt.cmd.push(function(){
Tynt.ads.display('300x250','x33x15351354282617836','inpage');});
(function(){var h,s=document.createElement('script');
s.src=(window.location.protocol==='https:'?
'https':'http')+'://cdn.tynt.com/siab.js';
h=document.getElementsByTagName('script')[0];
h.parentNode.insertBefore(s,h);})();
</script>
</div></div> </aside>
</div>
<footer id="footer" class="site-footer">
<div class="container">
<div class="container-fix">
<div class="bit-3">
<div id="mks_social_widget-2" class="widget mks_social_widget"><h4 class="widget-title">Socially Speaking</h4>
<ul class="mks_social_widget_ul">
<li><a href="https://www.facebook.com/onelovejamaica" title="Facebook" class="socicon-facebook soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>facebook</span></a></li>
<li><a href="https://instagram.com/jamaicans_com" title="Instagram" class="socicon-instagram soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>instagram</span></a></li>
<li><a href="https://twitter.com/jamaicansdotcom" title="Twitter" class="socicon-twitter soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>twitter</span></a></li>
<li><a href="https://www.youtube.com/user/outofmanyonline" title="YouTube" class="socicon-youtube soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>youtube</span></a></li>
<li><a href="https://jamaicans.com/?feed=rss" title="RSS" class="socicon-rss soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>rss</span></a></li>
<li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="socicon-pinterest soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>pinterest</span></a></li>
<li><a href="http://jamaicansdotcom.tumblr.com/" title="tumblr" class="socicon-tumblr soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>tumblr</span></a></li>
<li><a href="https://jm.linkedin.com/company/jamaicans-com" title="Linkedin" class="socicon-linkedin soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>linkedin</span></a></li>
</ul>
</div><div id="mailerlite_widget-3" class="widget widget_mailerlite_widget">
<div id="mailerlite-form_1" data-temp-id="61168aecd4018">
<div class="mailerlite-form">
<form action="" method="post">
<div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div>
<div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p>
</div>
<div class="mailerlite-form-inputs">
<div class="mailerlite-form-field">
<label for="mailerlite-1-field-email">Email</label>
<input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" />
</div>
<div class="mailerlite-form-loader">Please wait...</div>
<div class="mailerlite-subscribe-button-container">
<input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" />
</div>
<input type="hidden" name="form_id" value="1" />
<input type="hidden" name="action" value="mailerlite_subscribe_form" />
<input type="hidden" name="ml_nonce" value="03a73b700a" />
</div>
<div class="mailerlite-form-response">
<h4><p><span style="color: #339966;">Thank you for sign up!</span></p>
</h4>
</div>
</form>
</div>
</div>
<script type="text/javascript">
    window.addEventListener("load", function (event) {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=61168aecd4018] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                submitHandler: function (form) {

                    jQuery(this.submitButton).prop('disabled', true);

                    form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                        form_container.find('.mailerlite-form-loader').fadeIn()
                    });

                    var data = jQuery(form).serialize();

                    jQuery.post('https://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                        form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                            form_container.find('.mailerlite-form-response').fadeIn()
                        });
                    });
                }
            });
        });
    }, false);
</script>
</div> </div>
<div class="bit-3">
<div id="vce_posts_widget-2" class="widget vce_posts_widget"><h4 class="widget-title">Random Jamaican Recipes</h4>
<ul class="vce-post-list" data-autoplay="">
<li>
<a href="https://jamaicans.com/chefnels-caribbean-rum-wing-sauce/" class="featured_image_sidebar" title="ChefNel&#8217;s Caribbean Rum Wing Sauce"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="ChefNel&#039;s Caribbean Rum Sauce" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-145x100.png 145w, https://jamaicans.com/wp-content/uploads/ChefNels-Caribbean-Rum-Sauce-380x260.png 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/chefnels-caribbean-rum-wing-sauce/" title="ChefNel&#8217;s Caribbean Rum Wing Sauce" class="vce-post-link">ChefNel&#8217;s Caribbean Rum Wing Sauce</a>
</div>
</li>
<li>
<a href="https://jamaicans.com/exploring-jamaican-food-star-apple/" class="featured_image_sidebar" title="Exploring Jamaican Food: Star Apple"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Exploring-Jamaican-Food-Star-Apple-145x100.jpeg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Exploring Jamaican Food - Star Apple" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Exploring-Jamaican-Food-Star-Apple-145x100.jpeg 145w, https://jamaicans.com/wp-content/uploads/Exploring-Jamaican-Food-Star-Apple-380x260.jpeg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/exploring-jamaican-food-star-apple/" title="Exploring Jamaican Food: Star Apple" class="vce-post-link">Exploring Jamaican Food: Star Apple</a>
</div>
</li>
<li>
<a href="https://jamaicans.com/tips-on-cooking-with-scotch-bonnet-pepper/" class="featured_image_sidebar" title="Tips on Cooking with Scotch Bonnet Pepper"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Tips-on-Cooking-with-Scotch-Bonnet-Pepper-Photo-by-Xavier-Murphy-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Tips on Cooking with Scotch Bonnet Pepper - Photo by Xavier Murphy" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Tips-on-Cooking-with-Scotch-Bonnet-Pepper-Photo-by-Xavier-Murphy-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Tips-on-Cooking-with-Scotch-Bonnet-Pepper-Photo-by-Xavier-Murphy-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/tips-on-cooking-with-scotch-bonnet-pepper/" title="Tips on Cooking with Scotch Bonnet Pepper" class="vce-post-link">Tips on Cooking with Scotch Bonnet Pepper</a>
</div>
</li>
<li>
<a href="https://jamaicans.com/5-quick-one-pot-meals-from-jamaica/" class="featured_image_sidebar" title="5 Quick One Pot Meals From Jamaica"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/09/5-Quick-One-Pot-Meals-From-Jamaica-2-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2016/09/5-Quick-One-Pot-Meals-From-Jamaica-2-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/09/5-Quick-One-Pot-Meals-From-Jamaica-2-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/5-quick-one-pot-meals-from-jamaica/" title="5 Quick One Pot Meals From Jamaica" class="vce-post-link">5 Quick One Pot Meals From Jamaica</a>
<div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/5-quick-one-pot-meals-from-jamaica/#respond"><span class="dsq-postid" data-dsqidentifier="100247 http://jamaicans.com/?p=100247">Add Comment</span></a></div></div>
</div>
</li>
<li>
<a href="https://jamaicans.com/chef-noel-eggnog-french-toast/" class="featured_image_sidebar" title="Chef Noel Eggnog French Toast"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Chef-Noel-Eggnog-French-Toast-2-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Chef Noel Eggnog French Toast" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Chef-Noel-Eggnog-French-Toast-2-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Chef-Noel-Eggnog-French-Toast-2-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/chef-noel-eggnog-french-toast/" title="Chef Noel Eggnog French Toast" class="vce-post-link">Chef Noel Eggnog French Toast</a>
</div>
</li>
</ul>
</div> </div>
<div class="bit-3">
</div>
</div>
</div>
<div class="container-full site-info">
<div class="container">
<div class="vce-wrap-left">
<p>Copyright © Simbis Inc. All rights reserved. <a href="https://jamaicans.com/privacy/">Privacy Policy &amp; Terms of use</a>. Stock Photos from Photos.com, iStockPhotos.com, 123rf.</p> </div>
<div class="vce-wrap-right">
<ul id="vce_footer_menu" class="bottom-nav-menu"><li id="menu-item-76837" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76837"><a href="http://www.jamaicans.com/forums/">Forums</a></li>
<li id="menu-item-145195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145195"><a href="https://jamaicans.com/free-email/">Free Email</a></li>
<li id="menu-item-76836" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76836"><a target="_blank" rel="noopener" href="https://amzn.to/2JueBog">Shopping</a></li>
<li id="menu-item-459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-459"><a href="https://jamaicans.com/our-contact/">Contact</a></li>
<li id="menu-item-526" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-526"><a href="https://jamaicans.com/about-us/">About Us</a></li>
<li id="menu-item-77011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77011"><a href="https://jamaicans.com/advertise-with-us/">Advertise</a></li>
</ul>
</div>
</div>
</div>
</footer>
</div>
</div>
<a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://jamaicans.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "dc47c411ce", post_id : 151237 } ); } ); /* ]]> */</script>
<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":"300"}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":6,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"services":"facebook,twitter,email,pinterest_share,whatsapp,addthis","elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":6,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"services":"facebook,twitter,email,pinterest_share,whatsapp,addthis","elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-bf34677b4718a8fdb8e7d271cfbb868e","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=wp-bf34677b4718a8fdb8e7d271cfbb868e" async="async"></script><script type='text/javascript' id='google_cse_v2-js-extra'>
/* <![CDATA[ */
var scriptParams = {"google_search_engine_id":"partner-pub-1901173274277249:8952111638"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/wp-google-search/assets/js/google_cse_v2.js?ver=1' id='google_cse_v2-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/meks-flexible-shortcodes/js/main.js?ver=1' id='mks_shortcodes_js-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' id='vce-main-js-extra'>
/* <![CDATA[ */
var vce_js_settings = {"sticky_header":"1","sticky_header_offset":"200","sticky_header_logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/08\/final-logo-abbr.png","logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/01\/jamaicans_logo.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"https:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","ajax_wpml_current_lang":null,"ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"1","full_slider_autoplay":"","grid_slider_autoplay":"","grid_big_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"0","top_bar_mobile_group":"1","top_bar_more_link":"More"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/themes/voice/assets/js/min.js?ver=2.9.9' id='vce-main-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/meks-easy-social-share/assets/js/main.js?ver=1.2.6' id='meks_ess-main-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/js/jquery.validate.min.js?ver=3500f9c9638f8da19fe3de33a1de82fa' id='jquery-validation-plugin-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/wp-review/public/js/js.cookie.min.js?ver=2.1.4' id='js-cookie-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' id='wp-util-js-extra'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/wp-util.min.js?ver=3500f9c9638f8da19fe3de33a1de82fa' id='wp-util-js'></script>
<script type='text/javascript' id='wp_review-js-js-extra'>
/* <![CDATA[ */
var wpreview = {"ajaxurl":"https:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","loginRequiredMessage":"You must log in to add your review"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/wp-review/public/js/main.js?ver=5.3.5' id='wp_review-js-js'></script>
<script type='text/javascript' id='fca_pc_client_js-js-extra'>
/* <![CDATA[ */
var fcaPcEvents = [];
var fcaPcDebug = {"debug":""};
var fcaPcPost = {"title":"WEEKLY DEVOTIONAL - Let God be God","type":"post","id":"151237","categories":["Weekly Devotional"],"utm_support":"","user_parameters":"","edd_delay":"0","woo_delay":"0","edd_enabled":"","woo_enabled":"","video_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/facebook-conversion-pixel/pixel-cat.min.js?ver=2.5.7' id='fca_pc_client_js-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/facebook-conversion-pixel/video.compiled.js?ver=3500f9c9638f8da19fe3de33a1de82fa' id='fca_pc_video_js-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/wp-embed.min.js?ver=3500f9c9638f8da19fe3de33a1de82fa' id='wp-embed-js'></script>
</body>
</html>
