<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" class="no-js no-svg">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1, minimum-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<script>
			!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
			n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
			document,'script','https://connect.facebook.net/en_US/fbevents.js');
			fbq('init', '1055480241142713' );			fbq('track', 'PageView');

			</script>
<noscript><img height="1" width="1" style="display:none"
			src="https://www.facebook.com/tr?id=1055480241142713&ev=PageView&noscript=1"
			/></noscript>



<title>WEEKLY DEVOTIONAL - Our Ultimate Source - Jamaicans.com</title>
<meta name="description" content="Our minds cannot begin to comprehend what God is capable of doing, especially for those who are His.  Because He is our ultimate source, no one can stop Him when He decides to pour out His favor on any of His children." />
<link rel="canonical" href="https://jamaicans.com/weekly-devotional-our-ultimate-source/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="WEEKLY DEVOTIONAL - Our Ultimate Source - Jamaicans.com" />
<meta property="og:description" content="Our minds cannot begin to comprehend what God is capable of doing, especially for those who are His.  Because He is our ultimate source, no one can stop Him when He decides to pour out His favor on any of His children." />
<meta property="og:url" content="http://jamaicans.com/weekly-devotional-our-ultimate-source/" />
<meta property="og:site_name" content="Jamaicans.com" />
<meta property="article:published_time" content="2021-10-08T10:15:56+00:00" />
<meta property="article:modified_time" content="2021-10-08T10:33:03+00:00" />
<meta property="og:image" content="https://jamaicans.com/wp-content/uploads/ourultimatesource.jpg" />
<meta property="og:image:width" content="505" />
<meta property="og:image:height" content="327" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Colin Wilson" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="5 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://jamaicans.com/#website","url":"https://jamaicans.com/","name":"Jamaicans.com","description":"Out of Many, One People Online","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://jamaicans.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://jamaicans.com/weekly-devotional-our-ultimate-source/#primaryimage","inLanguage":"en-US","url":"https://jamaicans.com/wp-content/uploads/ourultimatesource.jpg","contentUrl":"https://jamaicans.com/wp-content/uploads/ourultimatesource.jpg","width":505,"height":327,"caption":"Our Ultimate Source"},{"@type":"WebPage","@id":"https://jamaicans.com/weekly-devotional-our-ultimate-source/#webpage","url":"https://jamaicans.com/weekly-devotional-our-ultimate-source/","name":"WEEKLY DEVOTIONAL - Our Ultimate Source - Jamaicans.com","isPartOf":{"@id":"https://jamaicans.com/#website"},"primaryImageOfPage":{"@id":"https://jamaicans.com/weekly-devotional-our-ultimate-source/#primaryimage"},"datePublished":"2021-10-08T10:15:56+00:00","dateModified":"2021-10-08T10:33:03+00:00","author":{"@id":"https://jamaicans.com/#/schema/person/e5b7219b64aa66241ef044712562cf22"},"description":"Our minds cannot begin to comprehend what God is capable of doing, especially for those who are His. \u00a0Because He is our ultimate source, no one can stop Him when He decides to pour out His favor on any of His children.","breadcrumb":{"@id":"https://jamaicans.com/weekly-devotional-our-ultimate-source/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://jamaicans.com/weekly-devotional-our-ultimate-source/"]}]},{"@type":"BreadcrumbList","@id":"https://jamaicans.com/weekly-devotional-our-ultimate-source/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://jamaicans.com/"},{"@type":"ListItem","position":2,"name":"WEEKLY DEVOTIONAL &#8211; Our Ultimate Source"}]},{"@type":"Person","@id":"https://jamaicans.com/#/schema/person/e5b7219b64aa66241ef044712562cf22","name":"Colin Wilson","image":{"@type":"ImageObject","@id":"https://jamaicans.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/23f05fd9d6f1216560d30b8800b4c038?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/23f05fd9d6f1216560d30b8800b4c038?s=96&d=mm&r=g","caption":"Colin Wilson"},"description":"Easy going, dislike negativity, and an optimist. I believe that amidst the hustle and bustle of everyday living, each day is a gift from God and if we stop and think about it, there is at least one thing for which we ought to be thankful. In addition, I believe that every day is a great day to be alive. No matter how bad we think we have it, there are any number of people who are on the \"other side\" who, if they could, would gladly trade places with us. Email me at churchdude@outlook.com","url":"https://jamaicans.com/author/colinwilson/"}]}</script>

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Feed" href="https://jamaicans.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Jamaicans.com &raquo; Comments Feed" href="https://jamaicans.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jamaicans.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=3d7ea3ee90d29ec8a70d43d3557ce3db"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wgs2-css' href='https://jamaicans.com/wp-content/plugins/wp-google-search/wgs2.css?ver=3d7ea3ee90d29ec8a70d43d3557ce3db' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://jamaicans.com/wp-includes/css/dist/block-library/style.min.css?ver=3d7ea3ee90d29ec8a70d43d3557ce3db' type='text/css' media='all' />
<link rel='stylesheet' id='mks_shortcodes_simple_line_icons-css' href='https://jamaicans.com/wp-content/plugins/meks-flexible-shortcodes/css/simple-line/simple-line-icons.css?ver=1.3.3' type='text/css' media='screen' />
<link rel='stylesheet' id='mks_shortcodes_css-css' href='https://jamaicans.com/wp-content/plugins/meks-flexible-shortcodes/css/style.css?ver=1.3.3' type='text/css' media='screen' />
<link rel='stylesheet' id='mailerlite_forms.css-css' href='https://jamaicans.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/css/mailerlite_forms.css?ver=1.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='wpProQuiz_front_style-css' href='https://jamaicans.com/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all' />
<link rel='stylesheet' id='vce-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%7CRoboto+Slab%3A400%7COswald%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='vce-style-css' href='https://jamaicans.com/wp-content/themes/voice/assets/css/min.css?ver=2.9.9' type='text/css' media='all' />
<style id='vce-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='meks-ads-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-easy-ads-widget/css/style.css?ver=2.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='meks_instagram-widget-styles-css' href='https://jamaicans.com/wp-content/plugins/meks-easy-instagram-widget/css/widget.css?ver=3d7ea3ee90d29ec8a70d43d3557ce3db' type='text/css' media='all' />
<link rel='stylesheet' id='meks-flickr-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-simple-flickr-widget/css/style.css?ver=1.2' type='text/css' media='all' />
<link rel='stylesheet' id='meks-author-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-smart-author-widget/css/style.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='meks-social-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-smart-social-widget/css/style.css?ver=1.5' type='text/css' media='all' />
<link rel='stylesheet' id='meks-themeforest-widget-css' href='https://jamaicans.com/wp-content/plugins/meks-themeforest-smart-widget/css/style.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='meks_ess-main-css' href='https://jamaicans.com/wp-content/plugins/meks-easy-social-share/assets/css/main.css?ver=1.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp_review-style-css' href='https://jamaicans.com/wp-content/plugins/wp-review/public/css/wp-review.css?ver=5.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css' href='https://jamaicans.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=3d7ea3ee90d29ec8a70d43d3557ce3db' type='text/css' media='all' />
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>

<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-2520621-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["jamaicans.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-2520621-1", {"anonymize_ip":true});
</script>

<link rel="https://api.w.org/" href="https://jamaicans.com/wp-json/" /><link rel="alternate" type="application/json" href="https://jamaicans.com/wp-json/wp/v2/posts/153029" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jamaicans.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jamaicans.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://jamaicans.com/?p=153029' />
<link rel="alternate" type="application/json+oembed" href="https://jamaicans.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-our-ultimate-source%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://jamaicans.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-our-ultimate-source%2F&#038;format=xml" />
<meta name="framework" content="Redux 4.3.1" /><meta name="generator" content="Site Kit by Google 1.42.0" />
<script>
(function(m,a,i,l,e,r){ m['MailerLiteObject']=e;function f(){
var c={ a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?v'+(~~(new Date().getTime()/1000000));
_.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');
</script>
 
<script>
        (function (m, a, i, l, e, r) {
            m['MailerLiteObject'] = e;

            function f() {
                var c = {a: arguments, q: []};
                var r = this.push(c);
                return "number" != typeof r ? r : f.bind(c.q);
            }

            f.q = f.q || [];
            m[e] = m[e] || f.bind(f.q);
            m[e].q = m[e].q || f.q;
            r = a.createElement(i);
            var _ = a.getElementsByTagName(i)[0];
            r.async = 1;
            r.src = l + '?' + (~~(new Date().getTime() / 10000000));
            _.parentNode.insertBefore(r, _);
        })(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

        var ml_account = ml('accounts', '957504', 'f8j0w4c9v9', 'load');
    </script>

<script type="text/javascript">
                var rsssl_share_url = window.location.href.replace('https://', 'http://');
                var addthis_share = {url: '' + rsssl_share_url + ''};
            </script>

<script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-1901173274277249" crossorigin="anonymous" type="text/javascript"></script>
<script type="text/javascript">
(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-1901173274277249","enable_page_level_ads":true,"tag_partner":"site_kit"});
</script>

<style type="text/css" id="wp-custom-css">
			.main-box-head {display:none;}
.header-sticky .main-navigation a {
    font-size: 1.9rem;
}		</style>
</head>
<body data-rssslsocial=1 class="post-template-default single single-post postid-153029 single-format-standard wp-embed-responsive vce-sid-right voice-v_2_9_9">
<div id="vce-main">
<header id="header" class="main-header">
<div class="container header-2-wrapper header-main-area">
<div class="vce-res-nav">
<a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a>
</div>
<div class="site-branding">
<span class="site-title"><a href="https://jamaicans.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><source srcset="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png"><img src="https://jamaicans.com/wp-content/uploads/2015/01/jamaicans_logo.png" alt="Jamaicans.com"></picture></a></span></div>
<div class="vce-header-ads">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="9929021134"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</div>
<div class="header-bottom-wrapper header-left-nav">
<div class="container">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-146369" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146369 vce-cat-284"><a href="https://jamaicans.com/jamaica/bestofja/">Best Of Jamaica</a><li id="menu-item-83497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-83497"><a href="https://jamaicans.com/recipes/">Recipes</a>
<ul class="sub-menu">
<li id="menu-item-150405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150405 vce-cat-422"><a href="https://jamaicans.com/jamaica/recipes/recipes-meat/">Meat Recipes</a> <li id="menu-item-150406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150406 vce-cat-406"><a href="https://jamaicans.com/jamaica/recipes/recipes-jamaican-food-photos/">Photo Gallery of Jamaican Foods</a> <li id="menu-item-150407" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150407 vce-cat-322"><a href="https://jamaicans.com/jamaica/recipes/recipes-pork/">Pork Recipes</a> <li id="menu-item-150408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150408 vce-cat-402"><a href="https://jamaicans.com/jamaica/recipes/recipes-sauces/">Sauce Recipes</a> <li id="menu-item-150409" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150409 vce-cat-396"><a href="https://jamaicans.com/jamaica/recipes/recipes-fish/">Seafood Recipes</a> <li id="menu-item-150410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150410 vce-cat-338"><a href="https://jamaicans.com/jamaica/recipes/recipes-seasonal/">Seasonal Recipes</a> <li id="menu-item-150411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150411 vce-cat-317"><a href="https://jamaicans.com/jamaica/recipes/recipes-soup/">Soup Recipes</a> <li id="menu-item-150414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150414 vce-cat-377"><a href="https://jamaicans.com/jamaica/recipes/recipes-traditional/">Traditional Recipes</a> <li id="menu-item-150415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150415 vce-cat-358"><a href="https://jamaicans.com/jamaica/recipes/recipes-vegetarian/">Vegetarian Recipes</a></ul>
<li id="menu-item-77663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77663"><a href="https://jamaicans.com/speak-jamaican/">Speak JA</a><li id="menu-item-79826" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-79826 vce-cat-276"><a href="https://jamaicans.com/jamaica/jamaica-magazine/">Features</a>
<ul class="sub-menu">
<li id="menu-item-150388" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150388 vce-cat-341"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-articles/">Main Feature</a> <li id="menu-item-150389" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150389 vce-cat-339"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-interviews/">Interviews</a> <li id="menu-item-150387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150387 vce-cat-348"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-advice/">Advice &amp; Help</a> <li id="menu-item-150390" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150390 vce-cat-325"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-comments/">Commentary</a> <li id="menu-item-150396" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150396 vce-cat-312"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-blogs/">Blogs</a></ul>
<li id="menu-item-79827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79827 vce-cat-40"><a href="https://jamaicans.com/jamaica/culture-jamaica/">Culture</a><li id="menu-item-79829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79829 vce-cat-265"><a href="https://jamaicans.com/jamaica/jamaican-music/">Music</a><li id="menu-item-61427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61427"><a href="https://jamaicans.com/travel-jamaica/">Travel</a><li id="menu-item-118281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118281"><a href="https://jamaicans.com/videos/%20">Videos</a><li id="menu-item-118279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118279"><a href="https://jamaicans.com/photogallery/">Photos</a><li id="menu-item-79856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-79856 vce-cat-267"><a href="https://jamaicans.com/jamaica/news-announcements/">News &#038; Media</a>
<ul class="sub-menu">
<li id="menu-item-150416" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-150416 vce-cat-856"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/">Weekly Devotional</a> <li id="menu-item-150418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150418 vce-cat-382"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/">Announcements</a> <li id="menu-item-150417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-150417"><a href="https://irietimes.jamaicans.com/">Irie Times Radio</a> <li id="menu-item-150419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150419 vce-cat-432"><a href="https://jamaicans.com/jamaica/news-announcements/events/">Events</a></ul>
<li id="menu-item-61425" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61425"><a href="https://jamaicans.com/jamaican-information/">Research JA</a></ul></nav> </div>
</div></header>
<div id="sticky_header" class="header-sticky">
<div class="container">
<div class="vce-res-nav">
<a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a>
</div>
<div class="site-branding">
<span class="site-title"><a href="https://jamaicans.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" srcset="https://jamaicans.com/wp-content/uploads/2015/08/final-logo-abbr.png"><source srcset="https://jamaicans.com/wp-content/uploads/2015/08/final-logo-abbr.png"><img src="https://jamaicans.com/wp-content/uploads/2015/08/final-logo-abbr.png" alt="Jamaicans.com"></picture></a></span></div> <nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="vce_main_navigation_menu" class="nav-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146369 vce-cat-284"><a href="https://jamaicans.com/jamaica/bestofja/">Best Of Jamaica</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-83497"><a href="https://jamaicans.com/recipes/">Recipes</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150405 vce-cat-422"><a href="https://jamaicans.com/jamaica/recipes/recipes-meat/">Meat Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150406 vce-cat-406"><a href="https://jamaicans.com/jamaica/recipes/recipes-jamaican-food-photos/">Photo Gallery of Jamaican Foods</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150407 vce-cat-322"><a href="https://jamaicans.com/jamaica/recipes/recipes-pork/">Pork Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150408 vce-cat-402"><a href="https://jamaicans.com/jamaica/recipes/recipes-sauces/">Sauce Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150409 vce-cat-396"><a href="https://jamaicans.com/jamaica/recipes/recipes-fish/">Seafood Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150410 vce-cat-338"><a href="https://jamaicans.com/jamaica/recipes/recipes-seasonal/">Seasonal Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150411 vce-cat-317"><a href="https://jamaicans.com/jamaica/recipes/recipes-soup/">Soup Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150414 vce-cat-377"><a href="https://jamaicans.com/jamaica/recipes/recipes-traditional/">Traditional Recipes</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150415 vce-cat-358"><a href="https://jamaicans.com/jamaica/recipes/recipes-vegetarian/">Vegetarian Recipes</a></ul>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77663"><a href="https://jamaicans.com/speak-jamaican/">Speak JA</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-79826 vce-cat-276"><a href="https://jamaicans.com/jamaica/jamaica-magazine/">Features</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150388 vce-cat-341"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-articles/">Main Feature</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150389 vce-cat-339"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-interviews/">Interviews</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150387 vce-cat-348"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-advice/">Advice &amp; Help</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150390 vce-cat-325"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-comments/">Commentary</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150396 vce-cat-312"><a href="https://jamaicans.com/jamaica/jamaica-magazine/jamaica-magazine-blogs/">Blogs</a></ul>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79827 vce-cat-40"><a href="https://jamaicans.com/jamaica/culture-jamaica/">Culture</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79829 vce-cat-265"><a href="https://jamaicans.com/jamaica/jamaican-music/">Music</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61427"><a href="https://jamaicans.com/travel-jamaica/">Travel</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118281"><a href="https://jamaicans.com/videos/%20">Videos</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118279"><a href="https://jamaicans.com/photogallery/">Photos</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-79856 vce-cat-267"><a href="https://jamaicans.com/jamaica/news-announcements/">News &#038; Media</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-150416 vce-cat-856"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/">Weekly Devotional</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150418 vce-cat-382"><a href="https://jamaicans.com/jamaica/news-announcements/announcements/">Announcements</a> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-150417"><a href="https://irietimes.jamaicans.com/">Irie Times Radio</a> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150419 vce-cat-432"><a href="https://jamaicans.com/jamaica/news-announcements/events/">Events</a></ul>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61425"><a href="https://jamaicans.com/jamaican-information/">Research JA</a></ul></nav> </div>
</div>
<div id="main-wrapper">
<div class="vce-ad-below-header vce-ad-container">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2520621-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2520621-1');
</script>
</div>
<div id="content" class="container site-content vce-sid-right">
<div id="primary" class="vce-main-content">
<main id="main" class="main-box main-box-single">
<article id="post-153029" class="vce-single post-153029 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional tag-divine-providence tag-god-as-provider tag-god-is-my-source tag-our-ultimate-source tag-the-lord-is-my-shepherd">
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h1 class="entry-title">WEEKLY DEVOTIONAL &#8211; Our Ultimate Source</h1>
<div class="entry-meta"><div class="meta-item date"><span class="updated">17 mins ago</span></div><div class="meta-item author"><span class="vcard author"><span class="fn">by <a href="https://jamaicans.com/author/colinwilson/">Colin Wilson</a></span></span></div></div>
</header>
<div class="meta-image">
<img width="505" height="327" src="https://jamaicans.com/wp-content/uploads/ourultimatesource.jpg" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/ourultimatesource.jpg 505w, https://jamaicans.com/wp-content/uploads/ourultimatesource-300x194.jpg 300w" sizes="(max-width: 505px) 100vw, 505px" />
</div>
<div class="entry-content">
<div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="1532314968" data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="at-above-post addthis_tool" data-url="http://jamaicans.com/weekly-devotional-our-ultimate-source/"></div><p>God is my source; everything else is a resource.  That is my conviction and how liberating it is!  Like most of us, I was socialized to think and believe that people and things were the sources from which we get the things we need, leaving us somewhat dependent on these sources.  To some extent, this is true.  For example, our jobs provide the income we need to provide for ourselves and our families.  However, if we are not careful, we start seeing <em>the job</em> as the source and conclude that our managers control and determine our outcomes.  This can be a source of anxiety because if we believe we are not in their favor, we become overly concerned about what they might do to us, or how their actions might impact us.  Are we at the top of the list of those to be laid off?  Will we get that promotion?  That salary increase?  If we lose our jobs, what would happen to us?  How would we survive? Those are legitimate questions.  Yet the anxiety would be lessened if we recognize that the source of our finances and everything else we need is God, and He channels those things to us through resources including our jobs.  French mystic Francois de la Mothe Fenelon puts it this way, &#8220;We sleep in peace in the arms of God, when we yield ourselves up to His providence.&#8221;</p>
<p>The online Merriam-Webster dictionary defines a <a href="https://www.merriam-webster.com/dictionary/source" target="_blank" rel="noopener" data-cke-saved-href="https://www.merriam-webster.com/dictionary/source">source</a> as &#8220;a point of origin or procurement [to get possession of (something)],&#8221; and a <a href="https://www.merriam-webster.com/dictionary/resource" target="_blank" rel="noopener" data-cke-saved-href="https://www.merriam-webster.com/dictionary/resource">resource</a> as &#8220;a source of supply or support.&#8221;  From the Christian perspective, the Scriptures clearly teach that God is our ultimate source, the origin from whom everything flows.  To the church in Corinth, Paul affirms, &#8220;. . . for us there is [only] one God, the Father, Who is the Source of all things&#8221; (<a href="https://www.biblegateway.com/passage/?search=+1+Corinthians+8%3A6&amp;version=AMPC" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=+1+Corinthians+8%3A6&amp;version=AMPC">1 Corinthians 8:6, AMPC</a>), and to the one in Philippi, &#8220;And my God will liberally supply (fill to the full) your every need according to His riches in glory in Christ Jesus” (<a href="https://www.biblegateway.com/passage/?search=Philippians+4%3A19&amp;version=AMPC" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Philippians+4%3A19&amp;version=AMPC">Philippians 4:19</a>).  From the pen of James, “Every good gift and every perfect gift is from above, and cometh down from the Father of lights, with whom is no variableness, neither shadow of turning” (<a href="https://www.biblegateway.com/passage/?search=James+1%3A17&amp;version=KJV" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=James+1%3A17&amp;version=KJV">James 1:17, KJV</a>).  From the psalmist, &#8220;O taste and see that the Lord is good: blessed is the man that trusteth in him. O fear the Lord, ye his saints: for there is no want to them that fear him. The young lions do lack, and suffer hunger: but they that seek the Lord shall not want any good thing” (<a href="https://www.biblegateway.com/passage/?search=Psalm+34%3A8-10&amp;version=KJV" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Psalm+34%3A8-10&amp;version=KJV">Psalm 34:8-10</a>).  From the chronicler, &#8220;Everything we have has come from you [God], and we give you only what you first gave us!” (<a href="https://www.biblegateway.com/passage/?search=1+Chronicles+29%3A14&amp;version=NIV" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=1+Chronicles+29%3A14&amp;version=NIV">1 Chronicles 29:14</a>).  And there are many others.  Our trust for the things we need should start and end in God.</p>
<p>It is no wonder then that David started one of the most well-known psalms with the words, &#8220;The Lord is my Shepherd [to feed, to guide and to shield me], I shall not want&#8221; (<a href="https://www.biblegateway.com/passage/?search=Psalm+23%3A1&amp;version=AMP" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Psalm+23%3A1&amp;version=AMP">Psalm 23:1, AMP</a>).  The Living Bible translation puts <a href="https://www.biblegateway.com/passage/?search=Psalm+23%3A1&amp;version=TLB" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Psalm+23%3A1&amp;version=TLB">it</a> this way, &#8220;Because the Lord is my Shepherd, I have everything I need!&#8221; Regarding those who allow the Lord to be shepherd over their lives, Bible scholar Adam Clark writes, &#8220;He who is their Shepherd has all power in heaven and earth; therefore He can protect them. The silver and gold are His, and the cattle on a thousand hills; and therefore He can sustain them. He has all that they need, and His heart is full of love to mankind; and therefore He will withhold from them no manner of thing that is good.&#8221; The supplies of our God are inexhaustible to the extent that He is &#8220;able to [carry out His purpose and] do superabundantly more than all that we dare ask or think [infinitely beyond our greatest prayers, hopes, or dreams], according to His power that is at work within us&#8221; (<a href="https://www.biblegateway.com/passage/?search=Ephesians+3%3A20&amp;version=AMP" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Ephesians+3%3A20&amp;version=AMP">Ephesians 3:20, AMP</a>).  Our minds cannot begin to comprehend what God is capable of doing, especially for those who are His.  Because He is our ultimate source, no one can stop Him when He decides to pour out His favor on any of His children.</p>
<div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-1901173274277249" data-ad-slot="1751381785"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>So, what about people and things?  Again, these are the resources God uses to get things to you and me.  People do not hold your future in their hands; God does.  No matter how much they may not be for us, they cannot stop the ultimate plan of God for our lives.  In the proverbs, we read, &#8220;The king’s heart is like channels of water in the hand of the Lord; He turns it whichever way He wishes&#8221; (<a href="https://www.biblegateway.com/passage/?search=Proverbs+21%3A1&amp;version=AMP" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Proverbs+21%3A1&amp;version=AMP">Proverbs 21:1</a>).  As it is with the heart of the king, so it is with the hearts of the bank managers, our supervisors, and all the people we encounter that have some influence over our lives.  They are not in ultimate control; God is.  The psalmist reminds us, &#8220;The Lord bestows grace and favor and honor; no good thing will He withhold from those who walk uprightly&#8221; (<a href="https://www.biblegateway.com/passage/?search=%28Psalm+84%3A11&amp;version=AMP" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=%28Psalm+84%3A11&amp;version=AMP">Psalm 84:11</a>).   When one door closes, He simply opens another.   Because of God&#8217;s favor and honor, even when we are in an environment with people who do not like us, He &#8220;will command the blessing on you . . . and in all that you [do]&#8221; (<a href="https://www.biblegateway.com/passage/?search=Deuteronomy+28%3A8&amp;version=AMP" target="_blank" rel="noopener" data-cke-saved-href="https://www.biblegateway.com/passage/?search=Deuteronomy+28%3A8&amp;version=AMP">Deuteronomy 28:8</a>).  Just because, as the saying goes, &#8220;favor ain&#8217;t fair!&#8221; Who or what is your source?</p>
<div class="at-below-post addthis_tool" data-url="http://jamaicans.com/weekly-devotional-our-ultimate-source/"></div><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>

<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1901173274277249" data-ad-slot="8801353632" data-ad-format="link" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

</div>
<footer class="entry-footer">
<div class="meta-tags">
<a href="https://jamaicans.com/tag/divine-providence/" rel="tag">divine providence</a> <a href="https://jamaicans.com/tag/god-as-provider/" rel="tag">God as provider</a> <a href="https://jamaicans.com/tag/god-is-my-source/" rel="tag">God is my source</a> <a href="https://jamaicans.com/tag/our-ultimate-source/" rel="tag">our ultimate source</a> <a href="https://jamaicans.com/tag/the-lord-is-my-shepherd/" rel="tag">the Lord is my shepherd</a> </div>
</footer>
<div class="vce-share-bar">
<ul class="vce-share-items">
<div class="meks_ess rounded no-labels solid "><a href="#" onclick="return false;" class="meks_ess-item socicon-facebook" data-url="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fjamaicans.com%2Fweekly-devotional-our-ultimate-source%2F&amp;t=WEEKLY%20DEVOTIONAL%20%E2%80%93%20Our%20Ultimate%20Source"><span>Facebook</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-twitter" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-our-ultimate-source%2F&amp;text=WEEKLY%20DEVOTIONAL%20%E2%80%93%20Our%20Ultimate%20Source"><span>Twitter</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-reddit" data-url="http://www.reddit.com/submit?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-our-ultimate-source%2F&amp;title=WEEKLY%20DEVOTIONAL%20%E2%80%93%20Our%20Ultimate%20Source"><span>Reddit</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-pinterest" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-our-ultimate-source%2F&amp;media=https%3A%2F%2Fjamaicans.com%2Fwp-content%2Fuploads%2Fourultimatesource.jpg&amp;description=WEEKLY%20DEVOTIONAL%20%E2%80%93%20Our%20Ultimate%20Source"><span>Pinterest</span></a><a href="/cdn-cgi/l/email-protection#350a4640575f505641086270707e796c1007057170637a617c7a7b7479100705107007100d05100c061007057a40471007056059415c58544150100705665a40475650135458450e575a514c085d414145461006741007731007735f5458545c56545b461b565a581007734250505e594c185150435a415c5a5b5459185a4047184059415c5854415018465a40475650100773" class="meks_ess-item  socicon-mail prevent-share-popup "><span>Email</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-linkedin" data-url="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-our-ultimate-source%2F"><span>LinkedIn</span></a><a href="https://api.whatsapp.com/send?text=WEEKLY%20DEVOTIONAL%20%E2%80%93%20Our%20Ultimate%20Source https%3A%2F%2Fjamaicans.com%2Fweekly-devotional-our-ultimate-source%2F" class="meks_ess-item socicon-whatsapp prevent-share-popup"><span>WhatsApp</span></a></div> </ul>
</div>
</article>
<nav class="prev-next-nav">
<div class="vce-next-link">
<a href="https://jamaicans.com/weekly-devotional-gods-passion-for-the-lost/" rel="prev"><span class="img-wrp"><img width="375" height="195" src="https://jamaicans.com/wp-content/uploads/passionforthelost-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="" loading="lazy" /><span class="vce-pn-ico"><i class="fa fa fa-chevron-right"></i></span></span><span class="vce-prev-next-link">WEEKLY DEVOTIONAL &#8211; God&#8217;s Passion for the Lost</span></a> </div>
</nav>
</main>
<section class="main-box mbt-border-top author-box">
<h3 class="main-box-title">About the author</h3>
<div class="main-box-inside">
<div class="data-image">
<img alt='' src='https://secure.gravatar.com/avatar/23f05fd9d6f1216560d30b8800b4c038?s=112&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/23f05fd9d6f1216560d30b8800b4c038?s=224&#038;d=mm&#038;r=g 2x' class='avatar avatar-112 photo' height='112' width='112' loading='lazy' /> </div>
<div class="data-content">
<h4 class="author-title">Colin Wilson</h4>
<div class="data-entry-content">
<p>Easy going, dislike negativity, and an optimist. I believe that amidst the hustle and bustle of everyday living, each day is a gift from God and if we stop and think about it, there is at least one thing for which we ought to be thankful. In addition, I believe that every day is a great day to be alive. No matter how bad we think we have it, there are any number of people who are on the "other side" who, if they could, would gladly trade places with us. Email me at <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="fc9f94898e9f9498899899bc93898890939397d29f9391">[email&#160;protected]</a></p>
</div>
</div>
</div>
<div class="vce-content-outside">
<div class="data-links">
<a href="https://jamaicans.com/author/colinwilson/" class="vce-author-link vce-button">View all posts</a>
</div>
<div class="vce-author-links">
</div>
</div>
</section>
<div class="main-box vce-related-box">
<h3 class="main-box-title">You may also like</h3>
<div class="main-box-inside">
<article class="vce-post vce-lay-d post-113534 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional tag-not-my-will tag-submission tag-surrender">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-not-my-will/" title="WEEKLY DEVOTIONAL &#8211; &#8220;Not My Will, But Thine, Be Done&#8221;">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/notmywill-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/notmywill-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/notmywill-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-not-my-will/" title="WEEKLY DEVOTIONAL &#8211; &#8220;Not My Will, But Thine, Be Done&#8221;">WEEKLY DEVOTIONAL &#8211; &#8220;Not My Will, But...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-83662 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional tag-devotional tag-god tag-psalm">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-god-is-no-mans-debtor/" title="WEEKLY DEVOTIONAL – God is No Man&#8217;s Debtor">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2015/03/devotion-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2015/03/devotion-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/03/devotion-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-god-is-no-mans-debtor/" title="WEEKLY DEVOTIONAL – God is No Man&#8217;s Debtor">WEEKLY DEVOTIONAL – God is No Man&#8217;s Debtor</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-107481 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional tag-determination tag-esther tag-if-i-perish">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-perish-perish/" title="WEEKLY DEVOTIONAL &#8211; &#8220;If I Perish, I Perish&#8221;">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2017/04/ruthperish-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2017/04/ruthperish-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2017/04/ruthperish-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-perish-perish/" title="WEEKLY DEVOTIONAL &#8211; &#8220;If I Perish, I Perish&#8221;">WEEKLY DEVOTIONAL &#8211; &#8220;If I Perish, I...</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-122723 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional tag-adversities tag-challenges tag-christian-faith tag-fear">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-does-jesus-care/" title="WEEKLY DEVOTIONAL &#8211; Does Jesus Care?">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/doesjesuscare-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="does Jesus care" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/doesjesuscare-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/doesjesuscare-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-does-jesus-care/" title="WEEKLY DEVOTIONAL &#8211; Does Jesus Care?">WEEKLY DEVOTIONAL &#8211; Does Jesus Care?</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-111085 post type-post status-publish format-standard has-post-thumbnail hentry category-weekly-devotional">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-refiners-fire/" title="WEEKLY DEVOTIONAL &#8211; The Refiner&#8217;s Fire">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/refinersfire-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/refinersfire-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/refinersfire-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-refiners-fire/" title="WEEKLY DEVOTIONAL &#8211; The Refiner&#8217;s Fire">WEEKLY DEVOTIONAL &#8211; The Refiner&#8217;s Fire</a></h2>
</header>
</article> <article class="vce-post vce-lay-d post-62150 post type-post status-publish format-standard has-post-thumbnail hentry category-jamaica-magazine category-weekly-devotional tag-devotional tag-god tag-psalm">
<div class="meta-image">
<a href="https://jamaicans.com/weekly-devotional-baring-the-soul/" title="WEEKLY DEVOTIONAL &#8211; Baring the Soul">
<img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2015/03/devotion-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2015/03/devotion-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2015/03/devotion-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /> </a>
</div>
<header class="entry-header">
<span class="meta-category"><a href="https://jamaicans.com/jamaica/jamaica-magazine/" class="category-276">Jamaica Magazine</a> <span>&bull;</span> <a href="https://jamaicans.com/jamaica/jamaica-magazine/weekly-devotional/" class="category-856">Weekly Devotional</a></span>
<h2 class="entry-title"><a href="https://jamaicans.com/weekly-devotional-baring-the-soul/" title="WEEKLY DEVOTIONAL &#8211; Baring the Soul">WEEKLY DEVOTIONAL &#8211; Baring the Soul</a></h2>
</header>
</article>
</div>
</div>
</div>
<aside id="sidebar" class="sidebar right">
<div id="search-2" class="widget widget_search"><form class="vce-search-form" action="https://jamaicans.com/" method="get">
<input name="s" class="vce-search-input" size="20" type="text" value="Type here to search..." onfocus="(this.value == 'Type here to search...') && (this.value = '')" onblur="(this.value == '') && (this.value = 'Type here to search...')" placeholder="Type here to search..." />
<button type="submit" class="vce-search-submit"><i class="fa fa-search"></i></button>
</form></div><div id="custom_html-9" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://miamicarnival.org?jamaicans-com">
<img src="https://news.jamaicans.com/wp-content/uploads/2021/09/Miami-Broward-Carnvial-2021.jpeg">
</a></div></div><div id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a href="https://jamaicans.com/vote-for-the-best-of-jamaica-2021-in-new-york-miami-jamaica-london-toronto-other-cities-worldwide/"><img src="https://news.jamaicans.com/wp-content/uploads/2021/09/Website-Banner-Vote-for-the-Best-of-Jamaica-2021-Abroad-copy.jpeg" /></a></center></div></div><div id="custom_html-5" class="widget_text vce-no-padding widget widget_custom_html"><div class="textwidget custom-html-widget"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1901173274277249" data-ad-slot="3218061934"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "250";
   medianet_crid = "966658449";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div></div><div id="rss-5" class="widget widget_rss"><h4 class="widget-title"><a class="rsswidget" href="https://jamaicans.com/videos/?feed=rss2"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://jamaicans.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://jamaicans.com/videos">Videos</a></h4><ul><li><a class='rsswidget' href='https://jamaicans.com/videos/watch-how-to-make-jamaican-guinness-punch-deddys-kitchen/'>WATCH: How to make Jamaican Guinness Punch! | Deddy’s Kitchen</a></li><li><a class='rsswidget' href='https://jamaicans.com/videos/a-meks-test/'>WATCH: How to make Jamaican Fried Dumpling!</a></li></ul></div><div id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="text/javascript" src="//ap.lijit.com/www/delivery/fp?z=406528"></script></div></div><div id="custom_html-7" class="widget_text vce-no-padding widget widget_custom_html"><div class="textwidget custom-html-widget">
<script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "600";
   medianet_crid = "526552473";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUN66J27' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div><div id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<script id='x33x15351354282617836'>
var Tynt=Tynt||[];Tynt.push('abWrx44JCr4z2Wacwqm_6r');
Tynt.cmd=Tynt.cmd||[];Tynt.cmd.push(function(){
Tynt.ads.display('300x250','x33x15351354282617836','inpage');});
(function(){var h,s=document.createElement('script');
s.src=(window.location.protocol==='https:'?
'https':'http')+'://cdn.tynt.com/siab.js';
h=document.getElementsByTagName('script')[0];
h.parentNode.insertBefore(s,h);})();
</script>
</div></div> </aside>
</div>
<footer id="footer" class="site-footer">
<div class="container">
<div class="container-fix">
<div class="bit-3">
<div id="mks_social_widget-2" class="widget mks_social_widget"><h4 class="widget-title">Socially Speaking</h4>
<ul class="mks_social_widget_ul">
<li><a href="https://www.facebook.com/onelovejamaica" title="Facebook" class="socicon-facebook soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>facebook</span></a></li>
<li><a href="https://instagram.com/jamaicans_com" title="Instagram" class="socicon-instagram soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>instagram</span></a></li>
<li><a href="https://twitter.com/jamaicansdotcom" title="Twitter" class="socicon-twitter soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>twitter</span></a></li>
<li><a href="https://www.youtube.com/user/outofmanyonline" title="YouTube" class="socicon-youtube soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>youtube</span></a></li>
<li><a href="https://jamaicans.com/?feed=rss" title="RSS" class="socicon-rss soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>rss</span></a></li>
<li><a href="https://www.pinterest.com/jamaicans/" title="Pinterest" class="socicon-pinterest soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>pinterest</span></a></li>
<li><a href="http://jamaicansdotcom.tumblr.com/" title="tumblr" class="socicon-tumblr soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>tumblr</span></a></li>
<li><a href="https://jm.linkedin.com/company/jamaicans-com" title="Linkedin" class="socicon-linkedin soc_circle" target="_blank" style="width: 47px; height: 47px; font-size: 16px;line-height:52px;"><span>linkedin</span></a></li>
</ul>
</div><div id="mailerlite_widget-3" class="widget widget_mailerlite_widget">
<div id="mailerlite-form_1" data-temp-id="61601e73eec00">
<div class="mailerlite-form">
<form action="" method="post">
<div class="mailerlite-form-title"><h3>Sign Up For Email Updates</h3></div>
<div class="mailerlite-form-description"><p>Join our newsletter to get the latest articles, news, &amp; videos.</p>
</div>
<div class="mailerlite-form-inputs">
<div class="mailerlite-form-field">
<label for="mailerlite-1-field-email">Email</label>
<input id="mailerlite-1-field-email" type="email" required="required" name="form_fields[email]" />
</div>
<div class="mailerlite-form-loader">Please wait...</div>
<div class="mailerlite-subscribe-button-container">
<input class="mailerlite-subscribe-submit" type="submit" value="Sign Up" />
</div>
<input type="hidden" name="form_id" value="1" />
<input type="hidden" name="action" value="mailerlite_subscribe_form" />
<input type="hidden" name="ml_nonce" value="3f80cda0dc" />
</div>
<div class="mailerlite-form-response">
<h4><p><span style="color: #339966;">Thank you for sign up!</span></p>
</h4>
</div>
</form>
</div>
</div>
<script type="text/javascript">
    window.addEventListener("load", function (event) {
        var jQuery = window.jQueryWP || window.jQuery;

        jQuery(document).ready(function () {
            var form_container = jQuery("#mailerlite-form_1[data-temp-id=61601e73eec00] form");
            form_container.submit(function (e) {
                e.preventDefault();
            }).validate({
                submitHandler: function (form) {

                    jQuery(this.submitButton).prop('disabled', true);

                    form_container.find('.mailerlite-subscribe-button-container').fadeOut(function () {
                        form_container.find('.mailerlite-form-loader').fadeIn()
                    });

                    var data = jQuery(form).serialize();

                    jQuery.post('https://jamaicans.com/wp-admin/admin-ajax.php', data, function (response) {
                        form_container.find('.mailerlite-form-inputs').fadeOut(function () {
                            form_container.find('.mailerlite-form-response').fadeIn()
                        });
                    });
                }
            });
        });
    }, false);
</script>
</div> </div>
<div class="bit-3">
<div id="vce_posts_widget-2" class="widget vce_posts_widget"><h4 class="widget-title">Random Jamaican Recipes</h4>
<ul class="vce-post-list" data-autoplay="">
<li>
<a href="https://jamaicans.com/non-pork-jamaican-stew-peas-recipe/" class="featured_image_sidebar" title="Miss G’s Simple Non-Pork Jamaican Stew Peas Recipe (Smoked Turkey)"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Miss-G-Simple-Non-Pork-Jamaican-Stew-Peas-Recipe-Smoked-Turkey-neck-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Miss G Simple Non-Pork Jamaican Stew Peas Recipe Smoked Turkey neck" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Miss-G-Simple-Non-Pork-Jamaican-Stew-Peas-Recipe-Smoked-Turkey-neck-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Miss-G-Simple-Non-Pork-Jamaican-Stew-Peas-Recipe-Smoked-Turkey-neck-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/non-pork-jamaican-stew-peas-recipe/" title="Miss G’s Simple Non-Pork Jamaican Stew Peas Recipe (Smoked Turkey)" class="vce-post-link">Miss G’s Simple Non-Pork Jamaican Stew Peas Recipe...</a>
</div>
</li>
<li>
<a href="https://jamaicans.com/jerk-tofu-recipe/" class="featured_image_sidebar" title="Jerk Tofu Recipe"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Jerk-Tofu-Recipe-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Jerk tofu" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Jerk-Tofu-Recipe-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Jerk-Tofu-Recipe-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/jerk-tofu-recipe/" title="Jerk Tofu Recipe" class="vce-post-link">Jerk Tofu Recipe</a>
</div>
</li>
<li>
<a href="https://jamaicans.com/jamaicas-ackee-and-saltfish-ranks-number-2-on-national-geographics-top-10-list-of-worlds-best-national-dishes/" class="featured_image_sidebar" title="Jamaica&#8217;s Ackee And Saltfish Ranks Number 2 On National Geographic’s Top 10 List of World’s Best National Dishes"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/Ackee-And-Saltfish-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Ackee And Saltfish" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/Ackee-And-Saltfish-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/Ackee-And-Saltfish-300x209.jpg 300w, https://jamaicans.com/wp-content/uploads/Ackee-And-Saltfish-768x535.jpg 768w, https://jamaicans.com/wp-content/uploads/Ackee-And-Saltfish-810x565.jpg 810w, https://jamaicans.com/wp-content/uploads/Ackee-And-Saltfish-380x260.jpg 380w, https://jamaicans.com/wp-content/uploads/Ackee-And-Saltfish.jpg 829w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/jamaicas-ackee-and-saltfish-ranks-number-2-on-national-geographics-top-10-list-of-worlds-best-national-dishes/" title="Jamaica&#8217;s Ackee And Saltfish Ranks Number 2 On National Geographic’s Top 10 List of World’s Best National Dishes" class="vce-post-link">Jamaica&#8217;s Ackee And Saltfish Ranks Number 2 On...</a>
</div>
</li>
<li>
<a href="https://jamaicans.com/chef-sians-conch-salad-recipe/" class="featured_image_sidebar" title="Chef Sian&#8217;s Conch Salad Recipe"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2016/09/conch-salad-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2016/09/conch-salad-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2016/09/conch-salad-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/chef-sians-conch-salad-recipe/" title="Chef Sian&#8217;s Conch Salad Recipe" class="vce-post-link">Chef Sian&#8217;s Conch Salad Recipe</a>
<div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/chef-sians-conch-salad-recipe/#respond"><span class="dsq-postid" data-dsqidentifier="98661 http://jamaicans.com/?p=98661">Add Comment</span></a></div></div>
</div>
</li>
<li>
<a href="https://jamaicans.com/9-recipes-will-make-jamaican-man-forgive/" class="featured_image_sidebar" title="9 Recipes that Will Make A Jamaican Husband/Man Forgive Anything"><span class="vce-post-img"><img width="145" height="100" src="https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Ackee and Saltfish" loading="lazy" srcset="https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-145x100.jpg 145w, https://jamaicans.com/wp-content/uploads/2017/02/Ackee-and-Saltfish-recipe-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
<div class="vce-posts-wrap">
<a href="https://jamaicans.com/9-recipes-will-make-jamaican-man-forgive/" title="9 Recipes that Will Make A Jamaican Husband/Man Forgive Anything" class="vce-post-link">9 Recipes that Will Make A Jamaican Husband/Man...</a>
<div class="entry-meta"><div class="meta-item comments"><a href="https://jamaicans.com/9-recipes-will-make-jamaican-man-forgive/#respond"><span class="dsq-postid" data-dsqidentifier="100257 http://jamaicans.com/?p=100257">Add Comment</span></a></div></div>
</div>
</li>
</ul>
</div> </div>
<div class="bit-3">
 </div>
</div>
</div>
<div class="container-full site-info">
<div class="container">
<div class="vce-wrap-left">
<p>Copyright © Simbis Inc. All rights reserved. <a href="https://jamaicans.com/privacy/">Privacy Policy &amp; Terms of use</a>. Stock Photos from Photos.com, iStockPhotos.com, 123rf.</p> </div>
<div class="vce-wrap-right">
<ul id="vce_footer_menu" class="bottom-nav-menu"><li id="menu-item-76837" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76837"><a href="http://www.jamaicans.com/forums/">Forums</a></li>
<li id="menu-item-145195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145195"><a href="https://jamaicans.com/free-email/">Free Email</a></li>
<li id="menu-item-76836" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76836"><a target="_blank" rel="noopener" href="https://amzn.to/2JueBog">Shopping</a></li>
<li id="menu-item-459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-459"><a href="https://jamaicans.com/our-contact/">Contact</a></li>
<li id="menu-item-526" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-526"><a href="https://jamaicans.com/about-us/">About Us</a></li>
<li id="menu-item-77011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77011"><a href="https://jamaicans.com/advertise-with-us/">Advertise</a></li>
</ul>
</div>
</div>
</div>
</footer>
</div>
</div>
<a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://jamaicans.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "d543b90f16", post_id : 153029 } ); } ); /* ]]> */</script>
<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":"300"}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":6,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"services":"facebook,twitter,email,pinterest_share,whatsapp,addthis","elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":6,"counts":"one","size":"32px","style":"fixed","shareCountThreshold":0,"services":"facebook,twitter,email,pinterest_share,whatsapp,addthis","elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post-arch-page,.at-above-post-cat-page,.at-above-post,.at-above-post-page"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-bf34677b4718a8fdb8e7d271cfbb868e","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=wp-bf34677b4718a8fdb8e7d271cfbb868e" async="async"></script><script type='text/javascript' id='google_cse_v2-js-extra'>
/* <![CDATA[ */
var scriptParams = {"google_search_engine_id":"partner-pub-1901173274277249:8952111638"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/wp-google-search/assets/js/google_cse_v2.js?ver=1' id='google_cse_v2-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/meks-flexible-shortcodes/js/main.js?ver=1' id='mks_shortcodes_js-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' id='vce-main-js-extra'>
/* <![CDATA[ */
var vce_js_settings = {"sticky_header":"1","sticky_header_offset":"200","sticky_header_logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/08\/final-logo-abbr.png","logo":"https:\/\/jamaicans.com\/wp-content\/uploads\/2015\/01\/jamaicans_logo.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"https:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","ajax_wpml_current_lang":null,"ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"1","full_slider_autoplay":"","grid_slider_autoplay":"","grid_big_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"0","top_bar_mobile_group":"1","top_bar_more_link":"More"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/themes/voice/assets/js/min.js?ver=2.9.9' id='vce-main-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/meks-easy-social-share/assets/js/main.js?ver=1.2.6' id='meks_ess-main-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/js/jquery.validate.min.js?ver=3d7ea3ee90d29ec8a70d43d3557ce3db' id='jquery-validation-plugin-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/wp-review/public/js/js.cookie.min.js?ver=2.1.4' id='js-cookie-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' id='wp-util-js-extra'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/wp-util.min.js?ver=3d7ea3ee90d29ec8a70d43d3557ce3db' id='wp-util-js'></script>
<script type='text/javascript' id='wp_review-js-js-extra'>
/* <![CDATA[ */
var wpreview = {"ajaxurl":"https:\/\/jamaicans.com\/wp-admin\/admin-ajax.php","loginRequiredMessage":"You must log in to add your review"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/wp-review/public/js/main.js?ver=5.3.5' id='wp_review-js-js'></script>
<script type='text/javascript' id='fca_pc_client_js-js-extra'>
/* <![CDATA[ */
var fcaPcEvents = [];
var fcaPcDebug = {"debug":""};
var fcaPcPost = {"title":"WEEKLY DEVOTIONAL - Our Ultimate Source","type":"post","id":"153029","categories":["Weekly Devotional"],"utm_support":"","user_parameters":"","edd_delay":"0","woo_delay":"0","edd_enabled":"","woo_enabled":"","video_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/facebook-conversion-pixel/pixel-cat.min.js?ver=2.5.7' id='fca_pc_client_js-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-content/plugins/facebook-conversion-pixel/video.compiled.js?ver=3d7ea3ee90d29ec8a70d43d3557ce3db' id='fca_pc_video_js-js'></script>
<script type='text/javascript' src='https://jamaicans.com/wp-includes/js/wp-embed.min.js?ver=3d7ea3ee90d29ec8a70d43d3557ce3db' id='wp-embed-js'></script>
</body>
</html>
